Running Script gives a different output than typing commands

When I run the script:
I get a message that says “This provokes no reaction.”.

when I run the individual commands by typing each one the game works.
this is under 6G60.

Room 1 is a room.

a man called the Cop is in Room 1.

instead of telling the Cop about “thief”:
if the thief is unspotted:
say “You tell the cop you were roobed but you didn’t get a good look at the robber. He promises to help find the thief.”;
otherwise if the thief is spotted:
say “The cop tells you that the thief was caught.”

Room 2 is east of Room 1.
a man called Mike is in Room 2.
instead of asking Mike about “thief”:
now the thief is spotted;
say “He was spotted in a nasty area of the city.”.

there is a man called the thief.
the thief is either spotted or unspotted.

test me with “Tell cop about thief/east/ ask mike about thief/west/tell cop about thief.”.

The extra period at the end of “tell cop about thief.” makes the difference. I suppose it means that the text no longer matches “thief” and therefore fails to trigger the rule.

I took the period out and it still does the same thing.

Just to be clear, you need to take out the period before the end quote mark, not the one after. Doing that makes it work for me.

Yes I did that. and you are correct. My code was somehow messed up but now it’s working again.

thanks for the feedback