Request for the comp organizers

Over here – – provides handy links for downloading the interpreters “Z-code and Glulx and TADS.” I actually went back to that page cause I can’t get an offline Adrift title running. Could the organizers stick some more links up there?

Neither my Gargoyle (either of them) nor my Zoom is working. Adrift uses a separate program to run those games, yes? (See, I was hoping the comp page would’ve had all the answers.)

EDIT TO ADD: it seems doubly odd because TADS hasn’t been the #2 system for a couple of years now, IIRC.

I don’t think there is a working OS X interpreter for Adrift 5 games at the moment, so you’ll need to play Return to Camelot online (or on a PC).

I was aiming at Curses.

And: crappola. But thanks for the quick reply.

Hey waitaminute, if Adrift is Windows-only, then why do both my terps purport to support them? Oh, Curses is v5 and the terps are v4, right? Bother. Thanks again.

Have you tried Spatterlight? I played How Suzy Got Her Powers in Spatterlight – it didn’t display perfectly, but I was able to complete the game.

When I try to launch The Ascot in Zoom I get this:

which makes me think Zoom thinks it supports ADRIFT (SCARE is the ADRIFT terp that Spatterlight uses), but it don’t.

EDIT: I think both Suzy and Cursed are ADRIFT 4. David Whyld might be able to tell us if running Suzy under SCARE introduces bugs beyond the display thing.

I successfully played the Alan game and the two ADRIFT 4 games in Gargoyle on Mac OS X (they didn’t work in Zoom and I didn’t try Spatterlight, as it’s kind of old and creaky); the ADRIFT 5 and the Quest game I played online. Everything else was either web-based or worked fine for me in Zoom, which remains my default interpreter.

So possibly if you’re not getting ADRIFT 4 to run in your Gargoyle, that means you need to update its plug-in for ADRIFT? I’m not sure, but my Gargoyle was a fresh download for the comp and needed no further modification to deal with those two.

The ADRIFT games should run in Gargoyle and Spatterlight. I don’t think I’ve ever seen Zoom play an ADRIFT game correctly, though… whether it’s not displaying variables correctly, changing display, or just plain not functioning… maybe it’s no longer supported? I dunno.

Just checked games on Spatterlight and they seem to work, though.

If you are unable to get them to run on anything else, WebRunner now does a much better job of running v4 games than when the comp began. I’ve also released a new v5 download which handles the same.

As for the Mac, if you have Mono installed the Linux version may well run on this, but I haven’t had the opportunity to check.

Well if Em got that game running in Gargoyle without problems, I gave re-downloading it a try. Now, even though the one I downloaded has the same time & date stamp as the one already on my system, it works and the previous didn’t. How weird is that?

Anyway, thanks gang.