Renamiing a Project (TADS3, using Workbench)

I have re-named my game, and I have gone through all the files that refer to the OldName and changed every reference to NewName, including all the header files, etc.

The game compiles just fine, but it still creates an OldName.t3 file in the debug directory.

A global search of all the project files does not turn up the word OldName anywhere.

I guess the OldName word must be embedded in workbench somewhere, but I can’t find out where.

Can anyone help?

Thanks!

–Bob

Did you search through the Makefile? I’m not using Workbench often, but I thing it’s the same as when compiling without Workbench. Try to find parameter -o in the Makefile.t3m or how the makefile is called.

There is a file called Newname.t3m that I can edit with Notepad, and I have included the line
-o Newname.t3

But there is a notice at the top of the file that says:

TADS 3 makefile

Warning: this file was mechanically generated. You may edit this file

manually, but your changes might be modified or discarded when

you load this file into a TADS development tool. The TADS tools

generally retain the comment at the start of the file and the

comment marked “##sources” below, but other comments might be

discarded, the formatting might be changed, and some option

settings might be modified.

And indeed, after I compile the game, it still creates a file called Oldname.t3 in the \debug directory.

Interestingly, when I do compile the game, the following message appears. (Color added)

----- begin build: Thu Feb 04 15:24:16 2016 -----

t3make -Fy “E:…\DEV\obj” -Fo “E:…\DEV\obj” -o “debug\Oldname.t3” -a -D “LANGUAGE=en_us” -D “MESSAGESTYLE=neu” -v -d -statprefix <@> -statpct “system.tl” “adv3\adv3.tl” “Debug.t” … -res “GameInfo.txt”
TADS Compiler 3.1.3 Copyright 1999, 2012 Michael J. Roberts

So somehow, even if I manually edit the .t3m file, Workbench has a setting someplace that is remembering Oldname.

–Bob

Did you change the name of the Project file itself? When I compile a game in Workbench, the interpreter window shows my new name, but the t3 file in the debug directory is still named after the project file.

I don’t know where to do that in Workbench. Do I need to do it outside of Workbench in the DEV directory itself? Or possibly in the debug directory?

(I renamed Oldname.t3m to Newname.t3m in the DEV directory, but I’m still getting Oldname.t in the debug directory.)

By golly, you’re right. At a guess, there’s no Save Project As… command in the File menu because it would be non-trivial. The user would have to decide whether to copy the source files to a new directory or use the existing source files. All sorts of file pointers, etc.

But it’s not difficult, really. Just create a new project but (if you prefer to do so) put it in the same directory as the old project – that is, create NewProject.t3m, but put it in the OldProject folder. Then delete NewProject.t from the Source files and add all of your existing source files by right-clicking on the Source Files folder in the Project Browser. (You’ll have to drag new files down below the library files.)

When I do this, the new _dbg.t3 file doesn’t seem to go into the debug folder; it seems to get parked int the main folder. Not sure why.

A better solution, then, is to put NewProject in its own folder while creating it, manually copy the source files into that folder, and then add them to the project.

That should solve the problem.

It’s in the Build Settings. Click on the Build menu -> Settings, then Output in the list on the left. You’ll probably want to change all three of the file names here, but the one for the debug build is the first one.

buildsettings.png

My thanks to all of you! Emily’s last email did the trick! --Bob