Raygun Diplomacy, an interactive pulp SF short story

Hey good people,

I’ve finally finished the project I’ve been working on for the past month or so, and would love some feedback from people who actually know what they’re doing :slight_smile:

The story is set on Mars – Old Mars, the one with air, and (some) water, and Martians; it features four endings (well, two, with a slight variation for each), a bunch of people that can be spoken to, and not a lot of puzzles.

You can get it here: Raygun Diplomacy by Reason: Optional


Oh, I will take a look.
Welcome to intfiction, thanks for your work and for sharing it.
By the way the interpreter for Android is not Fdroid but Fabularium. Googleplay is outdated, you can link to latest release to Fdroid or via ifwiki.

1 Like

By the way the interpreter for Android is not Fdroid but Fabularium

Updated the link and text, thank you :slight_smile:


Congrats on your game.

I only just noticed the “play in browser” option. Perhaps make this more prominent.

Also, not sure if this is a browser issue, game issue or system issue, but when you type something that it doesn’t understand, eg > dance, there’s a noticeable delay in responding.

1 Like

Hi, thanks for your comment!

I’ve made the link bolder, and it’s now more visible.

As to the other thing, it’s most likely a game issue – it’s slow on my machine as well, in browser and in both Lectrote and Gargoyle. Unfortunately, I have no idea how to fix that; any ideas are more than welcome.

1 Like

I tried playing this game a bit today and got really stuck. I was able to get myself unstuck by reading the source text a little bit, but I got stuck again, and can’t get unstuck even after reading the source.

First, a bug: The Well-tended Avenue doesn’t mention that it has an exit to the south. I had to check the source text for that.

Second, I think it’s confusing that I can’t go into the Wilderness until I’ve seen the probe and told Roderick about it. The game just says, “I didn’t want to get lost in the wilderness” when going north from Weed-Choked Street, which sounds like a “You can never go this way” message, not “You can’t go this way yet.” He doesn’t say that the probe is in the Wilderness, so I had no reason to return to check the Wilderness in particular.

OK, so, I found the cargo pod, got the orders, gave the orders and the tape to Roderick and … nothing else happens. I’m stuck.

The source text implies that there’s a “Winding Road” east of “Narrowing Street” that will lead me to a bunch of Martians to interact with, but when I try to go that way, it just says, “I took a long look at the road snaking downwards. The road sure was long. I looked again. I decided that if the probe was anywhere that way, it would have to damn well take its chances.”

More broadly, I recommend writing out hints for this game. (I prefer them in Invisiclues style, so the player can gradually reveal the hints, and so we can understand how the player was supposed to solve the puzzles, but it’s easier to just write a walkthrough.)

Other feedback: why am I taking orders from Roderick, anyway? Why am I, a linguist, looking for the probe? Wouldn’t it make more sense for me to look for Arnaud and to tell him to look for the probe and/or the cargo pod?

EDIT: Ah, I see it now, I’m supposed to give the tape to Giftig, not to Roderick. But if you give the tape to Roderick, it’s gone forever, and the game can’t be completed.

And… apparently I’m allowed to go east from Narrowing Street when Giftig has the tape and Roderick has the orders. But how was I supposed to know that? Nobody gives me a mission or reason to go that way. It all just feels really unmotivated.

1 Like

Thank you for the feedback, I’ll make sure to update everything, and prevent giving things to people who have no use for them.

1 Like

I have updated the game file, with a whole new chapter of responses to people being given things (I really hope I haven’t forgotten about anything), a few new responses, and the protagonist’s motivation made a bit more clear.

Again, thank you for pointing those things out :slight_smile:

1 Like

More bug reports:

  • Missing exits
    • Well-tended Avenue still doesn’t mention the exit south.
    • Palace Entrance doesn’t mention the exit north. (It implies that there’s an entrance “deeper” but you have to guess which way.)
  • I think you should be allowed to wander the Wilderness immediately after finding the probe; you shouldn’t have to report all the way back to Roderick just to be allowed to check out the Wilderness.
  • After finding the probe but before returning the orders and tape, when trying to go east from Narrowing Street, the message says, “I took a long look at the road snaking downwards. The road sure was long. I looked again. I decided that if the probe was anywhere that way, it would have to damn well take its chances.” That’s a bad message; I know exactly where the probe is. Furthermore, I presumably am well aware that Gharraz is that way, and that I ultimately want to go there. I think the message should say something like, “That’s the way to Gharraz, but I’m not supposed to go there until I complete my current mission.” Perhaps a special message is required when you’ve found the probe but not yet found the cargo pod. Maybe Arnaud is there and won’t let you past until Roderick gives you permssion…? And add a message, “Hopefully the cargo pod isn’t that way” or something.
  • Examining a missing noun like examine asdf gives the wrong message, “That’s not a verb I recognize.”
  • Missing synonyms for the Martians, even when explicitly referenced in the text.
    • In Large Square, examine peddler says “That’s not a verb I recognize.” You have to say fruit peddler.
    • Similarly on Poor Street, talk to martian “That’s not a verb I recognize.” I could only get it to work by saying man.
  • When talking to the bronzesmith, I got this suggestion: “I could have asked about what she thought of an Earth colony or asked about what he thought of an Earth colony.” (Not sure how to reproduce it.)
  • Let me take the uniform before meeting the bronzesmith. (Why not?)
  • When speaking with Lan Kar, you tell about Song of Toil instead of asking about it. But then the conversation feels more like asking.
  • I wish it were possible to GO TO AIRLOCK or GO TO EMBASSY in this game. It’s suuuuch a long walk back to the embassy.
  • The game doesn’t make it clear enough that you need to return to the Administrative Office. When you’ve heard the last song, the game should include a message like, “That’s enough songs. I should go back to the office and write all this down,” or something. (I only figured it out by reading the source.)
  • In the event of diplomatic failure, if you immediately go to Roderick immediately after writing your manuscript, the game suggests telling Roderick about the coming attack, even if you’ve never attempted to return to Gharraz.
  • I think it’s too easy to get a diplomatic failure. If you just ask/tell everyone about the colony, (i.e. if you use all of your conversation options,) all of the Martians get mad, and you lose. At the very least, the game should warn you against talking about the colony before you do it!
  • I also think it’s too “hard” (in the sense of mindless busywork) to get diplomatic success. To make Dar Xan happy, you have to talk to Dol Tan and Lan Kar first. In practice, that forces you to run around this very large city talking and re-talking to everybody, to see if earlier conversations have unlocked later conversations. I think instead the game should clearly say, “now you can tell someone about the opportunity.”
  • I mentioned that this game would benefit from hints, but I specifically think it would benefit from a GOALS command, like in Counterfeit Monkey. What am I trying to do right now?
1 Like

So, based on the feedback received so far:

  • I’ve implemented a “go to [any visited location]” command
  • Am halfway through checking all room for missing exit descriptions
  • Am thinking that maybe 70 rooms are a bit too many
  • Added some missing synonyms (including calling all Martians, Martians)
  • Wrote no-can-do actions for giving things to people who don’t need them
  • Am rewriting a whole bunch of dialog, to make everybody’s goals more clear
  • Am investigating a hint system
  • Am trying to get rid of some busy-work

An updated version will follow sometime next week.

Again, many thanks for your feedback, Dan!

1 Like