Quixe 2.1.0

I think I’m doing everything right (the images got extracted from the blorb etc) but, still, they don’t show.

Is this compatible with Emily Short’s Simple Graphical Window and Location Images?

EDIT: Nope, the thing works (I’ve tried the link in the Quixe page, here: eblong.com/zarf/glulx/quixe/, and it works).

Maybe it has something to do with the fact that, apparently, Inform is still using Quixe 1.x.x (as stated in “play.html”)?
Also: the folder “Templates” was not there under my Library/Inform folder. Could this be the problem?

Thanks a lot for the help.

Could you be more specific about what you are trying to do?

Which version of Inform are you using?

First of all, because I know how much appreciation is important in life and how much it is forgotten, I would like to state officially how EASY life is in the IF scene thanks to people like you, zarf. I don’t think any other place is as noob-friendly as this one.

Second: I think that the chain is broken in MY MIND and not in your work.

What I do, following the instruction on the Quixe page: 1) extract Quixe into a /Templates folder in /Library/Inform (note: there is no Template folder until I make one, so the original Quixe 1 materials must be somewhere else). 2) I Release along with an interpreter. 3) I run the python script you made. Up to now, to no avail. This (I suppose) because the game is still released with Quixe 1.

The game works if I upload it somewhere (note: the extension can be .whatever. I used .zip or my Wordpress uploader rejects the file) and use the link in the Quixe page. So it has nothing to do with Emily’s extensions.

What I want to do is simply have a game with the Graphical Window and Location Images to show images. So that I will be able to run it from here: andromedalegacy.com as I did for the graphic-less games.

Last note: Yes, I know I have to add copyright details for Quixe on the website. The credits page is under construction.

PS: I’m using Inform7 1.54 which is the second to last (thanks to these days add) version.

The secret is always hidden in daylight. So the secret seems to be: do NOT work on code after 1AM.

Ok, I used mulehollandaise trick and it worked at first try. The sequence listed on the message above, though, still doesn’t work. I think I’m missing something. But NP. The game’s up and running (on my desktop) at the moment.

If you need further info on how I fucked up when trying to have all work from Inform, feel free to ask. Hope I did not waste your time.

If it’s working, good.

Yes, the Inform application comes with a built-in Quixe template. You override this by creating a Quixe directory in ~/Library/Inform/Templates, or in the .materials folder.

Yes. Quixe did not have any image capabilities until 2.1.

you can check The result here: andromedalegacy.com/A1983/play.html

Looking slick! I guess that Quixe doesn’t allow you to use your custom font, though, huh?

Did you have to do any changes in-game to make the background black, or is it CSS?

Quixe actually lets you do anything because it’s all CSS. I used a Google font to spare me some time but could have turned the custom font into a webfont and made it work. Turns out there is this bitmap typeface so I thought “why not?”.

Everything is CSS. I never tried Glulx coloring features because I see they can be easily overridden. Now I’d like to find a way to remove the white bar under the location image: can’t seem to find the appropriate style anywhere.

One last topic I’m working on is making the #gameport or #windowport large an exact number of pixels*, but I need my web developer at the studio for that :slight_smile:

*A1983’s images are large 900px, so I guess it won’t be a problem on any computer made since the Nineties.

Actually, I have overriden the Glulx coloring features and the result is that every game which has the default colour scheme shows my colours, and every game that uses extra colours overrides my settings. I like this, because it ensures that I’m seeing what the author intended - and I still get to keep my own colour scheme when the author didn’t set anything. This may be behaviour you find acceptable.

Maybe this is not how Gargoyle works? I don’t know. But the main (dedicated, sort-of-official) Glulx interpreters for Windows, WinGlulxe and WinGit, do work this way. It’s most pleasing.

You can try this out with the Glulx ports of Rod Pike’s “Dracula”. I’ve got my terp quite customised, and yet when I load those games I get treated to old-school colour bliss. Dunno how it’d work with a customised Gargoyle.

I’d just like to point out that you’ve had to customise Gargoyle to ensure the game’s colours display well on Gargoyle, and you’ve had to CSS to ensure the game displays well on web browsers… and made no provisions for any other interpreters, which will therefore definitely not show the colour scheme you intend. Whereas if you’d used the Glulx colouring features (AND supplied the Gargoyle file as some users may have overridden their default colour scheme) the game would look more consistent throughout systems.

Finally, in the end, if your colour scheme is bad on my eyes (yours isn’t, but hypothetically) I’ll do everything I can to change it, and if I can’t, I won’t play the game. So… the player being able to override your colour scheme is A Good Thing (Lazzah would disagree over this - Axe Of Kolt, Adrift version. I ended up disabling fancy colours on my terp for that game because it was hurting my eyes). Stopping the player of doing this by alternative methods is usually self-defeating.

In this case, it’s definitely self-defeating, because you’ve ensured only two interpreters will display the colours you want - Gargoyle and a web browser running Quixe. WinGit, WinGlulxe, iFrotz, the Glulx-running Android apps, Mac terps… those are guaranteed to show the colour scheme you didn’t want.

I’d like NOT to hijack this thread as usual, so we can skip this or take it somewhere else.

Anyway: thanks for the insight: you made a point.

Too bad, typography size or shape cannot be decided in Glulx, just colors. So I still need CSS for a web-playable game. Or an .ini file for Gargoyle or whatever. That’s why I love Quixe: full customization, not just colors, no user-interaction needed and a single layout for everybody.

I’m pretty sure typography was decided at times when the computer displays were faaaaaaar smaller than the ones we have nowadays. So it always results in being too small, unless you really find comfortable having to stand one inch from the monitor to read :slight_smile: This kind of change can’t be made inside Glulx, so using features from the inside may just be double work.

Will look at it, anyway. But color is not my priority, as much as typography is.

You can specify font sizes in Glk, but support for it is not good. WindowsGlk does, but Gargoyle doesn’t.

That said, you shouldn’t try to change a user’s default font size too much - they will have it set to whatever font size feels best for them. But it could be okay to petition the interpreter makers to increase their font size.

I think casual gamers just take the various interpreters as they are, not fiddlying too much with preferences. Experienced users know how to change things easily. No?

To be fair, I brought it up in the actual game’s announcement thread. You just never responded. And it seemed relevant to bring it up here, as it sort of came up.


That’s because the terps take the most of the workload. That is a good thing! You don’t know what size screen your games will be played in, what resolution. You definitely do NOT want to hard-code a resolution. Photopia and Narcolepsy were written in the days of 640x480 and 800x600, and they come bundled with a configuration file that handily ensures the terp displays at its best setting… but try using that configuration on today’s 1440x900 resolutions!

With typography, it may be best if Glulx allows for relative changes - allow the writer to set a “smaller font size” for effects. Even that may be courting problems, but it’d be better than anything absolute.

As to the shape of typography, I don’t think it ever really came up, but as a totally lay non-programmer person I would actually like seeing games with spiffy fonts. As long as I could turn them off if they were unreasonable.

Sure you do. My point is, be smart: use built-in capabilities for everything you can to ensure maximum compatibility, and then use those .ini files (and .cfg files, too - I told you what you could put in the .cfg so that Windows users, which do exist despite your dislike of the system, make sure to also see your font. You really think even an advanced user is going to go through the trouble to change his preferences just for this one game, to reset them to their favourites after he’s done?) for the things that aren’t built-in.

On the contrary, not using them at all seems to me to be half-work.


I have been trying to use blorbtool.py and am following all your steps, however it keeps giving me an error saying, “This does not appear to be Blorb file”. I do have a blorbed glulx game with an extension of gblorb and I have ensured that I am feeding the correct location of the blorb file. Can’t figure out what might be going wrong.
Any help will be appreciated.

I’m not entirely sure what you want to do, but if you are just trying to make Quixe display graphics in a game made with the latest version of Inform, these steps should work.

Yes, I have been trying to include graphics in a playable webpage in a game made with the latest version of Inform. The name of the game does not include spaces. But still I am getting the following error:
“Exception: This does not appear to be a Blorb file.”
I am still not sure why this is happening. The name of my game includes an underscore though. I have even tried including quotation marks, but it did not help. Is there any other thing which might be wrong?


How did you create the Blorb file? If you try the process with different Blorb files, is the result the same?

If you don’t want to share the problem file, perhaps you could make a small test Blorb with an image and upload it?

I just used the default release option which was set to glulx and I checked the box to create a blorbed file automatically in inform 7. I am trying to display the image constantly on my screen and so can only use the glulx format.
As I am a new user, this portal is not allowing me to upload stuff. But I am pasting my test code:
“Test1” by Sanya

Include Simple Graphical Window by Emily Short.
Include Glulx Entry Points by Emily Short.

Part 1 - Setting up things

Release along with cover art, an interpreter, an introductory postcard.

Figure flower room is the file “flower.jpg”.

[Set up the simple divided screen]
The graphics window proportion is 75.
The graphics window position is g-above.
The graphics background color is g-medium-grey.
The currently shown picture is Figure flower room.

Rule for starting the virtual machine:
now the current graphics drawing rule is the standard placement rule.

Every turn:
follow the current graphics drawing rule;
now the currently shown picture is Figure flower room;

[Seed the random number generator]
When play begins:
seed the random-number generator with 1234.

Part 2 - The Setting

flower room 1 is a room.

I am attaching a link to the pictures that I used:


[flower] (https://images.unsplash.com/photo-1533467915241-eac02e856653?ixlib=rb-1.2.1&ixid=eyJhcHBfaWQiOjEyMDd9&auto=format&fit=crop&w=1000&q=80)

Thanks again.

Also, in case I am not able to use blorbtool, could anyone let me know how to manually update the resourcemap.js file. What is the image key and where can I find that information from. Also, besides manually updating the resourcemap.js file, would I need to do anything else to include graphics in a playable webpage? I would really appreciate if anyone could share what a completely filled up resourcemap.js file looks like.

Sorry for not getting back to you.

I was able to run the blorbtool.py command on your test game after compiling it with Inform 7 6M62, but I had to change the line

The graphics background color is g-medium-grey.


The graphics background color is "$808080".

in order to make it build, and I think that means you are using an older version of Simple Graphical Window (and Inform?).

The updated resourcemap.js would look like this:

/* resourcemap.js generated by blorbtool.py */
StaticImageInfo = {
1: {
  "image": 1, 
  "url": "interpreter/pict-1.jpeg", 
  "width": 1000, 
  "height": 667
3: {
  "image": 3, 
  "url": "interpreter/pict-3.jpeg", 
  "width": 1000, 
  "height": 667

Hope that is any help at all!