PUT ALL INTO... There are none at all available!

Continuing the discussion from >DROP ALL … What do you want to drop those things in?:

This part made me wonder about those verbs so I tried it out (after checking that the DROP ALL thing worked!)

>drop all
You don't have anything to drop.

>put all into bench
There are none at all available!

This seems to fix it, based on something I use for “GET/TAKE ALL” (which I probably picked up here):

Rule for printing a parser error when the latest parser error is the nothing to do error and the player's command includes "put all" or the player's command includes "insert all":
	say "You are not carrying anything." instead.


>put all into bench
You are not carrying anything.

I’m adding this potential solution here as I wonder whether there is a better way :slight_smile:


Thanks! There was more relevant code in the source to Counterfeit Monkey, but I didn’t need it as there’s really nothing to put or insert in my game (and the “what do you want to put/insert those things in?” response makes a bit more sense than when trying to drop everything).

Thanks, I see now… there is some code for “insert all into” which presumably is also dependent on a lot of other Counterfeit Monkey-specific code!

1 Like