Puny Seeds


“Which treasure chest do you mean? PunyJam#3 or SeedComp?”

I’m a little overwhelmed by the amount of great-sounding games that are suddenly up for play. I will do my best to spread lots of loving attention around.

  • PunyJam has nine games that were whipped together by intrepid authors in just three weeks. All games are required to start in/at an airlock. I expect a lot of spaceships and submarines. (Maybe someone has thought of a CDC-quarantined building with an infectious disease?) → Submissions to PunyJam #3 - itch.io

  • SeedComp presents nineteen games sprouted from the seeds we planted. I’m very excited to explore the garden! I’ve sown a few rather straightforward grains myself, and I’m particularly interested what the more vague or abstract seeds (poems, pictures, music,…) have inspired → Submissions to SeedComp! - Sprouting Round - itch.io

My intention is to switch back and forth between the two Jams, playing games back to back from each. (Let’s see how long that holds up…)
This thread will be for impressions and feedback. I’ll be posting (perhaps edited and/or expanded) reviews to IFDB for some games too.

I’m now nearing the end of A1RLOCK. A great game to kick off this Jam-run indeed! More thoughts on that soon.

  • A1RLOCK -(PunyJam)-

This is a game which takes a tried and true adventure setup and squeezes the best out of it.
You wake up disoriented and amnesiac in an underwater base. Some kind of catastrophe has all but destroyed the place and it seems everyone has fled, leaving you alone.

The map is small but challenging. With a few crooked passages and bending corridors, the surroundings take on an eerie and ever so slightly disorienting feel. The locked doors (or functional equivalents thereof) serve their purpose well, guiding the player through the base until she has found what needs to be discovered.

Puzzles are common sense and straightforward. A few could be better clued, and I missed alternate commands for the necessary actions and reasonable synonyms for some important items.

A1RLOCK has a dark atmosphere. (The child-protagonist lightens the mood considerably here and there, for instance when she Pew! Pew! Pew!-shoots a staple gun at random objects.)There is always the suspense of some gruesome revelation just around the corner. This feeling of expectation keeps growing until it is finally resolved in the final confrontation.

I’ll be honest, it needs work. But even with insufficient polish and uneven implementation, I found myself thoroughly engaged. A splendid start for my PunySeed adventure. A1RLOCK sets the bar high.


Mah. I don’t like itch.io-based comps, because I evaluate itch.io as a site too “nosy”… but I’ll watch the proceedings of itch.io comps, anyway.

Best regards from Italy,
dott. Piergiorgio.

  • In a Tomb with a Donkey -(SeedComp)-

Curiosity got the better of me. I just had to know what @dee_cooke had done with my donkey seed.

Um… Moving on…

Unavoidably, I am biased since I wrote the seed that inspired the game. However, there’s no need whatsoever to suppress any laudative exclamations I might exhort about In a Tomb with a Donkey. The obvious quality of the game can easily stand up to any bias.

After an exposition-filled introductory sequence, where commands are heavily telegraphed to keep up the tempo, our protagonist Evidence Sweet (doesn’t that have a lovely Pratchetty ring to it?) ends up locked in a tomb with, I kid you not, a donkey. In Egypt. About 3000 years ago.

While there is a whole range of IF games where finding out the backstory of the main character is the whole point, here it is but a very enjoyable side-effect of the important quest: find the way back home. Home being present-day England. Where Evidence was bumped back in time by… Nevermind. You’ll see for yourself.

A fair amount of puzzles are common sense hands-on manipulation of objects. Where it gets interesting though is the application of your set of magic spells. An increasing set, as you explore the tomb and uncover more enchantments for more diverse tasks.
Now, having control over a diverse collection of spells invites unlimited free experimentation. (Hands up: who wants to see a donkey floating in the air, wide-eyed and baffled? I thought so.) A postcomp version would benefit greatly from granting Evidence more freedom to enchant just about everything in sight (or at least take the opportunity to explain at humorous length why it shouldn’t be attempted.)

The tone of the writing is very interesting. It seems on the surface that the narrator is invested in telling a serious account of the events, combining an exciting story with a detailed and efficient record of the surroundings and the items there-in.

Then why does it feel as if there is a muffled subcutaneous chuckle just below? As if the narrator is reaching out and pulling the player in on a joke. “Oh what marvelous sillines we get into…”

The map is small, but bursting to the brim with stuff to investigate and examine, oftentimes with several layers of implementation.
When Evidence Sweet starts her exploration, just three rooms are available. Expanding the map through hard-won magical adventure-work is a real source of pride for the player.
The level of difficulty was just right for me, maybe even a bit on the easy side. This means that I could experience the thrill of victory while never feeling held back from advancing the story.

I simply loved it.


Thanks so much for your lovely review and for the spark of inspiration in the first place! I definitely have a few more ideas for the post-comp version now…


Can I get a hint for the upper platforms in the pool room?

The Pharaoh’s necklace is 1.) Ivory, 2. ) Copper, 3.) Glass, but that sequence doesn’t work for me once I levitate the stepping stones. Do I have the order wrong? Does it need to reset if I screwed it up?

ETA: I did DISSOLVE ELEPHANT and I can get on the ivory. It just thunks instead of clicking pleasantly.


Ah. I was a bit stuck there myself until I stumbled on a *click*.

To get to the exalted Pharaoh, one must first pass by the lower ranks.
Even if one has already done that once to get acces to the puny Queen.
Full spoiler: repeat the Queen’s sequence on the lower platforms, LEVITATE STONES, then enter the Pharaoh’s sequence.


Thanks! Don’t know why it didn’t occur to me to do the whole sequence over.


Arrgh now I can’t figure out how to get off the stones. I’ve tried D, DOWN, DESCEND, DESCEND STONES, CROSS STONES, OFF STONES, OUT, OFF, W, GO WEST… and a bunch more and it just keeps telling me I have to get off the stones first, or that I’m already on the stones. Help!

1 Like

Yeah. This could really use some alternate commands.

However, they are stepping stones after all, and quite insistent on that.

1 Like

I STILL can’t get it. Tried STEP OFF STONES, STEP DOWN STONES, STEP STONES, STEP OVER STONES, STEP ACROSS STONES. Obviously it’s obvious, but I’ve tried over 50 commands now to get off the stones!

Oh, right. I forgot there’s a catch.


(@dee_cooke are you scribbling this in your notebook?)


Whoops, sorry! Some of the responses there were bugged so I’ve fixed them as part of a bugfix release. Hopefully players won’t have as much trouble now!


All done! A delightful game despite that one hiccup. A great seed and a zippy implementation!

  • Sea Coral -(PunyJam)-

A very cool setup! You’re aboard the MV Pollux, a survey ship for research of the Florida coral reefs. But although the science can help you achieve your goal, you’re no scientist yourself.
The coral reef is used by smugglers and other criminals, and you are a NAVY SEAL on a covert operation to seek out and eliminate any wrongdoers in the reef.

After exploring the ship itself and seeing the equipment at your disposal, it’s time to go into the Florida Straits and begin your mission. You can take the Pollux to other ships and talk to the people on it to further your investigation.

The conversation system is a simple choice menu, but it’s presented in a cool way. When you TALK TO someone, the screen is split horizontally. The conversation topics appear in the top half, and the conversation itself takes place fluently (kind of…) in the bottom half.

However, the game needs work. Lots of it. I understand this is @fos1 's first foray into Inform, and the time pressure will not have been helpful.
I recommend putting Sea Coral aside for a week or two after the competition to wipe away the self-conditioning of playing and reading your own game so many times that you develop blind spots. Then go over it again with a clear mind and try to do stuff completely out of order. Never type the first command that enters your head. Fix the things you find that way.

Then throw it in the ocean for another batch of testers to nibble at.

That is, if you intend to smoothen and polish Sea Coral into a postcomp version. Otherwise, I certainly loved the premise and making this will have been a great learning experience.

(Let me know if you do plan a postcomp version. I could play through this version again and annotate a transcript, or you could send me a more polished version to test.)


Thank you for your most gracious review. I’m still early on the learning curve. I had to improvise the flow to accommodate the Talk Menu system. My next goal is to use a more proper conversation system. I’m already at work on another game. Without the three time pressure I hope it will be much more polished. I am learning so much. I will get back with you to check both games, this one and the new one set on a seafaring port.

Thanks again.


Please do. If you can come up with a skeleton game with a setup like Sea Coral, I’d like to see what comes after.

  • His Majesty’s Royal Space Navy Service Handbook -(SeedComp)-

Meet Sub-Lieutenant of Human Resources Command Sheryl Swift.
Sheryl is punctual, tidy, scrupulously hygienical, and conscientious about her work. All good personal qualities, no?
She diligently organises and leads the weekly staff meetings, preferably during friday-noon lunch break. She sternly believes those beneath one on the societal ladder should be cared for with a firm guiding hand. That’s important work, no?
Recently, Sheryl was promoted to the free-standing cubicle closest to her boss 's Lieutenant’s office. Even though he never asks her in, it’s a sign that she’s worthy of her position, no?
The Lieutenant himself even calls her to take care of an urgent matter in the office. On a friday evening. Minutes before she would leave her desk, put on her coat and go home. That’s firm proof of his trust in her, no?

Against a tumultuous futuristic backdrop, we follow Sheryl as she searches the Human Resources Command offices for a number of missing chapters for the new draft of His Majesty Smurg IV’s Royal Space Navy Service Handbook. Lieutenant Fernandez wants them sent through that same evening. A menial clerk’s job it would seem, but Sheryl performs it with pride and ingenuity. While we see glimpses of the Space Navy fighter fleet in action through the window, Sheryl just as dutifully does her part for the smooth operation of the Human Resources department of His Majesty’s Space Navy.

His Majesty’s Royal Space Navy Service Handbook utilises a limited and efficient verb set, which it vehemently insists upon when it is strayed from. In contrast, the surroundings are richly implemented. Descriptions of objects provide deeper layers of detail and they often include nuggets of characterisation for Sheryl or clues about her co-workers who misplaced the missing chapters of His Majesty’s Royal Space Navy Service Handbook.

While at first it may seem that there is a bit too much handholding in solving the problems, we must realise that His Majesty’s Royal Space Navy Service Handbook chooses to exchange some player satisfaction or puzzle-glory for a smoother flow of the story and better control of the tempo. This makes for a more engaging story.

Sheryl is a beautifully drawn character. I will remember her for the next XYZZY Awards.


Way cool command prompt! (From a very old sailor.)

  • A Clean Getaway -(PunyJam)-

It’s really cool to see a game that doesn’t use a spaceship or submarine airlock. In A Clean Getaway you start in the tightly locked and secured research room of some kind of scientific/medical facility. You’re a nerdy researcher who was so absorbed in work you got overlooked while your co-worker stepped out.

And then something happened and now the airlock is locked, leaving you trapped listening to the fans…

A very promising start.

This is a rather straightforward basic parser puzzler. The puzzles are hands-on. Despite the background of the protagonist, there is no science involved in overcoming any obstacles you encounter. Well, except some basic knowledge of gravity and common sense stuff like that…
Relatedly, it was a real disappointment that the introduction made such a big deal of the top-secret stuff you were discovering and inventing, but then nothing of that research was involved in the story. I kept thinking there would be some groundbreaking speculative scientific/medical new theory and lots of sciencebabble in a backstory, but no…

If it were polished with a lot of spit and shoeshine, A Clean Getaway would be a very cool game to last the player an hour or so. The kind of game that gives you comfort on a rainy sunday afternoon.
Sadly, it’s not. It’s clumsily implemented and it lacks narrative tension.

The poor implementation specifically made me never put my trust in the game. I encountered a number of bugs, unhelpful responses to reasonable commands, and one time a suddenly appearing object. This made me question if my commands did indeed have the intended result under the hood.

The game has a good setup and a bunch of nice albeit simple puzzles. It does need more attention and testing. Given that, it could be a very enjoyable escape-puzzle.