Problem with .sit files

when I would go to download a game from the mac database in the ifdb.tads.org site, I would try to open the game file wich always would be .sit on my mac, I get an error everytime, how do I fix this?

.sit was the StuffIt archive tool. It was used on MacOS Classic – that is, in the 1990s. Those games won’t run on MacOS X at all.

You may be able to get them working with a classic MacOS emulator. However, I don’t remember the process for loading files into the emulator filesystem. I must have done it once (setting up System’s Twilight disk images) but that was years ago.

how do I find this amulator?

Here are instructions for BasiliskII, which is one emulator for classic Mac software.

Note that it’s a complex process – you’re essentially setting up a virtual 90s Mac. Remember too what zarf said: the .sit file is just an archive file, like an old Mac version of a .zip file. Once you’ve set up your virtual old Mac and installed StuffIt Expander, you’ll unwrap the .sit file and still have something that, probably, you have to play in your virtual old Mac. You may need to install additional software in your virtual old Mac at that point to be able to play it.

EDIT. The link provided is setup instructions for Windows, but it should be the same basic process to set up BasiliskII for a contemporary Mac.

I downloaded the zip files that were required, however, upon unzipping them, I tried to open each app, it did not work.

Just so we’re not needlessly over-complicating things here…

Are these Macintosh-only games, or are they cross-platform with the Macintosh version distributed as a .sit file? E.g. the IF Archive has the old “Unnkulian” adventures distributed as .sit.hqx, .sit.bin, etc. which I assume contain both the data file and the interpreter. But since they are TADS games you’d almost certainly be better off getting the platform-independent .gam files and run them through a standalone interpreter.

1 Like

this is the file I downloaded. https://www.ifarchive.org/if-archive/games/mac/DraculasCastle251.sit

Ah. Yeah, that would be Macintosh-only. Simply unpacking the file (not worrying about whether or not I can run it) gives me a README file that says the game is available in a “Classic Version” (“Mac Plus or better, System 6.03 or better”) and a “Carbon version” (“MacOS 8.6 and up with CarbonLib 1.4 or MacOS X 10.1 or better”). I’m guessing the file you downloaded is the Classic Version, and the other one is the Carbon version.

So maybe you’ll be able to play it on a modern Mac, without emulation, assuming you can unpack the file?

Humbly recommend that maybe begging aid from one of the vMac bundling volunteers at archive.org to solve this problem for many is the best way through this conundrum…

The timestamp is 2005, which means it’s almost certainly a PPC binary. So no, it won’t run.

I tried to unpack it and it said I needed something else in order to do it I forget what exactly it said

this may be off topic, but, andrew plotkin, AKA zarf, is the jenius behind frotz?

No, I never worked on Frotz.

Frotz was originally by Stefan Jokisch, with support from a bunch of other people, and is currently maintained by David Griffith.

I downloaded lectrote, hopefully, it will be able to play all 1283 games I finished downloading today, oh, by the way, again, not sure if this is off topic, but, if anyone has not checked out any games by andrew plotkin, I recommend checking them out, I believe he made a tutorial game, the dreamhold, wich, is the second game I played, after failing adventure, back in 2011 when I was introduced to if.