Problem with Disambiguation Control

I’m using the version of Disambiguation Control on github. I had this code:


Include Disambiguation Control by Jon Ingold.

The Lab is a room.

A fruit is a kind of thing. A fruit is always edible. Understand "fruit" as a fruit. Understand "fruits" as the plural of a fruit.

An apple is a kind of fruit. A banana is a kind of fruit. 

Three apples and three bananas are here.

A hat is a kind of thing. A hat is always wearable. Understand "hat" as a hat. Understand "hats" as the plural of a hat.

A fedora is a hat, here.
The bowler is a hat, here.

Test apple with "x apple / x apple. / x an apple / x an apple. / x bowler, apple / x apple, bowler".
Test bowler with "x bowler / x bowler. / x bowler, apple".
Test fruit with "x apple and banana / x fruit / x fruit. / x fruits."
Test hat with "x fedora and bowler. / x hats / x hats."

The game behaves in some strange ways when I tried “get 2 apples and 2 bananas”. Searching on this forum brought up this thread. After making those changes to my copy of Disambiguation Control, I then found that typing multiple commands on one line (like “x apple. x fedora”) made the interpreter freeze. I then found this thread, and I thought making the change to Parser Letter A would fix things … but not entirely. The game no longer freezes, but it seems not to recognise command some commands.

For example, typing “x apple. x fedora” (or just “x apple.”, with the full stop) yields “You can’t see any such thing.” This only happens if you try doing anything with the words “apple”, “banana”, or “hat”; it doesn’t happen if you type “x fedora.” or “get bowler.” It’s not just the full stop: chaining commands with “and” or “then” or a comma – as in “get apple, banana” or “get apple then get bowler” – also produces “You can’t see any such thing.” But if you type “take bowler, apple” then the game responds as expected.

If you put “a” before the name of these items, this doesn’t happen, so “take an apple, banana” works. Also, this doesn’t happen if you use the plural names of these kinds, like “hats” and “apples”.

Does anyone know what’s going on here? I tried searching to see if anyone else has run into this issue, but came up empty.