Prince Quisborne post-comp release

Hello friends of IntFiction and IF! How Prince Quisborne the Feckless Shook His Title is now available in its first “final release” version! Huge thanks to @rovarsson, whose annotated post-comp playthrough transcripts of the entire game were instrumental in flushing out (particularly later) areas of the game that I never felt had gotten a sufficient amount of beta testing before IFComp hit.
Due to the game’s size and the amount of components that can potentially interact, I don’t pretend for a minute that I won’t be making updates and improvements for a long time to come; but I’d like to think I’ve finally reached a point where I’m happy with calling this the first “official” version!

Many thanks to those who have already shown support for Prince Quisborne during IFComp, and for any and all who provided feedback or took the time to play.
For anyone reading who has not been previously introduced, Prince Quisborne is a very large game, written in TADS 3; an exploratory adventure of a faux medieval world, in many ways one with “old-school” vibes, but with significantly heavier description and storyline, and with every effort made to cater to modern text adventure conveniences.

Readthrough mode and/or comprehensive hinting is available for parser-shy or puzzle-shy players!
Screen reader mode is also available, in which some content, presentation or formatting is altered to try to streamline the experience for those using screen readers.
For anyone who has been thinking of giving the game a go, or perhaps has downloaded the game previously but not started playing yet, this would be a good time to download the new release version so that the details of your experience can potentially be at their most polished!
Cheers, good luck, and happy 2024 everyone!


Great work! And just in time for me taking leave…


Can’t wait to get through the whole thing!


Sorry folks: the option to turn off the inventory window wasn’t something I expected to be used very often, so apparently it didn’t get tested very thoroughly. It had buggy behavior which I just updated a few minutes ago…


Congratulations on the release.
How to enable screen reader mode?
QTads is not accessible for screen readers, so I am stuck with HTML Tads or Lectrote.


Hi Luel! I believe if you launch the game with any non-graphical interpreter it will ask you if you want to play in screen reader mode. The one case I’ve heard of so far, the player used Spatterlight on Mac. I’m not certain what Windows standard S.R. Interpreter is, but maybe @inventor200 could confirm?

An old web page mentions the DOS Box interpreter, but there may be something newer now?

1 Like

Thank you for the answer.
For me a question about screen reader triggers in Lectrote.
Nothing happens in HTML Tads, so I believe the game is normal there.
May I ask what screen reader mode does exactly?
I am okay using Lectrote, but I cannot figure out how to move between menu items there.
When I try to read instructions, for example, I end up reading the first thing in the menu and do not know how to select something else.

1 Like

Alas! Lectrote does not seem capable of running the game properly (screen reader mode or not). The status bar is not appearing, and it seems to get stuck on a pause-for-more prompt. That is unfortunate. Have you tried Gargoyle? That seems to allow menu selections, but it is very slow compared to QTads.
Or perhaps, can you turn graphics preferences off with the HTMLTads, and then try to load the game?

The screen reader mode dispenses with a lot of symbols that are used for formatting and decoration in the graphic version, and also there are a number of puzzles which are presented differently in screen reader mode compared to regular mode. It would certainly be a much pleasanter experience, I think, if you can get it to run.


Good call about disabling the graphics in HTML Tads.
I did not know it was possible, but I found the option.
The question about a screen reader popped up after starting the game.
I do not know if I can read the status bar, but I can handle in-game menu in HTML Tads.
Thank you for the suggestion.
And thank you for implementing the screen reader mode.
The last time I tried Gargoyle, it was not accessible.
I check Gargoyle from time to time, when I remember it exist, which is usually if I see some announcement about a new version.

1 Like

I’m glad there’s some progress! I don't remember how status bars work with screen readers anyway… do they ever get read? The status bar includes the current location name, the list of known exits, the score and the turn count. Within menus, the status bar also lists which keys perform which functions…

I don’t know if this link adds any useful info to your situation…

If you do get things running satisfactorily, I’d sure love to hear about your experience, pros and cons! If you feel like creating a SCRIPT as you play, that would be good as well!


I checked the link, but in my case, I already have everything mentioned there.
I am using NVDA screen reader with the add-on mentioned in the topic.
This add-on makes NVDA read text automatically in some interpreters.
From my experience, status bar is sometimes read randomly in the middle of reading some other text.
As far as I know there is no way to check it manually, unless a command to do so is directly in the game.
It would be useful to quickly check available exits.
I can make a transcript of the game, but I doubt I will be able to finish it in one go.
It will take some time.

1 Like

Hi again, Luel…

You’re under no obligation to make transcripts! (And they can be broken into multiple files with SCRIPT OFF, as well… nobody in their right mind would play Prince Q in one sitting!)

If you have not gone very far already, you could consider redownloading the game within an hour two after this post. I’m going to modify the EXITS command for screen reader mode to print what the status line shows as far as exits go. I didn’t realize this limitation with the status bar. Thus in the new version, typing EXITS will immediately print the obvious exits.


The download link has been updated with a new version, 1.4. Now the EXITS command will explicitly print out what ordinarily appears in the status bar. Apologies for these complications!

If you (or anyone else out there) HAS started playing, and doesn’t care to restart with a fresh download, I can create and provide a patch file which will inject the new functionality into your current version.
Let me know, and good luck!


Thank you for adding the exits command.
It really is useful, I use it when a game allows it.
I have not started properly yet, I was just checking how things were working.
I did have a playthrough where I was some 80 points from finishing, but that was with the older version, which I downloaded some time in December.
Fortunately I do not have a transcript for that one, because that playthrough was all over the place and any transcript would be a mess to read.
I look forward to playing with a screen reader mode active.

1 Like

Investigations of some of these issues with non-HTML terps led me to realize that the intro screen formatting was pretty much a wreck and the title splash didn’t show. I’ve updated the logic for the game introduction while running on non-graphical interpreters. It seems to be out of my control at this point that the menu systems within the game have some erratic behavior when run on non-HTML interpreters…

Hey!! I wanted to play the post-comp release since it’s been a minute and I wanted to restart anyway, but I’m having trouble getting either of the files currently on IFDB to work in QTads - I can get through the title screen and first set of background text just fine, but once I’m in Before Castle Darchingcrast, QTads is asking me to press enter/any key to continue, but the parser is active, so something contradictory is going on and nothing I type will appear in the parser OR make anything continue in the way the enter key does during cutscenes. Gargoyle is working fine (inasmuch as it works with this game, anyway - obviously no visuals lol), although I did notice after the conversation with the king/before Before Castle Darchingcrast, the [MORE] prompt appears twice? So maybe it’s something to do with that? If there’s a fix, let me know - I’d rather play in QTads than Gargoyle lol


Oh no! I’ll have a look when I get home from work today!

1 Like

Real quick though, the MORE is supposed to show twice, cause it was the only way to get the music to fade right…

1 Like

So sorry! I did a fresh download of PQ from the IFDB link (definitely use the top link: the IF Archive version is typically way behind), and opened it in both QTads 3.3 and QTads 3.4. Nothing got stuck!
Have you tried rebooting QTads and seeing if the problem persists? This may not have anything to do with it, but it’s worth nothing that when QTads gives a MORE prompt, the Enter key will sometimes only advance the text window by one line, where Space (or most other keys) will jump all the way to the next wave of text. So, maybe try using Enter key for menu selections (such as which intro to read) and Space for all of the MORE prompts…
If it consistently gets stuck after that, I’d need to send an SOS to someone savvier than me, because it sounds like a hardware/platform issue! What system are you playing on?
Does QTads have Allow Graphics/Sound Effects/Background Music all checked?
Sorry for the hassle!

1 Like

No worries! I downloaded everything again and tried on both QTads 3.3 and 3.4, and it’s still getting stuck on that first opportunity to input text (strangely, the BEGIN command works fine, it’s only after that that I can’t seem to type). All QTads settings were at default. Did the space bar instead of enter key as well (and tried it all multiple times).

Two other weird things: other TADS games are working just fine; I checked a different one to make sure. Also, the comp file isn’t working either, when it used to previously (on this same computer, using QTads 3.4), so… if anything I’m now more confused about where the problem is coming from. I’m using a MacBook Air, so OS is MacOS Ventura at the moment.

To summarize:
QTads 3.4: Some sort of error when trying to play PQ, but can play other games.
PQ: Not working in QTads, but is working on Gargoyle.
My Laptop: confused, apparently.

I have genuinely no clue why even the comp file isn’t working anymore, when there’s been no update to QTads or my computer in the time since I last played it. I’ll probably restart my computer later tonight to see if that works, then go from there. So weird!

1 Like