passing save files between different interpreters?

I started playing Counterfeit Monkey in Zoom and tried to switch to Gargoyle. However, Gargoyle doesn’t seem to recognize my save files – when I type “restore” in, the relevant .glksave files show up grayed out in the menu. (I’m using a Mac.) Is this possibly an issue of git versus glulxe, or something else? I’m pretty sure I’m using the right version of the game.

Zoom saves extra data along with the VM save file. The “glkdata” file you see is actually a package containing several files. If you look inside it (command-line, or right-click “Show Package Contents”) you can find the actual Quetzal file, which I believe is called SAVE.DAT.

Thanks! For anyone reading this, if you’re copying the file from the “Show Package Contents” view in order to rename it to a .sav and open it in Gargoyle, make sure to option-drag it out to create a new copy in another location – I tried dragging it out, duplicating it, and dragging the original back in, but the Finder isn’t letting me drag anything back into the original package.

(This is strictly for theoretical purposes – Gargoyle isn’t supporting UNDO either so I’m just going to keep playing in Zoom.)

I believe if you switch Gargoyle to the Glulxe VM instead of Git, it will support UNDO. (Git allocates less memory for the undo chain.)

Ah, thanks. I can do that by editing the config file, I guess. (I think this has crossed the “It’s less annoying to stay in Zoom and save all the time” line, though.)

[Wrong thread; sorry]