Packrat by Bill Powell

I played a couple of games by the same author in last year’s IFComp and didn’t care for either (I think I gave them both a rating of 3 out of 10), so I approached this one without much enthusiasm. However, despite my misgivings, the introduction was certainly more interesting than I expected and as I began to play the game in earnest, I soon got hooked.

As the Packrat of the game’s title, you’re an adventurer/thief in a fantasy story based loosely (very loosely) on the old fairytale of the princess asleep in the castle in the middle of nowhere who needs to be awakened by a handsome prince in order to save the kingdom. You’re not a prince (the handsome part I’m not sure about) but you’ve still been picked to do the job. And as this is a castle full of unguarded loot, you’re only too happy to accept.

Unfortunately, I tend to run into problems with even with my favourite games in the comp. Here some of the puzzles were of the guess-the-author’s-mind variety and pretty much impossible to figure out by anyone lacking psychic abilities. There’s an item in the first location which you need to take to trigger a mood swing, but when first attempting to take it you’re told you can’t. As I assumed that was it for the item – it was either a red herring or it served some purpose other than being picked up – I decided not bother with it again. After becoming stuck later on and consulting the walkthrough, I found that you need to attempt to take it four times. I couldn’t understand how I was supposed to know this or even why I was being made to attempt this four times before it worked.

Attempting to take the item four times puts you in ‘acquisitive’ mode, which gives you the strange habit of automatically attempting to pick up every single item you come across. Items that can’t be taken – like a laundry chute or a staircase– you’ll still attempt to take, and you’ll do this every time you come across them. The first time I saw this, I assumed it was some kind of bug. Attempting to take non-carryable items like laundry chutes and staircases certainly seems like a bug (has the author flagged them as carryable items for some reason?) but it could also just be a wry joke at the player’s expense. You are a packrat after all.

While in acquisitive mode, you can’t put down any items… except if you try the DROP ALL command which is a little buggy as it puts down most of the items you’re carrying (obviously the author forgot to program in any restrictions for these items) and even tries to put down an item referred to as ‘nothing’, tells you that you don’t want to part with ‘nothing’ and promptly picks it back up again. ‘Nothing’ never actually shows up in your inventory but it’s still kind of odd seeing this sort of thing happen. DROP ALL also produces an unfortunate error message (on top of trying to drop the item called ‘nothing’).

Later on, performing an out of character act of kindness (you are a thief after all) puts you in ‘content’ mode which allows you to drop items normally. During my initial pay through the game, I found it possible to put the game into acquisitive mode and how to get out of it*, but was never sure what the point of these modes was. Acquisitive allows me to pick up items without actually typing anything (like an automatic GET ALL command), but short of saving a little typing I didn’t see what purpose it served. I can also imagine it becoming a little wearying after seeing several lines of


tacked onto the end of every other action I carry out.

  • Only the once for each though, so if there was something that needed doing in acquisitive mode and I’d already exited it, I might have blown my chances of finishing the game. I ran into a problem with this in that initially I discovered content mode first (I was actually content at the time – i.e. picking up and dropping items normally – so going into content mode didn’t change anything as far as I could tell, aside from making it impossible to leave acquisitive mode), and then afterwards I discovered acquisitive mode. As I then needed to drop several items in order to complete a puzzle, I became stuck as the game wouldn’t let me drop them, being acquisitive as I was, and I had no idea how to exit the mode.

While I wish the game had been tested more thoroughly, I still had a lot of fun playing it. It’s kind of strange considering how buggy it was that out of the 22 games I played during the IFComp, I rated it 4th overall… which is certainly a lot higher than some other games that seemed essentially bug-free. It’s tempting to knock several points off for the bugs – they were frustrating after all – but as I still enjoyed playing the games, bug and all, I think I’ll leave my rating of 7 as it is.

7 out of 10