Odd Twine Problem in Ubuntu Linux

I have an odd problem I am hoping a Linux guru can help me sort out.

I have a relatively new Ubuntu Linux installation. I downloaded the latest build of Twine from Githuub, unzipped it and ran it. I can create a game, add passages, and edit CSS and JavaScript.

The problem is that the play and test buttons do not work. It appears Twine is creating the files in the /tmp/ directory, but that my web browser(s) do not have permission to view those files so I get a 404 error “File Not Found.”

I know the files are there. I can browse to them with the file manager or in the terminal, but no matter how I try to bring them up in the browser, they are invisible.

I assume this is a permission/ownership issue, but I am hesitant to start messing with it without a clue what I am doing. Any help would be appreciated.

It is working out of the box on my Xubuntu 20.04 installation.

First, which web browser are you using? I have had occasional trouble with Chrome and Chromium accessing /tmp files. It seems like Chromium, especially if you’ve installed it through snap, points to its own special /tmp directory that is not the same as the system one.

I’ve had better luck with Firefox…make sure to set it to the default browser even if you’re already using it.

If /tmp files continue to cause issues, you can try exporting a non-temporary file with the menu on the bottom left hand part of the Twine window. [Story title] > Publish to file

If all else fails you try creating a new Ubuntu account. This will at least let you know whether the problem is system-wide.

1 Like

I started with Firefox and then switched to Chromium just to see if it made any difference. It did not. The issue almost has to be that Twine is creating files that the browser(s) do not have permission to view. I may try creating a new account, but I’m not hopeful. I wish I could fully install the program, rather than just running it from a folder.

I’d feel better.

Tmp files that Twine has no permission? Did you check it via CLI/Terminal? ls -l command should tell you. You can change permission with

sudo chmod 755 filename

If you don’t know how linux CLI work, though, better ask a friend who does.

You can also try running the 1.x version of Twine under Wine, which is what I do. That version exports temporary files to the folder with your .tws game file instead of /tmp.

Assuming you’re not trying to upgrade from 1.x already that is.

I wish I could fully install the program, rather than just running it from a folder.

That probably wouldn’t help…the export directory seems to be hard coded into Twine 2.

Also, I just found out there is another directory besides /tmp for Twine 2 HTML files. In the Ubuntu file manager go to

~/Documents/Twine/Stories/

and try opening it from there.

That folder is where the desktop release of the Twine 2.x application stores its project files, which can be accessed via the application’s View > Show Story Library menu option.
see: Desktop