{ not collapsing white-space when story first loads

Twine Version:
Harlowe 3.3.5

Hi, I don’t know exactly what I’ve done wrong, but hopefully it’s just something simple and stupid that y’all can maybe help me fix?

My header appears to be doing something funky when I first launch the story - it shows the {, a bunch of whitespace (which I believe should be collapsed) and then “(set: 0 to (either: }” followed by the 3 links that I expect it to display (About, Go to the library, and Please choose a difficulty level).

(I do not know where the “(set: 0 to (either: }” is coming from, at all.)

Once I click onto one of the links, the weird { and whitespace and code disappear and the header appears exactly as I expect.

My header passage contains the following text:

(link-reveal-goto: "About", "About")[(set:$t to it + time)]
(link-reveal-goto: "Go to the library", "Library")[(set:$t to it + time)]
(if: $choice is 0)[(link-reveal-goto: "Please choose a difficulty level", "LevelChoice")[(set:$t to it + time)]]\
(if: $choice is 4)[(link-reveal-goto: "Escape the room", "Key4")[(set:$t to it + time)]]\
(if: $choice is 6)[(link-reveal-goto: "Escape the room", "Key6")[(set:$t to it + time)]]\
(if: $choice is 8)[(link-reveal-goto: "Escape the room", "Key8")[(set:$t to it + time)]]\
(if: $choice is 12)[(link-reveal-goto: "Escape the room", "Key12")[(set:$t to it + time)]]\


<center>(if: $choice is > 1)[Unknowns to identify: (for: each _case, ...$list)[(link-reveal-goto: $cases's (_case), _case)[(set: $t to it + time)] | ]]</center>


This happens on any page I have tried launching from, and isn’t specific to the launch page. I have tried updating my desktop app and that didn’t help either.

I thought maybe it was something odd I’d done with all of the if: statements for choosing different difficulty levels, but it does stop happening and work correctly once I’ve clicked a link, and the if: statements do seem to be working correctly. [N.B. This used to be an if: followed by several else-if:'s, I changed it to the if: statements just now hoping that it would fix the problem…no such luck.]

Am I not using the { brackets correctly? Is there something in my startup passage I need to change? Is it just stupid to be dwelling on it since it seems to disappear once I’ve clicked a link?

Thanks a million for all the help! I’ve tried attaching a screenshot of what I see in case that is useful, but not sure if it will work or not.

Your code works fine for me.

I see the About link at the very place first character should appear.


Oh wow - thanks for checking! I am glad to hear that it’s working … a little perplexed that it’s not working on my machine! Thank you so much though!

The only thing that happens differently when the first passage is displayed, is a possible startup passage.

Do you have a startup passage that might be breaking your code?

1 Like

Oh, of course - I really should have clocked that! Yep, I had an unclosed variable definition in my startup passage that I guess must have been causing the error - works fine now that I’ve deleted it.

Thanks a million! Definitely needed help to see the obvious here, really appreciate it!

1 Like