"No such file or directory" error when running any command

Hello, I attempted to install TADS today in Ubuntu but ran up against some issues: any command I run returns the error bash: /usr/local/bin/t3make: No such file or directory.

It doesn’t matter which command I run or what options I include with it (if any), I always get a “no such file or directory” error back. The files do exist, I’ve double-checked (running ls /urs/local/bin returns frob, t3make, and tadsc, and I can find those files in my gui application as well), and I’m not sure what’s causing them to return this error.

I cannot find any reports of anybody else experiencing this error as well or guidance as to how to troubleshoot it — does anybody have any ideas on what might be the problem?

Can you try to move the files to another location and see what you get? Really, I don’t know anything about Linux so I hope you can get some help…

When you say “any command”, you mean any command involving t3make, or literally any command you type at the command prompt?

If you are entering commands on the command line, can you supply the actual command and copy and paste the error? For example, when I try to run t3make on a non-existent option file, that’s:

jbg@hostname:~/tads$ t3make -d -f foozle.t3m
error: unable to read option file "foozle.t3m"
Errors:   1
Warnings: 0

And while you’ve got a command line, can you do the following and report their results:

ls -l /usr/local/bin
echo $PATH

The first will show everything in /usr/local/bin along with the permissions set on the files, their owner, and so on. The second will show a colon-delimted list of all the directories bash will check for matching commands.

I mean any command involving t3make, frob, or tadsc. It doesn’t matter if I include options or files or if I just took it on it’s own, I still get the same error (just with the file matching the command I used).

gjo@xyzzy:~/Projects/TADS/MyGame$ t3make -d -f MyGame.t3m
bash: /usr/local/bin/t3make: no such file or directory
gjo@xyzzy:~/Projects/TADS/MyGame$ t3make
bash: /usr/local/bin/t3make: no such file or directory
gjo@xyzzy:~/Projects/TADS/MyGame$ frob
bash: /usr/local/bin/frob: no such file or directory
gjo@xyzzy:~/Projects/TADS/MyGame$ tadsc
bash: /usr/local/bin/tadsc: no such file or directory

(MyGame.t3m should be a valid file.)

The result of ls -l /usr/local/bin:

total 2120
-rwxr-xr-x 1 root staff 835324 Apr 16 2008 frob
-rwxr-xr-x 1 root staff 1088640 Apr 16 2008 t3make
-rwxr-xr-x 1 root staff 241896 Apr 16 2008 tadsc

The result of echo $PATH:


Okay, does it report the same error if you give it the full path? I.e., something like

/usr/local/bin/t3make -d -f MyGame.t3m

Also, report what

file /usr/local/bin/t3make

tells you. It should be something like:

/usr/local/bin/t3make: ELF 64-bit LSB pie executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=938c804c2a94b609568381f02faf22635431117f, for GNU/Linux 3.2.0, not stripped

Yes, I get the same error if I specify the full path.

Ah, mine is 32 bit which could be the problem — I downloaded the only .deb file of it I could find, and assumed that since it seemed to have installed properly it was fine for my system, which was probably a faulty assumption.

Anyway: /usr/local/bin/t3make: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.4.1, stripped

Okay, now try

ldd /usr/local/bin/t3make

It should say something like:

        linux-vdso.so.1 (0x00007ffd65a56000)
        libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f2fbcb43000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f2fbca5c000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f2fbca3c000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2fbc814000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f2fbd078000)

If any of those is instead a message about something being missing, that’s the problem. In which case you’re missing one or more dependencies for the package.

It says not a dynamic executable.

Well, that’s odd. Because the output of the file command you cut and pasted earlier says that t3make is dynamically linked. So either there was a typo or something’s borked.

In any case, in another thread you mention trying to install inform in ubuntu, but here you’re talking about installing a random .deb package? Whatever else is going on, I think we can conclude that whatever package you installed is not in fact compatible with your OS.