Mike Russo's ParserComp 2022 Reviews

While in spring, a young person’s fancy turns to well-crafted works of IF across the spectrum of styles and approaches, by summer they’re in the mood for typing: yes, it’s time for ParserComp, and per my usual practice I’ll be doing reviews! Y’all know the drill by now, I’ll be playing in a random order and saving the ones I beta tested for last. As always, my goal is to get through all the games by the end of the month.

Atypically for me, I’ll leave the preliminary tap-dancing there and get straight into things.

Alchemist’s Gold, by Garry Francis
Anita’s Goodbye, by IlDiavoloVesteRosa
ConText NightSky, by XxTheSpaceManxX
Cost of Living, by Dorian Presser
Desrosier’s Discovery, by Ben Ehrlick and Isabel Stewart
The Euripides Enigma, by Lazzah
Gent Stickman vs. Evil Meat Hand, by AZ
The Impossible Stairs, by Brian Rushton
Improv: Origins, by Neil deMause
Kondiac, by Picarly
Lantern, by Sylfir
Midnight at Al’s Self Storage, Truck Rentals, and Discount Psychic Readings, by Thomas Insel
The Muse, by Xavier Carrascosa
October 31st, by Finn Rosenlov
Of Their Shadows Deep, by Amanda Walker
python game, by theernis
Radio Tower, by Brojman
Things that Happened in Houghtonbridge, by Dee Cooke
Uncle Mortimer’s Secret, by Jim MacBrayne
You Won’t Get Her Back, by Andrew Shultz


Kondiac, by Picarly

Although you’re only told it in the blurb, rather than in the game proper, Kondiac has a neat premise: there’s been some untoward events in a small town in Alaska, and it’s up to you to troll through the archives of the local newspaper to get to the bottom of things. As someone who maxes out their Library Use skill whenever they play Call of Cthulhu, I’m a sucker for this kind of diegetically-presented approach to research, and the specific keyword-search system used here reminded me of Her Story, which I quite enjoyed (some might raise the question: even though this kind of game involves typing, there’s not really a world model, so is this truly parser IF? To that I reply, eh, doesn’t bother me one way or the other, in ParserComp it is so into the ParserComp review queue it goes).

Sadly, these initially-high hopes were quickly dashed. The game doesn’t take the “newspaper archives” premise at all seriously – while several pieces of evidence are found by using specific proper nouns, as you’d imagine (looking into a business by checking out its name, for example), many of them require the use of incredibly common words as search terms, which somehow turn up only a single hit. This small-town newspaper has also amassed quite the trove of evidence already, including photos that unambiguously depict crimes being committed and bank records of private parties, so one feels less like an intrepid investigator connecting the dots and more like a harried IT staffer under the gun to wrestle a cockamamie file storage system into shape ahead of the already-written big scoop.

It doesn’t help that the mystery being investigated isn’t especially twisty or fleshed-out. There appear to be less than a dozen different pieces of evidence to find, which stymied me for quite a while – I followed the initial thread of obvious things to search, like the name of the town and the proper-noun that greets you when you start up the game, and got to a page indicating that rather than the single missing person I’d turned up, there were actually a total of half a dozen people who disappeared in this town all at the same time. But searching for any of the other victims was a dead end; only the first person had anything written up for him, and lots of other search terms that really seem like they should give some result (like the police department, or even the newspaper itself) come up empty instead.

Further deflating matters, the punchline to the investigation is both one you’ve probably seen before and doesn’t make much sense on its own terms: the plot centers on an inpatient substance abuse treatment facility, which is being paid $12k a pop to perform various evil deeds, but having done health policy work and being familiar with the reimbursement rates you can pull down for this sort of thing, garden-variety Medicaid fraud would be far more lucrative. And I ran into some technical wonkiness with the implementation: notably, errant white space seems to confuse the search bar, so “kondiac” gets a hit but “kondiac “ doesn’t, and while a first name or a last name might get you to the same hit, a full name won’t.

All told, Kondiac seems like a proof of concept that needs substantial expansion and editing to hit its potential. The basic premise, again, is good, and I liked the visual presentation – there’s some creepy CGI art, and it’s fun to look at the mocked-up bank statements, newspaper articles, and missing posters on display to extract the relevant information. The technical niggles would also probably be easy to sort out. But as is, there’s not enough here to justify the trip.


The Euripides Enigma, by Lazzah

With its enthusiastic space-adventure opening crawl, including a prominently-featured “Chapter 4”, The Euripides Enigma makes a fun, friendly first impression. Sure, there’ll be danger and excitement here – it doesn’t take long to realize that we’re in general sci-fi plot #4, AKA an Aliens rip-off – but the helpful introductory text and instructions seem to promise smooth sailing, even if there are a few discordant notes of foreboding (in addition to examining objects “you can also SEARCH and LOOK IN, BEHIND, and BENEATH things”; “there are lots of buttons to press or push in this game”). I pushed fears away upon launching the game, appreciating the nicely-implemented preliminaries of engaging with your squad and making my way into the requisite derelict base’s airlock, and enjoying the endearing way that the producers of this particular movie seemed really focused on saving money (only one marine has a speaking role, and the whole squad is moved off-screen absurdly quickly – guess even paying scale was a stretch – while the alien monsters are invisible most of the time, really easing the CGI budget, and the whole thing could be shot on the cheap on a repurposed Star Trek soundstage).

Then I faceplanted on the first real puzzle, hard. I’m going to spoil it, because if you’re in this game’s target audience, you’d have solved it easily anyway, and if you aren’t, you’d have needed to run to the hints and I’m just saving you some keystrokes. You’re in a small control room, and need to get the power back on, but you quickly realize that there’s a broken on/off switch on the environment control console. Fortunately, exploration reveals that there’s a storeroom right down the hall, with trays of spare parts, so for this nice easy opening puzzle you must just need to poke through the shelves, right? After every combination of EXAMINE, SEARCH, etc. I could think of failed to bear fruit, I took a step back and re-inventoried my surroundings, realizing that there was another console whose functioning on/off switch was conspicuously mentioned. Aha, thought I, all I need to do is abstract this one and plug it into the other console, and we’re off to the races.

But it was not to be, and after another 15 minutes of banging my head against the puzzle, I had recourse to the hints, which told me I had to LOOK UNDER the environment control console – sure enough, there was a compartment there with a spare switch. Happy to be making progress, I was prepared to overlook the fact that nothing in the room or console descriptions prompted this kind of further searching in the slightest. But flipping the switch didn’t accomplish much, because I also needed to fix a second console to restore emergency power to the base. Once again, flailing got me nowhere, though I went to the hints much quicker this time – the answer was to EXAMINE WALL to discover a relay box, again with no prompting indicating there was anything of interest worth looking at there.

At this point the game’s map opened up and I was able to explore the rest of the moon base. Friends, it was chock-a-block with equipment shelves, sofas, chemical stores, bunks, tables, desks, and more, and while I was able to hoover up a few inventory items and get a sense of the game’s ultimate challenges, it was clear I was missing a lot. Regular abuse of the hint function helped me figure out some of these pieces – I had to LOOK BEHIND some cushions on a chair, EXAMINE THE FLOOR in one room to discover that the vending machine could be pulled out, and of course LOOK UNDER one of the bunks in one of the half-dozen identical rooms of living quarters. After about an hour, I was out of hints – they appear to be room-specific, rather than speaking to your overall progress – and when I looked at the walkthrough, it was a solid fifteen pages of zero-context commands, and while those in the back half looked fun, a dispiritingly large proportion of the rest were all about SEARCHing and various flavors of prepositional looking, and realizing that finishing the game was going to mean paging back and forth through the walkthrough to figure out where I was, then just following it puzzle by puzzle, I decided to give up instead.

What looking at the walkthrough made clear is that this use-all-the-verbs-on-all-the-nouns stuff in the first scene isn’t a momentary lapse of player-unfriendliness – this is a positive design ethos, the author having clearly decided that this sci-fi action premise is best served by gating the meat behind a marathon, furniture-centric scavenger hunt. I’ve encountered this kind of approach in several ADRIFT games before (though you see it in other systems too), I think the product of a sub-subculture that largely looks to 80s games outside the Infocom canon and prides themselves on writing text adventures, not interactive fiction – and who hold high difficulty and tedious, mine-sweeping gameplay as virtues, much as S&M people are really into stuff that seems really quite alarming to us vanilla folks. And while EE is undeniably well-crafted, with terse but effective prose, a big but not overwhelming map with major puzzles clearly signposted, and not a bug in sight, it feels very much by, of, and for said sub-subculture.

Of course, we’re talking about different flavors of parser IF, in space-year 2022 – in other words, we’re all into one niche fetish or another round here, so it’s little rich for me to dismiss Euripides Enigma, especially since for all I know the old-school text adventure fanciers could outnumber the people I’m positioning as more mainstream. This is fair! But still, I feel, there are degrees. If, invited back for a night of fun, one’s intended introduces some light tickle play, even if that’s not the thing that gets one’s engine revving, I’d guess that more likely than not one will simply go along for the ride. It’s a different matter where one’s inamorata greets one at the door wearing a leather mask and oiling up a marlinspike – for some, this might be the sum of earthly bliss, and truly, God bless ‘em. But I can’t count myself among their number, and having tried the flogging for an hour and found it not to my taste, hopefully I can be forgiven for skipping out before giving the nipple tenderizer a go.


I forgive you, Mike, and I’m very, very glad you got out before things got to that stage. Thanks for making me laugh like a drain, to the bemusement of colleagues, as I read this at my office desk.

I think you’re right that this style of gameplay will appeal hugely to a certain type of retro-inclined audience. Different strokes, certainly.


Larry Horsfield’s Alaric Blackmoon oldschool fantasy games were what brought me back to IF for real some years ago, and I am very much the intended fancrowd.

If needs be, I’ll LOOK BEHIND PURPLE SOFA CUSHION while searching for the nipple tenderizer in every frickin’ room. But I get what you’re getting at, and you are forgiven. Some people are satisfied by a light dusting with the plumeau feather duster.

And I playtested this game, so that means I’m invested in all the LOOKing UNDER stuff.


I appreciate the forgiveness, and I hope you read your colleagues some excerpts so they could be reassured at how totally normal the stuff you were laughing at was.

(This is assuming “laughed like a drain” means you were actually laughing? I don’t tend to think of drains as particularly droll, but I’m guessing this became a common British colloquialism after Harry the Happy Drain was such a hit in a 1974 Doctor Who Christmas special – though they didn’t have the budget for a drain so the role of Harry was actually played by a colander).

Definitely – in all seriousness, I’m looking forward to a review from someone more attuned to this style of game so I can vicariously appreciate what I’ve missed.

Well, Bob’s your uncle. (Did I do that one right?) I saw your other post about your reviews being delayed due to nonsensical excuses like “taking vacation with loved ones” and “spending time in nature”, but looking forward to hearing your take on the game when you get back!


October 31st, by Finn Rosenlov

Welp, that’s done it. Having likened ADRIFT afficionados to sex deviants in my Euripides Enigma review, sniggering through my sleeve all the while, I’m eminently deserving of karmic retribution, and the gods of the ParserComp queue (it’s an important job, there have to be several of them) have seen fit to reward me with another ADRIFT game as a chaser. This time, instead of generic sci-fi plot #4, it’s generic horror plot #7 – spend a night in a spooky mansion – and there are once again definite warning signs in the introductory text (the distinction between EXAMINE and SEARCH is emphasized). But while the setting is just as generic as the premise, and there are some wonky puzzles, including some guess-the-verb fiddliness and read-the-author’s-mind shenanigans, I actually got along fairly well with October 31st. Partially this is down to personally finding Halloween monster-mashes more appealing than po-faced sci-fi bug hunts, but the game also paces out its challenges well, and provides both a hint menu and a walkthrough to help players get over some of the rougher patches.

The game starts out with some appropriately spooky build-up, as you slowly and trepidatiously make your way to the grim manse where the adventure is set. The prose nails a campy but still slightly spooky tone, which helps build anticipation for what’s to come – like, when you open the gate to the mansion’s grounds, you’re told that “almost reluctantly it swings open with the sound of a thousand tormented souls.” Fortunately, X ME discloses that we’re quite the matinee hero, and definitely up to the challenge: “your piercing eyes are set in a face with a straight nose and lips quite a few girls find very kissable.” Indeed – it’s not our fault that all said girls live in Canada!

Er, regardless, it quickly becomes clear that rather than simply snoozing your way through the night, you’ll need to take on and defeat a series of classic monsters – a witch, a skeleton, a mummy, etc. – before going up against their boss (Count Dracula, obviously). Oh, and there’s a ghost too, but he’s cool (he’s a well-implemented NPC, in fact, and I enjoyed my chats with him). Each baddie inhabits a different precinct of the mansion, and defeating each requires running through a short self-contained puzzle chain. This structure gives the player agency in deciding who to go after first, and also keeps the game’s pace up, since every time you get to a new part of the mansion you’ll do some initial exploration, then encounter the foe, then get the climax of beating them, before moving on. While the lack of interdependence does sometimes lead to moments of illogic in the puzzles – in particular, there’s a bit where you’re doing the classic newspaper-under-the-door trick, but you can’t use a short piece of wire to poke out the key because you got that in a different branch, so you need to find a comparable item in the nearby environment instead – it does work to cabin things, meaning I usually had a reasonable sense of which locations and which items I needed to poke at in order to make progress.

The puzzles are simple fare, but often with a small twist that makes them more fun – like, no points for guessing what you’ll need to do with the bit of cheese you find, but there’s an extra step you need to perform that means the puzzle doesn’t feel utterly generic. Per my complaints earlier in this review, there are definitely moments that had me running for the hints, though: there’s one place where EXAMINing a bit of writing tells you what’s written there, so I didn’t realize I had to separately READ it as well, and there’s a spot of gravedigging that’s rendered more challenging than it needs to be by the parser being overly persnickety about your word choice. This is an issue in several places, in fact – I guessed that there was something weird about the clock in the library, but could never figure out what precise syntax was needed to interact with it, and I wasn’t able to put a key object in a receptacle clearly designed for it until, running out of more plausible approaches, I tried PUSH KEY OBJECT WITH RECEPTACLE, which doesn’t make much sense. And I wasn’t able to actually win the game, despite getting to the final confrontation being pretty sure of what I’m meant to do, with the hints and walkthrough not providing the help I needed (and contradicting each other to boot). Still, for every iffy puzzle, there was another that worked well.

I can’t help listing the annoyances, but still, I enjoyed my time with October 31st regardless of some of these spikier bits, with the evocative writing, campy monsters, and fun-but-shonky puzzling carrying me through. I’m guessing the real classic text-adventure afficionados will find it more lightweight than something like the Euripides Enigma, but for the rest of us this is a nice, less-painful way to experiment with the style.


ConText NightSky, by XxTheSpaceManxX

It’s hard to write a true review of ConText NightSky, because the game’s blurb reveals that what’s been submitted falls well short of the author’s expectations. Taking the ambitious course of developing a new parser system, it’s clear that there wasn’t enough time to wrinkle out the bugs, much less create a full game to take advantage of the system. While the setup of mysterious goings-on at an Arctic research base is intriguing, the game stops just as it seems ready to get going – you have a three-item to-do list, but after showering and eating a meal, I wasn’t able to discover how to start the protagonist’s data-analysis work, which was the third item.

I’m pretty sure this is due to the game being incomplete rather than a failure to guess the verb because the system prompts you with all possible actions, and nouns those actions can apply to, each turn, with the possibilities shifting as you type. This is a nice convenience that removes guess-the-verb issues, though I was still often puzzled by why some objects had to be looked at and others examined, for example. What’s worse, I found that performance was awful – while I chuckled when I first noticed the game had an always-on FPS counter, I soon found that the game would grind to a near-halt in certain locations, making it a real burden to play.

With these technical limitations, a truncated story, and nonstop typos, it’s clear that the version of ConText NightSky currently on offer isn’t really worth playing; I get that the author probably felt pressure to submit something by the Comp deadline even if it didn’t fit the initial vision, but in this as in almost every case, the best course would have been to delay releasing the game until it was something the author could be proud of. There are high-profile competitions and festivals every couple of months these days, so waiting a bit costs basically nothing, whereas the chance to make an amazing first impression is a terrible thing to lose.

(I’ll also take this opportunity to plug @mathbrush’s great Twitter thread on custom parsers from a couple weeks back – definitely essential reading material for anyone considering writing one with an eye towards entering an IF competition).


Uncle Mortimer’s Secret, by Jim MacBrayne

Sometimes I read a game’s blurb and it feels like it’s inviting me into an exciting adventure, or to settle into a warm, comforting bath, and I’m chomping at the bit to get started. Others, though, like the sorry-this-is-broken lament of ConText NightSky, feel like a wet blanket. And to be honest, for an entirely different set of reasons I found the blurb for Uncle Mortimer’s Secret daunting. The author flags that the game is large and takes at least 300 moves to solve (which seems like a lot?); that some extrinsic Google searching is required to solve the game; and it’s a custom parser with a really really old-school appearance. That appearance was also somewhat familiar, which made me realize that the author wrote Somewhere, Somewhen for last year’s ParserComp, which was a sprawling, hard Zork-alike that I respected for its achievements – the custom parser, at least, was solid, with the exception that it makes interacting with objects in containers or on supporters kind of a pain – but found too punishing to really enjoy. So it was with dread in my heart that I booted up this year’s entry.

Reader, that dread was ill-founded. This is another decidedly old-school game, with its plot focusing on a missing relative with a mansion full of magic/weird science, a collectathon metapuzzle (the MacGuffins this time are colored rods), and puzzle-forward gameplay. But it’s actually a forgiving one: there’s a well-considered hub-and-spoke structure where you start poking around your uncle’s mansion and discover the time machine, then start to unlock different time periods to visit, each of which opens up further eras, gives you one of those rainbow rods, or provides items or info you need to access new areas of the mansion hub. This helps pace out what’s a reasonable-sized game, so that you’re always pretty clear on where you should be focusing your efforts, and regularly get the dopamine hit of making progress on one of your goals. And there’s no inventory limit, or ability to get the game into an unwinnable state.

Another departure from old-school sensibilities is that the game eschews the overly-terse style of the 80s, providing enough texture to make the time-travel exploration lots of fun, at least for this history-nerd. The periods you visit are all reasonably separate in time and place, and strike a good balance between being instantly iconic, while not making you visit eras that have been done to death (though the choices are admittedly entirely Eurocentric). While each is usually made up of no more than a handful of rooms, with only a little bit of scenery and an NPC or two, there’s enough here to give you some flavor and scratch that time-tourism itch; I caught a couple of fun Easter Eggs, and I’m sure I missed more (I’ll spoiler-text my favorite: meeting Watson and Crick as they discovered DNA, I was a little annoyed the author had omitted the contributions of Rosalind Franklin – but when you ask the duo about her, they shamefacedly admit they yoinked her work without credit). And while there are some anachronisms, usually to solve the puzzles, they’re kept to a minimum, thankfully, avoiding the zany kitchen-sink worldbuilding that I thought detracted from Somewhere, Somewhen’s effectiveness.

Speaking of the puzzles, they’re also a traditional lot: some codes with attendant riddles, some item-swapping, and a soupcon of key manipulation. None of them are that novel, and sadly some of them are not especially well-integrated and feel like the author’s put a puzzle in for the sake of having a puzzle: in the Runnymede segment, for example, the central dilemma is that the Barons have shut King John up in a tent until he signs Magna Charta, but they’ve neglected to provide him with the means to affix his John Hancock to the thing. But taken on their own terms, they’re for the most part satisfying to solve, and with rare exceptions are generally pretty simple, so at least the iffy ones don’t draw too much attention to themselves (there’s also a two-tiered hint system, that prods then spoils each challenge, to get the player unstuck).

As mentioned in the game’s blurb, there’s also a less-traditional sort of challenge to proceedings, which is that you need to set the time machine to a specific year in order to access each different era. But only once is the year just given to you; in every other case, you’ll be given a location, event, or more cryptic clue that the player needs to decode to figure out what year to put in. Keeping with the overall low-key vibe, the average player will probably know a couple of these off the top of their heads, and for the others a few seconds on Wikipedia will be enough to clear things up. But I still found it a fun dynamic, and I could see the need to pop open a web browser prompting some players to engage with the real-world history that’s teased in each era.

All told, I had a lovely time with Uncle Mortimer’s Secret. Sure, the gameplay largely consists of crowbarred-in puzzles, and the story is sketchy to the point of nonexistence (hopefully you’re not expecting much of a climax or denouement). And the no-looking-at-stuff-in-containers-or-on-supporters thing continues to be an annoyance. But it’s largely player-friendly, and has a certain hard-to-capture charm to it that makes those flaws melt away. If you’re in the mood for some low-stakes, low-friction time tourism, it’s hard to think of a better option.


I admit I cut this review off after “time machine” so as not to spoil what was next.

The screenshots seemed familiar to me, and so I also linked things up with Somewhere Somewhen. I know a lot of people do okay in, say, IFComp one year, and then they learn and do even better the next time with the lessons they learned. I’m glad to see that that’s (likely) happened in ParserComp, too.


The Muse, by Xavier Carrascosa

(In what follows, I thoroughly spoil this game, because I don’t think there’s any other meaningful way to discuss it. Ordinarily I’d say that if you’re interested in the thing, you should probably go off and play it on your own, experiencing it the way the author intended, before coming back to read what I wrote. This time, though, I have qualms about that recommendation – but even saying why I have qualms might obviate the whole point of this non-spoilery introduction. I guess I’ll just say that I have a significant objection to a major part of how The Muse engages the player, and while it’s a well-crafted game that’s self-consciously addressing moral questions, in my view it’s not sufficiently well-crafted or sufficiently sophisticated to clearly overcome that objection).

2005 was a while ago, though I fancy I remember it reasonably well. I was 24, finishing my 1L year. I saw my second, third, fourth, and fifth Mountain Goats concerts, including a secret Halloween show at the Knitting Factory – the venue schedule listed the band playing that night as the Hospital Bombers, but I recognized the in-joke and bought my tickets in advance. A solid 40% of my personality was hating the Bush Administration for enshrining torture in U.S. policy (it’s down to about 5% these days). Vespers won that year’s IF Comp; I reviewed it enthusiastically. As I recall, both player and NPCs get up to some rather heinous deeds in Vespers, and there wasn’t a content warning in sight, inasmuch as content warnings weren’t yet a thing. I don’t remember the absence bothering me (I already said I was 24).

The Muse is an English reimplementation of the Spanish-language original, La Musa, released in 2005. It contains no specific content warnings, though it does note it’s not suitable for children and may offend the sensibilities of some players; it’s right.

The game doesn’t do much to explain itself – it’s clearly one of those allegorical games short on specifics but long on associations. You’re in the dark, with a book, a bloody pen, a woman; you can examine everything you see, including yourself, but it doesn’t provide much illumination. Or rather, the muse does: “she emanates a reddish evil light that envelops your being and your book, impregnating the pages with blood.” However handy she’d be in a darkroom, she’s not much of a conversationalist – all she does is exhort you to write. The parser lets you decide what word or words to put down in the book, then when you look at her again, you’re thrust into a different environment – happily, it’s bucolic this time, and all you are required to do (or can do) is relax and rest.

Then you’re back in the dark with the girl and the book, and the process repeats. The gameplay of each scenario remains the same – it’s basically a guess-the-verb thing, you need to puzzle out the appropriate action to bring each to an end – but they grow darker in turn. You gorge yourself while watching a starving prisoner despair, you kill a soldier begging for mercy, with the muse’s voice coming in from off-stage to egg you on. In between the cycles, you write about whatever you want, the muse’s bit getting staler with each repetition.

The fourth vignette shunts you into a boudoir, where a naked woman is combing her hair. She’s also not much of a talker – if you compliment her on her hair, she says thank you, and if you tell her to stop brushing it (your only other option), she simply stands still. Unlike the other sequences which clearly prompted an action in need of completion, this one seemed more static. I tried taking the hairbrush, I tried breaking the mirror, I tried combing my own hair. This time, when the muse’s voice came in, it said “What are you going to do? What should you do?”

At this point I realized two or three things near-simultaneously:

  1. Each of these little scenarios was dramatizing one of the seven deadly sins; I’d worked through sloth, gluttony, and wrath.
    1.5. Oh, I’m probably dead and in hell, aren’t I?
  2. This game was really going to make me type RAPE WOMAN to progress.

The woman’s clearly a fictional construct; she’s got no agency, and has only a limited range of robotic responses to your behavior. Given point 1.5, and the way the characters in each of the other scenes seemed to poof into existence from nowhere when I showed up, as if they were created just to torment me with their little tableaux, and presumably returned to that same nothingness when I left, it’s an open question whether within the fictional world of the game she’s even meant to be a real person with subjective experience, or just a demonic illusion.



I walked away from the game for ten minutes, and when I got back, I typed it.

It’s over in a sentence, and of course there’s no detail, no panting, prurient narration to fog up the moral allegory. I went back to Limbo, and this time when prompted to write something in the book, I wrote about lust, and the game nodded its approval: the muse “understands that you now know you are doing penance and she is really your jailer. But smile anyway, because you are by her side and you still love her.”

I played through the rest of the game after that, three more sins. Pride is a fun one, you need to complete a bloody ritual, which involves some improvising with an altar and a blood sacrifice. Number seven is Envy and spells out what I’d guessed by this point: you’re Cain, the muse is Lilith (running with the tradition where she’s his lover and not his step-mom, I hope), it’s all punishment for killing Abel out of jealousy. Then the cycle repeats, because of course it does – but there’s also a way out, because of course there is, though the implementation wasn’t robust enough for REPENT or BEG FORGIVENESS to do the business. God’s forgiveness allows you to rest peacefully, though too bad for Lilith, “beautiful and wicked,” crying as you abandon her.

In 2005 MeToo hadn’t happened yet. If you’d asked me my favorite novels, I’d have probably listed Atonement (there’s a rape), Demons (there’s a rape), Ulysses (no rape so far as I can tell but not 100% certain). The way interactive fiction can make the player complicit in evil was still something of a novelty. Sam Alito joined the Supreme Court.

The Muse isn’t an irresponsible work. It propounds a set of moral ideas, which are wedded to a Catholic structure that pretty much requires something like RAPE WOMAN to hold together (theologically speaking you could end the sequence with COMMIT THE SIN OF ONAN, but in these fallen times it lacks the same heft). It gets the distasteful deed off-screen as quickly as is decent. And for all the murder and mayhem the average player of video games has committed at this late date, how fussed can one really get about two little words?

I still wish I’d walked away from it and never come back.


Thank you to you and some other reviewers who have picked up on what for me would be an absolute red flag issue re playing. And could have benefited from an in competition content warning. If there are other games with major possibly triggering content issues I’ll be very grateful if my fellow reviewers can highlight this. As it is I now know one game I need personally to pass on, regrettably,


In one of the endings in game Desrosier’s Discovery player has to join orgy. It’s made as two choices: 1 - join orgy, 2 - join orgy with gusto. No cw for that game either.

1 Like

Interestingly, the author of this one, Jim MacBrayne, has been around the text adventure scene for a long time and his games tend to be traditionally hard - but he’s definitely showing signs of developing a more merciful attitude towards his players in recent years!


Anita’s Goodbye, by IlDiavoloVesteRosa

An interesting consequence of hosting ParserComp on Itch has been the collision of traditional IF competition/festival culture with Itch’s more improvisational jam culture as folks noticed the Comp cropping up on their feed and decided to participate. In IF world, authors typically have their eye on a particular venue for their game and start work months ahead of time, building out and refining their game, then subjecting it to rigorous testing – please, always subject your game to rigorous testing. I’m much less familiar with Itch jams, but I’ll overgeneralize based on my limited experience (the wag who’s read the rest of this review thread will ask, how are Itch jams different from anything else I spout off on?) – as I was saying, based on my limited experience, jams tend to involve developers roughing something out and firing it off based on a couple day’s work, with minimal testing, just riffing off a new set of tools or ideas and seeing what sticks with the audience. Competitions seem more about setting ground rules that are rewarding for players; by that same token, the jam framework seem more about the author’s experience.

On the plus side, jams seem like a cool way to quickly test whether a particular approach is promising and get near-immediate feedback without much in the way of sunk costs; many indie games I like are elaborations of a no-frills prototype banged out as part of a game jam. At the same time, I’m not convinced the jam ethos is a great fit for parser IF. I think it’s most effective when it allows an author to generate a proof of concept for a game mechanic, and test out how it feels in play – plus a novel mechanic provides a hook to potential players, making it worth their while to put up with what’s probably a buggy, low-content game. But parser IF as a genre isn’t especially gameplay-forward, with prose, story, and characters looming large, and for me at least the quality of puzzles is usually less to do with their abstract mechanics and more about the extent to which they fit into the story. Sure, there are some IF games that are primarily about how they change the typical medium-dry-goods approach – the wordplay of Counterfeit Monkey, the sympathetic magic of Savoir Faire, the alchemical system in Hadean Lands. But even these mechanics would feel underwhelming, I think, if pared down to a series of minimalist examples, since much of what’s fun about them is seeing how they’re elaborated through the course of the game, and how they communicate the story’s themes in gameplay terms.

400 words of throat-clearing out of the way, we come now to Anita’s Goodbye. The perspicacious reader will have guessed by this point that it’s an example of the jammy approach I’ve outlined above – and indeed, the blurb reveals the game was made in four days, the download page offers two versions of the game file, one of which is labeled “finale now works” (I played that one), the comments threads are filled with players finding fiddly bugs and the developer cheerfully offering workarounds, and ParserComp is referred to as "Parser Game Jam” throughout. Beyond these extrinsic indicia, the game itself also plays the way you’d expect the product of a jam to play – the plot and locations are very lightly sketched in, with the main item of interest being a series of time travel mechanics that let you, and certain objects, move forward and backward through time as you attempt to bid farewell to the eponymous Anita.

If you judge the game by the standards associated with such a truncated, improvisational process, I have to say, I think it’s pretty successful. It’s true, even the fixed version that I played had some wonky technical features – the novice author appears to have implemented a lot of the game’s logic via a brute force approach to syntax that don’t take advantage of Inform’s ability to parse player input, such that verbs stop being understood depending on where you’re standing and some commands require to refer to objects with a “the.” And the story doesn’t expand much beyond the premise embedded in the title and opening narration, save for a final twist that renders much of the midgame nonsensical (in retrospect, how did a charged scooter help you get down the mountain?)

But it holds together well enough to function, and certainly is far more impressive than anything I could do on my fourth day with Inform! The time travel conceit isn’t implemented in a super robust way, but it does open up some fun puzzle-solving possibilities that go beyond the unlock-key-with-door standards of the genre. So again, as the product of a jam, I’d have to say nice job.

As an entry into an IF competition, though? Well, it doesn’t look so good using that lens. Like, even in this ParserComp, we’ve got the Impossible Stairs, which similarly has time travel as a major puzzle-solving mechanic. But that runs long enough to introduce some fun riffs on the basics possibilities of moving into the future and the past, plus has some fun characters to engage with and a neat overall story, plus is technically quite solid (I beta tested it, which is why I haven’t reviewed it yet, but even then it was in good shape). I’m not saying this to pit games against each other – let there be a million time-travel pieces of IF, it’s all good – but just to point out that from a player’s perspective, the traditional way of doing things seems to deliver better results. With that said, Anita’s Goodbye shows a significant amount of promise, and if, in the tradition of game jams, it’s a necessary step in getting the author to put more time and energy into a future work of IF, it’ll have served its purpose very well indeed.

anita’s goodbye mr.txt (54.8 KB)


Since the community is so generous with regard to beta testing, the benefits of publishing unfinished games seem slim. Through testing, a writer can get detailed feedback regarding a WIP while preserving their prospects for a successful launch.

Personally, I’d rather test an unfinished game than evaluate it in a contest, even though testing requires more time.

I’m not trying to police anything. People should do what they like with their own creations, my opinion be damned.


For a new writer, asking for testing is daunting. People have no way of knowing how kind and helpful this community is unless they take the leap. I was scared when I asked for testing for the first time last year, because I knew there would be major problems in the game, but didn’t really know how to find them myself, and I only have one person IRL who plays IF, who doesn’t code at all. I thought there was a good chance that I’d encounter meanness-- it being the internet and all.

For anyone reading this, take that leap. Ask for help here. You will not regret it.


Desrosier’s Discovery, by Ben Ehrlick and Isabel Stewart

In other recent reviews, I’ve banged on about one of the more interesting trends in contemporary IF, which is a breakdown in the previously-sharp boundaries between choice-based and parser games. Sometimes this takes the form of choice-based games with a world model and verb-object interfaces; sometimes it’s story-based parser games that eschew puzzles or offer a limited parser; and sometimes you see straight hybrids where parser sections alternate with scenes that require choice-based navigation. There are a variety of effects and affordances provided by these varying approaches, and it’s a neat feature of the current scene that this wider palette is currently available to authors. In this case, the authors of Desrosier’s Discovery have opted for the third option, with laser-eyed clarity on what this structure buys them: an effective delivery mechanism for really dumb jokes.

You don’t start out expecting that, mind. The game opens with old-school green text on a black background, with an even older-school premise: yes, it’s generic Lovecraftian plot #3, your old friend Professor Redshirt sending you a letter telling you to join him at the site of his latest dig (entertainingly, you’re told that “you recognize the handwriting immediately as belonging to Professor Desrosier, an old colleague, and an old friend.” ALL THREE HAVE THE SAME HANDWRITING??? The record will show I am ride or die for the Oxford comma, but probably should have fixed that in post).

Anyway, one ferry ride later you’re picking your way through the abandoned dig site. The custom parser’s no great shakes – it doesn’t recognize L as a synonym for look, and in my browser at least (I think it’s web-only) it didn’t deal well with text that spans more than one screen – but it does the job well enough as you notice the nicely-rendered runic carving on the not-at-all-ominous stone door at the base of the dig. So far so Lovecraftian, especially once you enter the small expedition log and read the last entries in your missing friend’s diary (found in a desk which isn’t described as having a drawer; the game also hanged on me the first time I tried to read it, though thankfully I didn’t encounter that bug on a replay).

Then you solve generic adventure game puzzle #1 (I’m not gonna spell it out, but you’ll definitely know it when you get there) and find a table with half a dozen different objects, ranging from the useful – a gun – to the incongruous – a box of dog treats – to the notionally comedic – a big box o’ phylacteries. And here the structure shifts, because depending on which one you pick, you get shunted into one of several different mutually-exclusive choice-based vignettes – and so too does the mood, which takes a turn for the zany. There are still some stakes, as the wrong choices can lead to bad ends, but they’re all played for laughs so the gameplay is less about picking the right options to get the intended result and more about lawnmowering through to see all the jokes.

The jokes are dumb, but to my mind that’s not necessarily a bad thing. There’s one that made me laugh – you’re given the choice whether to participate in a particular rite, or to do so with gusto, which get you the same ending but picking the more stylish choice gets you an additional five points in the totally-meaningless score you get as the game wraps up. And I defy even the starchiest sophisticate not to snigger at least a little at the ending involving Father Angus.

I found the fun wore off before I’d completed my replays, though. Partially this is on me – but for my completionist streak, I could have quit any time – but of course I’d still have had to hit a bum ending or two to decide to put a stop to things. There’s a Scooby Doo parody that goes on way too long to justify the limp twist of a joke at the end, and a digging-to-China gag that’s fine enough so far as it goes, but lost me with a throwaway reference to 7th-century explorers finding an “antique opium pipe from the opium wars” in their antipodeal adventures (the opium wars were in the 19th Century! There was no opium in China until the British forcibly introduced it to prevent their trade deficit from draining the national silver reserves!) It isn’t just the staleness of some of the gags, though – while a straight choice-based game could probably have been set up to facilitate easy replays, here you have to go through the whole opening then type in the half-dozen commands to get to the item choices, all the while dealing with that page-scrolling interface annoyance, all of which makes redoing the first half of the game a chore.

Indeed, while I’m usually all for experiments that break down the boundaries between parser and choice games, here I think it might have been a mistake. There’s one ending branch that doesn’t shunt you off into a series of choices, and sticks with the parser interface throughout. This is one of the few where you actually encounter the eponymous Professor, and it has what I thought was the best gag, where the game throws a head fake at you, but if you type in a counterintuitive command, you’re rewarded with what I think is the best ending. It’s a sequence that shows that there’s yet fun to be had with an old-style parser, and I think the game might have been better for it if the authors had stuck to their guns, rather than slap on a bunch of choice-based sequences that fit awkwardly into their custom engine.


This had me snorting coffee out my nose. Ah, commas. The joy they give us.

(My last cup of coffee before I’m off to France BTW. Enjoy the Comp! See you in a few weeks.)


Improv: Origins, by Neil deMause

A prequel arriving more than two decades after the original series wrapped up, Improv: Origins is a funny, deep one-room puzzler that makes me interested to check out the sequels it sets up. There’s some old-school difficulty, plus a nasty bug or two that made things even harder than intended on my playthrough, so I can’t help bemoaning the lack of modern conveniences like a hint menu, so the game’s definitely not for everyone, but the entertaining cast of characters and intricate puzzle design made me glad I powered through (and, er, begged for help on the forum when I got stuck).

What we’ve got here is comedy superheroes. I see you shuffling for the door, and I know, I know, that sounds pretty dire. But the game makes a great first impression, with sophisticated jokes that go way beyond the typical played out super-parody. Like, your hero is a temp – so far so standard, but the reason the bottom’s dropped out of the heroism game is that a superhero bubble has just burst. The game’s set in a bank – your job is to open up a locked safe after the bank fired the inventor who created it, and they huffed off without sharing the trick of accessing the thing – and as a result there’s a set of economics jokes that kept me laughing, like the painting of two financial-themed heroes, PIN and Teller. Sure, much like with the game as a whole the author must have been sitting on that one for several decades, but it still got me.

It quickly becomes clear that the challenge on offer is no laughing matter, however. As befits a good one-room game, you’re presented with a clear goal and a dense space to explore in hopes of finding an answer. Atypically for this sub-genre, though, soon enough you’re not alone – your MacGuyver-themed superhero is eventually joined by others whose powers include object-finding echolocation, Google News searches avant la letter, and deep familiarity with the dictionary. This is the crew, presumably, that star in the 90s-era Frenetic Five games, and their powers – and personalities – strike a good balance between being comically useless and surprisingly helpful. The group is implemented well, too, with the team serving as a Greek chorus to some of your more hapless flailing, and interjecting into each other’s conversations with the occasional bit of kibitzing.

For all the fun banter and clever writing, though, the game is very much structured around that puzzle, and as mentioned up top, I found it to be a doozy. After finding that the obvious ways to try to open the vault end in failure, I wound up doing a lot of further poking and prodding in the environment not because I had a clear sense of how it would be helpful, but just because it was something to do. And this single big puzzle has a lot of sub-steps, some of which can feel more frustrating than they need to (the mini-puzzle of accumulating rubber bands especially seemed like it ended in anticlimax, though the bug I mention below might have contributed to that). There are definitely high points – I felt super clever when I sussed out how Lex’s word powers could be leveraged – but also moments where it seemed like reading the author’s mind, or using out-of-game thinking, was necessary to progress, and overall I spent a lot of time banging my head against the wall.

What’s worse, some of that banging was occasioned by what seemed to be bugs. The blurb indicates that it’s meant to be impossible to render the game unwinnable, but I think I managed to bork it up by taping the rubber-band ball to the book, which rendered the former object unusable and didn’t seem to be possible to reverse. I also was sent on a wild goose chase when looking for a password for the vault, after consulting with the finding-specialist Clapper to locate it: typing ASK CLAPPER FOR PASSWORD results in the heroines herself starting to beep, which by the rules as they’ve been spelled out indicates that she should know, or somehow be, the password. But that appears to be completely incorrect, unless I missed an alternate solution.

These are significant downsides to the game, and again, there’s no integrated hints or even separate walkthrough file to hold the player’s hand, which makes me think some might not make it to the end. Still, I think there’s more than enough creativity and humor here to make Improv: Origins worth trying. What’s even better news, the ABOUT text indicates the author’s return to the IF scene looks to be no one-time thing, so I’m looking forward to seeing more of their work – and as mentioned, I’ll likely check out their older stuff too, though I hope someone’s hacked together some walkthroughs in the intervening decades…