Making Glulx Files Playable in Browser on

Hi. I’m looking for some basic help setting up an Inform 7 game to publish on as playable in the browser using the interpreter. It’s mostly working, but I’m having some difficulty getting it to display just the interpreter, not the entire index.html page, within the frame. Here is what I have done so far:

I’ve created a new release from the Inform application, including a website, cover art, an interpreter, and the introductory postcard.
I’ve prepared a zip file of the Release folder and uploaded it to the site.
I’ve selected “HTML” from the drop-down option for the kind of project.

I can now see “Run Game” in the browser when I bring up the page preview. However, it then opens the Inform project web site within this frame, and the interpreter opens within a smaller sub-frame.

How can I fix my release package so that it just opens the interpreter within this frame? I have tried removing the web site from the release section of the source code, then preparing a new zip file and uploading it, but this doesn’t seem to have changed anything.


As an update, I have found a workaround for this. Instead of embedding the web site in a frame, I changed the embed option to “Click to launch in fullscreen” so that it replaces the game page with the Inform project index.html page.

If I change it back to embedded, I can also edit the dimensions of the frame, but still no luck making it so that just the Quixe interpreter loads in the frame.

1 Like

Edit the play.html file and remove the following lines:

<div class="coverimage"><span><a href="Cover.jpg"><img src="Small Cover.jpg" border="1"></a></span></div>
<div class="links">
<div class="smalltitle">[Title of your game]</div>
<li><a href="index.html">Home page</a></li>

and (optionally)

<div class="interpretercredit"><a href="">Quixe for Inform 7 (v. 2.1.2)</a></div>

Then add this right before the line at around the middle that says </head>:

  #gameport {
    left: 0;

If you want the interpreter to launch directly without first showing the generated front page, replace the index.html file with the play.html file.


Thanks for your help! I’ll try that out.