MacOS Catalina 64 bit support?

Many of the interpreters that are available for Mac (Zoom for example) are not compatible with the next version of MacOS.

Are there any plans to update the various 'terps for Mac? Is there a work-around in the mean time which allows me to use the current systems on Catelina?

There was quite a bit of effort put into making Frotz simple to compile and run on MacOS. Do you have access to a Catalina machine? I’d love to get a beta-test report for Frotz on it.

I am on the fence with upgrading. I don’t want to upgrade before I know what stuff I’ll lose access to.

You may know this already, but if you go to About This Mac (from your Apple logo icon), click “System Report”, then select “Software -> Applications” from the list on the left, a table will show up that has a column at the end (“64-bit”) with a Yes or a No for each application on your Mac.

A “No” in that column means whatever that application is, it is very likely to not work under Catalina. It’s slightly more complicated because some apps might be 64-bit but still be using 32-bit licensing apps and/or installers.

2 Likes

Yes, that’s how I found out about the problem. It’s great you posted this, because other Mac users should check this screen as well before upgrading to Catalina.

There is no work-around for running old (32-bit) apps on Catalina. If you need one, put off upgrading.

Zoom hasn’t really been compatible with current MacOS for years. Lectrote is up to date. Gargoyle and Spatterlight have recent releases, although you have to dig around for them.

Inform 7 is a problem. The System Report page lists it as 64-bit, but actually it has 32-bit components; the IDE runs but compiles will fail. I have been in contact with Graham about this, and he intends to release a rebuilt version (of the current version of I7). But I haven’t gotten a release date for that.

Announcement about I7: http://inform7.com/releases/2019/10/10/catalina.html

Instead, a fully 64-bit version of the current Inform will be available for download here in the next few days, and shortly after that on the Mac App Store.

3 Likes

There is no comfortable way to use 32bit, but there is also the virtualization way. If you havn‘t upgraded to Catalina yet, but want to try Catalina, you can install it in one of the popular virtualizers. This might even provide some kind of integration into your host system, so you can launch the required apps directly in your host system. This of course can also be done the other way around. If you are on Catalina yet, you can still officially download Mojave from the Apple site and virtualize it.
You could also dual-boot. If you have an APFS drive, you even don‘t need to repartition, but instead use an APFS container.
Well, only workarounds, there is no nice solution. Catalina invalidates of lot of older software and hardware. I still have almost 200 32bit apps on my system. Many of those will probably never get an update (drivers, emulators, old games,…)

2 Likes

Hi everyone,

I’m in a similar boat. I just bought a new MacBook Pro this week, which came with Catalina whether I wanted it or not. Zoom has always been my Z-code interpreter of choice, and as we know, it’s kaput under Catalina. However, I’ve subsequently found Spatterlight, Yasmin, and Lectrote, so all is well.

The only problem I’m currently having is not being able to find an interpreter that can handle .z6 files. This is something I can live with, but is there anything I’m missing? An interpreter I’ve overlooked? If the answer is “there’s no workaround at present time,” or “You’ll just have to play Shogun or Journey in a DOSbox session,” that’s fine. I appreciate everyone’s hard work on these interpreters.

Joe

2 Likes

I’m unclear on what exactly I have, but my local copy of Shogun and Journey each came in a RAR file containing both a .blb blorb file (which, I agree, won’t open in Spatterlight or Lectrote) and a .ZIP file, with a readme that says:

Launch the .ZIP file in your Frotz machine - it is not a broken archive but a Zork/Zcode Interpreter Program.

I was able to use Homebrew to brew install frotz; with Frotz installed, I could frotz shogun.ZIP and get a running game. (EDIT: it doesn’t/can’t include graphics; brew install frotz installs a text-only version of Frotz.)

But, uh, what the heck do I have here? I, ah, don’t have a record of how I acquired this ZIP. How would anyone but me make it?

1 Like

Sounds like somebody combined the game files from an original release of those games, with the graphics data converted to blorb files, as available from the IF Archive.

1 Like

Thank you both very much. I do have the .blb files, plus a .z6 file for each game. I took a look at the IF archive for a Mac version of Frotz, but the only ones I saw appeared to be several years old. I didn’t try Homebrew, but if the result is a text-only version, I’ll probably just stick with using DOSBox to run the PC version of the few games in question.

Funny how it seems to be getting harder rather than easier to run some of these older games on modern machines. Again, I appreciate the input.

Hmm. Any update on this? I’m looking at Inform in the Mac App Store right now (on 4/22/20), and it says the current version (1.65.1) was uploaded 3 years ago, and is “Mac Sierra” compatible. The first comment on the app says it doesn’t work under Catalina. Just wondering if it’s still in review or something.

EDIT: I just downloaded it from the App Store and tried to compile a “Hello World”-type game, and the compile hung without completing. So yeah, the App Store definitely doesn’t have the updated version.

EDIT #2: Downloading the interim version from the Inform page allowed me to compile and run the test program, but oddly, I get no cursor in either the source code window or the gameplay/output window.

The cursor issue is noted here: http://inform7.com/mantis/print_bug_page.php?bug_id=2116 . It only occurs when MacOS’s dark mode is turned on.

1 Like

It took some effort, but I managed to compile SDL Frotz, the version with graphics. @DavidG has applied my updates to Frotz’s documention, and I’ve also filed a PR to update the Homebrew formula for Frotz, to make it install the SDL version.

So probably in a week or so you can just brew install frotz (or brew upgrade frotz if you already have it installed) and you’ll get a working copy of SDL Frotz.

If you’re feeling impatient, here’s what I did.

I installed Xcode 11.4.1 from the Mac App Store on macOS Catalina 10.15.4, installed Homebrew from its setup script, and then I ran this command to install all required dependencies.

brew install libao libmodplug libsamplerate libsndfile libvorbis \
  pkg-config sdl2 sdl2_mixer freetype libpng jpeg zlib

With that done, I checked out the latest version of Frotz from Gitlab (which has build fixes not available in the latest frotz-2.51 release), and I ran make all. That builds a binary sfrotz in the current directory. I was then able to run ./sfrotz ~/Downloads/shogun/shogun.ZIP, which, since it appeared alongside shogun.blb, was able to load and display images.

1 Like

Infocom sometimes used .“zip” as the file extension for the Z-code file in their MS-DOS releases. What you’ve almost certainly got in “shogun.zip” is not a zip archive containing other files, but a file containing the Z-code data. The idea of giving them a file extension with the Z-code version (i.e. “.z6”) is a post-Infocom thing.

1 Like

Ah, thank you. I am indeed running dark mode.

Fabulous, Dan! I understood about 70% of what you just said (haha), but I’m really impressed with your results. In the short term, I have Arthur, Shogun, Zork Zero and Journey running under DOSBox. Not ideal, but good enough to let me scratch the itch to play those games without running to another computer, or installing another emulator.

Catalina, I love you, but your adjustment curve is steep.

For now, I’m afraid I can only agree with one of those statements. :wink:

2 Likes

My Homebrew PR has merged, so SDL Frotz now installs cleanly on Catalina via Homebrew.

Just install Homebrew in the normal way, then brew install frotz. With that, I was able to run sfrotz shogun.ZIP on my ZIP file, with shogun.blb in the same directory, and the game worked normally, with graphics.

I believe sfrotz is now the only interpreter that works on macOS Catalina and supports Z6 games with graphics.

5 Likes