Macintosh I7: Rogue copy of Standard Rules

When I open the Standard Rules within the Mac IDE, I seem to be getting the Standard Rules from an old build. For instance, the “examine undescribed containers” rule is listed in this copy of the Standard Rules and the “examine containers” rule isn’t. Inform is using the up-to-date Standard rules, as the “examine containers” rule is firing at the appropriate time; it’s just that the wrong copy of the rules is opening in the IDE.

Anyone know how I can fix this?

There is a probably a copy of the Standard Rules in your user extensions folder (as opposed to the built-in extensions folder). If there is a version of a built-in extension in the user folder, the latter overrides the former. Just delete the version in your user folder and you should be good.


Ah! Well, I couldn’t find the old copy of the Standard Rules and still don’t know where it is, but I finally managed to use “Show Package Contents” to find the new version of the Standard Rules (it’s under Contents/Inform7/Extensions/Graham Nelson – I hadn’t found the Inform7 folder before because there is a remarkable amount of stuff to look through in the “contents” folder). Then opening that up from the Finder and installing it worked.

Still not sure where the rogue version may be hiding, but I don’t need to worry about it anymore.

I’m glad you figured something out. However, you’ve now replaced the old local copy with a new local copy, which means that you’ll have to repeat this process the next time a new Inform is released. In other words, you’re still working from a local copy of the Standard Rules rather than the built-in copy, and the next time Inform is updated, that local copy will override the built-in copy. Here’s some info specific to OS X, which it sounds like you are using:

The built-in folder is the one you found after peeking into the app package’s contents. What almost certainly happened when you clicked on “Install” after opening the Standard Rules from the built-in folder was that the extension was copied to your local extensions folder, overwriting the old version.

You can find the newly installed copy and just delete it by opening it from within the IDE, and then Command + clicking on the filename at the top of the document window. This will bring up a little pop-up list showing the directory path to the file; you can click on the parent folder to open it, then delete the file. Your local folder is probably located at /Library/Inform/Extensions. When you find the folder, you might want to make an alias so it’s only a single click away.


Thank you, that seems to have worked, and the folder was where you said.

If I’m not mistaken, the moral is not to install the Standard Rules, even though the IDE keeps bugging me to; that’s what creates the extra copy that won’t get updated. (Actually, there may have been a grayed-out copy of the Standard Rules that I could’ve opened to get the new version. Still, it seems unnecessarily confusing.)

Yes, that reminder seems like a bug. I get it too.

I’m not sure it’s a bug, per se–it’s just poorly named. The message to “install” should be something like "This is a built-in extension and cannot be edited. To make changes to this extension, I will first need to make a local copy in your Extensions folder. Would you like me to do that now? You will be able to begin editing immediately. ".

In the absence of such a message, though, it is confusing enough that having no message at all would be preferable.

I’m pretty sure that I’ve reported this at some point, but I don’t know when or where…


I’ve submitted it.

In retrospect, I think I got snagged on this very issue as well. Definitely counter-intuitive as named.

Here’s more discussion at the bug tracker – it was a duplicate bug, apparently, but they seem to be looking at Erik’s fix.