(Mac) IDE hangs up when searching a certain string

I was just doing some tests on my WIP and I tried to search through the game output using the search string “ii”. I got a beach ball that lasted for several minutes, so I forced quit. When I tried searching for “ii” again, it froze a second time. I created a test project with only the words “Test is a room.” in it. Searching for other strings works fine, but searching for “ii” causes it to hang consistently.

I’m attaching the preferences file in case that helps. It does seem to contain several recently used search strings. The plist extension was not allowed, so I added a .txt - hopefully that won’t cause the binary contents to be mangled too much.
uk.org.logicalshift.inform-compiler.plist.txt (8.35 KB)

Yep, that’s a bug; if you file a report, I’ll confirm it. Give me a little bit, and I might be able to say something about the cause too.

Were you able to reproduce it using that prefs file?


I couldn’t figure out how to attach a file to the issue. Please let me know if I should still do that.

Sorry, I could have worded that more clearly. The bug I’m looking at is independent of the preference list, so I was able to reproduce it. There’s an explanation and workaround posted as a comment on the bug report. However, if deleting the preferences file was a workaround for you, it might be that we’re talking about two different bugs. What happens when you try the steps to reproduce in my comment after the preference file is gone?

No, I think I was mistaken. I hadn’t thought that the cursor position would make a difference, so I wasn’t watching where it was.

Ah, okay. I’ve updated the bug entry accordingly. Thanks for the report; this could have been a lot harder to track down than it was.