Login error

what’s this mystery login error, i’ve been getting for a week now. Anyone else seen this or just me?

No, I don’t experience that.

Whenever I press the “Log in” button (starting from a logged-out state), it pops up the “Welcome back” login dialog, and immediately over that an error box saying “Sorry, an error has occurred”. Pressing the “OK” button on that allows me to log in with a password without apparent ill effects. (Firefox 115.7.0esr.)

“About a week” seems about right. It feels to me that it appeared about the same time as “Log in with a passkey” did on the login dialog proper, but that might not be true.

1 Like

ok thanks. must be me. maybe aliens?

1 Like

@jkj_yuio What browser are you using? I’m using Chromium.

That generic error seems to come up multiple places on Discourse.

Since not everyone experiences this, it could be something with your browser, it could be something with your login behavior, or it could potentially be a Discourse update that’s not playing well with your specific browser or security measures.

Are you logging out and leaving the tab open, then logging back in? Does this ever happen with a completely fresh new browser window? (I never log out unless troubleshooting other accounts and then usually I log right back in. I’m using Safari.)

The only time I’ve seen that error a lot is when I have the forum open in two windows and I’m updating in one, the other will get confused like it goes “hey, the pointers aren’t where I put them!” and needs to reload to update also. Are you logging in elsewhere while you’re logged out and leaving the tab/window open?

I’d try all the normal browser troubleshooting - refresh the page before logging in, close all browser windows and re-open, clear cache, if it persists clear cookies, see if it happens using a different browser, computer or device. It could be corruption in the cookies the system sets not playing well with an update (that did happen about a week ago) - sometimes just completely re-loading the site instead of persistently keeping it open clears some issues.

Since everything works after you hit okay, I’m wondering if Discourse has just timed out the connection somehow, or if you have some browser security measure that’s not letting it do its thing.

1 Like

@jtn that’s exactly it.

And it could be something to do with your update. about a week ago. before that, no problems and i have not changed the browser. @jtn has posted a picture too.

Yes fresh bnowser. switched it off and on again. cleared cookies. said abracadabra. turned round 3 times while wearing the ruby slippers.

So in that case it’s kind of hard to diagnose. Since it’s intermittent and doesn’t subsequently keep you off the forum it’s likely an update glitch. As Dannii has mentioned, the Discourse devs usually fix things very fast as multiple Admin from sites report them. Usually minor issues like this will resolve with the next update.

If you’re inclined, you might want to research and report this anomaly on Meta, or discuss if there’s a thread with people having a similar issue.

I’m of course not implying we’re washing hands of this, it’s just usually part of the natural update-problems-fixes process with most software. It’s not helpful to Meta for us to report-by-proxy “some users intermittently have these random problems but then it’s fine” - especially if we can’t reproduce it personally, to which they’ll usually reply “known, working on it for next patch…”

1 Like

I usually log in to the forum only from a private-mode browser window, so it should be pretty much completely fresh in terms of cookies/cache. (Also, this computer and hence browser gets restarted at least once a day.)

(I realise this is an unusual pattern, which is why I didn’t flag this until someone else mentioned it.)

I also see the same error if I press the “Log in” button in a non-private browser window.

(For the avoidance of doubt: I never saw this before a week or two ago. Now it happens to me every time, consistently.)

If I’m watching the “console” tab in Firefox’s “web developer tools” when I press the “Log in” link, a big pile of barf appears at the same time as the error box. (The red bits; the prior yellow/white bits are pre-existing grumbles from when I first loaded the page.)
I can post the whole barf if you want. I can’t find an actual error message in it. I’m not familiar with this output, but it looks like a backtrace-ish sort of thing; I’m guessing from the presence of words like passkeyLogin near the top that the error might have something to do with the “passkey” functionality (is this new?). I don’t know what that is, and I don’t use it; maybe I’d have more trouble if I did.


This is helpful, thank you.

It’s mentioning a plugin “scrollable post content” so I can twiddle that as well, though that might not have to do with all the red logs.

I’ve got a draft on Meta but I’m not gonna post it until I know it’s not just “shut off this deprecated plugin…”

I updated “Scrollable Post Content”. Let me know if the error still occurs. If it does, I’ll try temporarily disabling this plugin.

I was directed that this was likely an error that was fixed.

We are upgraded to the latest update so if it still happens, it’s the usual…refresh the browser, clear cookies and cache to make sure you’re not harboring remnants of old cookies or code.

1 Like

I’ve been having untold problems getting intfiction.org to load at all over the last week or two, so I cleared all 57 MB of cookies and tried again. It still took an eternity to load, but I eventually got the home page, logged in and got the error message, but the log in worked. So, whatever the error was, it hasn’t been fixed…or fixed properly. I’m using Firefox on Windows 7.

1 Like