Installing 2112 (George K. Algire, 2001)

I’d like to download and play this game:

2112 - Details (

On its IFDB-page, there’s a Windows Application (2112.exe) that gives an error message when I run it. Something about missing supporting files.

Beneath the exe-file, there’s a list of dozens of sound-files (wav). There’s also a file called “Richtx32.ocx”, which is apparently the library the game uses.

I suspect I can do without the sound files (?), but a game definitely needs a library. When I tried downloading that library-file however, my computer refused, stating this kind of file may damage my machine.

Anyone more technically inclined than poor ol’ me who can explain/give pointers?


You may want to take a look at the documentation:

It says runs under Win95. Does DosBox exists for your OS? If so, you could also try to run the game through DosBox (or maybe WINE).


Ah, the structure is at the ifarchive: Index: if-archive/games/competition2001/windows/2112

Compressed in one file: (3.3 MB)

It seems to run under WINE :slight_smile:


FYI, for Win95, DosBox is not the best solution - or even a really workable one in all but the most basic cases. The authors of DosBox do not ever intend to make Windows a supported thing, and the fact any Windows applications work on it at all is mostly just luck.

DosBox-X is a fork that supports Windows games way better.


.ocx files are really just a form of .dll files, containing executable code that implement the old Windows ActiveX control interface. Back in the day they were commonly used by Visual Basic, and that’s what the IFDB page suggests it’s written in, which makes sense. Without more details it’s hard to know whether it was your browser, your anti-virus or how WIndows is configured that made your PC refuse to download it. It’s probably okay, or at least, no worse than downloading any other sort of executable code from the Internet. As ever, you have to balance the risk against what you want to do.

As other people have mentioned with comments about DosBox and similar, a safer approach is to have some sort of VM environment with an old version of Windows running in it, and run any executable you’re not completely sure about within that: then when you’re done you can delete the VM and be pretty sure nothing bad is left on your PC. But that is more effort to set up.


I just tried it by unzipping that zip-file. It ran directly in Windows 10, as long as the folders are correct. No need for DosBox.


I’m on Windows 11.

I unzipped the zip-file @cibersheep provided. When I try to run the game file, I get:

Run-time error ‘339’
Component ‘RICHTX32.OCX’ or one of its dependencies not correctly registered: a file is missing or invalid.


It’s not enough for richtx32.ocx to be there, it has to be registered in the OS registry. If you open a command prompt, go to the directory containing those files, then run “regsvr32 richtx32.ocx” as a command, then that should fix it. You may need to have that command prompt running under an administrator account for that to work, depending on how your PC is set up.


I see. I have not used Windows in more than 10 years. I can only say it works on Linux with WINE (but game crashed if you double click on some of the words of the description ¬¬)