[inklewriter] fixing a script error?

Hello everyone,

recently I ran into a problem with inklewriter, and I’m wondering if anyone has had a similar problem; or might be able to think of a way to help out.

I’ve been writing on a fairly long story, using a lot of logic and flags. While the story grew in length, eventually Firefox reported a script not answering, but when I chose to wait for it, inklewriter snapped back into action.

I was about to finish the story, but now that same script will freeze, and waiting on it won’t fix the problem. As a consequence, I’m no longer able to log into my account, as inklewriter will attempt to go back to the (corrupted?) paragraph, triggering the unresponsive script every time.

So I am stuck with this:

inkle2.png

Steps I have taken so far:

  • Configured Firefox to wait for the script to complete, up to 60 seconds.
  • Updated Java to the most recent version.

Sadly, this did not fix my issue.

Does anyone have a suggestion for me?

Thank you for considering the problem!

Have you tried “debug script”? Depending how it’s configured that might let you break out of the deadlock while keeping everything else running.

Hello Draconis, thanks for your reply :slight_smile:

Well, yes and no. I have played around with that, but unfortunately, I don’t know how to work the debugger in Firefox.
The script mentioned in the error message fills a whole page if I post it in a text editor, so I don’t know where to begin when trying to break out of the deadlock, as you suggest.

This is the debugger fyi:

inkle5.png

Have you tried using a different browser and seeing if it’s also freezing? Firefox can be kind of hinky sometimes and switching to Opera or Chrome works for me most of the time.

You’ll probably have to contact Inkle directly with a bug report. It’s unlikely that this can be resolved without fixes to the editor on their end.

Hey guys, thanks for your input and suggestions,

Yes, I did try it with Chrome, which simply told me that the website becomes unresponsive after an (eerily similar) amount of time, and presents me with an option to “wait” on the page or “kill” it. I will give Opera a try however, since you suggested it.

I did :slight_smile: Is there any way to get in touch with them on support issues? I used info@inklestudios.com, as I found no better option.

I’m pretty sure I somehow broke my story with too many flags or random variation. In debugger, I can see the last paragraph I worked on, and it looks really buggy (giving choices that don’t belong there and the End at the same time). I’m unable to delete it however and/or rewind my story in the editor.
Meanwhile, my proofreaders still access my story (via the share link) and push me to finish it. I was wondering if anyone perhaps has any experience on the limitations of inklewriter? I’d hate to abandon the app, but I don’t think I’ll ever go back if I don’t know how I caused this.