Inform7 on Ubuntu 20.04

In have installed Inform7 on Ubuntu 20.04. DPKG shows: gnome-inform7:i386 as installed.
But I cannot figure out how to RUN it.

Depends on how you normally run programs. As with all things Linux, the details of your setup matter. (In particular, Ubuntu can be run with any of several desktop environments installed as part of the operating system, and more can be added and used post-install.)

First, check to see whether the install process has left a launcher item in your desktop environment’s “applications” menu. If you can’t find one, try opening a terminal or bringing up a “launch program…” dialog box (possibly Alt+F2) and typing gnome-inform7.

(I moved this to the Inform 7 category.)

1 Like

How did you install it? What repo offers it, or where did you get the .deb? from gnome-inform7-builds on github?

If you open a terminal window and enter ls /usr/bin/*inform* you’ll probably see an entry for/usr/bin/gnome-inform7. If so, @patrick_mooney’s advice should work perfectly.

1 Like

In my Debian Inform,with Mate WM, Inform 7 is run from an appropriate icon on top panel, a custom launch setup.

As Mooney says, Linux’s freedom isn’t only free as free beer: it’s also freedom of setup, configuration, hacking, use &c, but as ol’ Benjamin Franklin notes, with freedom came also responsibility… in this case, of knowing where things are.

as Zed notes, searching in the various */bin dirs (there’s not only /usr/bin/, but also /usr/local/bin and even ~/bin.

The search path can be found with this command line:
$ set | grep PATH

and there’s a convenient tool, appropriately named whereis: you should do also:

$ whereis gnome-inform7

HTH and welcome to Linux,
dott. Piergiorgio.

1 Like

Thanks all, for the quick response.
The problem is with my install:
dpkg -i gnome-inform7_6L38-0ubuntu1_i386.deb
does not install properly because of unmet dependencies from a lot of xxx.:i386 packages, like libc6:i386, libcairo2:i386…etc.
When I run apt --fix-broken install, it uninstalls inform7.

Are you running on a 64-bit machine? If you don’t have any other 32-bit programs installed, you might just need to enable multiarch support. (TL;DR: try sudo dpkg --add-architecture i386; sudo apt-get update in a terminal.)

If you’ve already done this, it won’t do any harm to do it again, so it’s safe to try. Doing sudo apt-get update; sudo apt-get dist-upgrade in a terminal might theoretically help with some potential issues, too.

EDIT. My phone’s autocorrect has some wacky ideas about what I might Really Mean by those terminal commands.

The easiest way to get the IDE on Linux is with the Inform 7 for Linux Flatpak package.

If you don’t like flatpaks, then read on for details that may be helpful to you.

First, you probably don’t need to use the i386 version. If your system is x64, you can use that version instead and avoid the need for multiarchitecture support.

Second, as you have discovered, there are some dependencies that cannot be met by the 20.04 repository contents, but which can be satisfied via manual installation of packages from the 18.04 repository. See Gnome-inform7 6L38/6M62 IDE now running on modern Ubuntu & Fedora OS for the gnome-inform7 download I used (put together by user @interactivefiction). Post #74 in that thread lists the specific packages that must be pre-installed to satisfy gnome-inform7 requirements and how to get them.

2 Likes

Thanks. I finally got it working.

2 Likes

I made this, in case you do not really care about the IDE:
https://intfiction.org/t/a-couple-of-scripts-for-installing-and-running-inform7-in-linux-from-the-cli/44628
Just my two cents :stuck_out_tongue:

1 Like