Inform7 on linux cant reopen project


i cant reopen project that was working on with mac. i was able to unzip file, it seems legit there could be some errors in story but inform closes. also after working some time with inform7 my mate panel disapears but that could also be problem with low memory of my graphic card.

The Inform project files are supposed to be compatible but there may be a bug.

You could create a new project on Linux and then copy the Source/ file in from your zip file. That’s the source code, which is the important part.

sources from mac to Linux… the latter use Line Feed (LF, Ascii 10/$0A, \n), the former Carriage return (CR, ascii 13/$0D, \r), seems to me a classical problem with a classical solution…

Best regards from Italy,
dott. Piergiorgio.

Actually I cannot imagine that Inform could not handle different line terminators from mac and linux.

I had this issue with xvan, below is some C code that solves it for me.

static int NextChar(FILE *fp)
  /* will read dos, mac and linux text files  */

  int c;
  int nc;

  c = fgetc(fp);

  if (c == '\n') {
    /* must be linux                    */
    /* '\n' is ok to return for windows */
  else {
    if (c == '\r') {
        // mac or dos
        // look ahead for '\n'
        nc = fgetc(fp);

        if (nc != '\n') {
          /* must be a mac, put back nc */
            ungetc(nc, fp);
        c = '\n';
  return c;

Mac Inform stores source files with \n ($0A) line breaks.

Really, all Mac programs do nowadays, as far as I know.

1 Like

as quick fix i opened source file with pluma (mate text editor) and ctrl-c/v to new project.

I ran into this problem once, and it turned out to be the skein having some flavour of double-quote character in it. I know that used to crash the macOS Inform when loading a project, I haven’t tried it lately.

Hi! Is it possible to share the project file that made the Linux IDE crash?

ill try to regenerate situation later i think i still have some files intact. all i know i closed project started testing project i think i then copied over project from mac machine… and and inform ide couldnt open project and inform ide window was dissapearing. but sometimes my lowest end graphic card also creates issues in mate session so sometimes when alot apps are open and specialy when i work for longer time with inform ide i lose my panel …god forbid that i have open facebook in firefox along to all tools then weirdest thing can happen. but i did copy over text in source file and got it running again.