Inform7 latest build still crashing on OS X Yosemite

Hi all,
I’m not sure if this should be posted somewhere else. However, I’m using VoiceOver so maybe this is also a factor. When I write source and press the Go button, an intreperater like Parchment or similar loads and it crashes on me along with the app. When I get an error in the code it works fine, though.
I wonder if this is a VoiceOver problem or a Yosemite problem… I think it may have worked just fine under Mavericks.

I have same issue with 6G60, both Mavericks and Yosemite. Only with Gluix format. Also in Mac Zoom app. Voiceover crashes Gluix interpreter in both. Does not show issue with z-code format. Magnify screen causes issue as well. Note: crash only happens when running game, happens immediately if VO is already running, or immediately upon loading VO, if game is already running. Does not occur if I do not use VO or megnify screen. I am almost completely blind, so need to use VO or magnify, or both. FYI, Spatterlight IF player does not show this issue. Finally, I absolutely love Inform 7!!!

Same here, Inform 6G60 and 6L38 both crash when I try to test a glulx game in Yosemite (Zoom crashes too, it seems). Everything is fine with z-machine, and everything was fine with Mavericks (I upgraded because everything seemed to work according to this thread).
I’m not using VoiceOver, by the way.

It would be cool if there was an easy solution, because I need to make my game for the French Minicomp…

Here is what happens in the console:
[rant=Console]09/11/2014 15:41:14,399 glulxe[1424]: *** Terminating app due to uncaught exception ‘NSInvalidReceivePortException’, reason: ‘connection went invalid while waiting for a reply because a mach port died’
*** Call stack at first throw:
0 CoreFoundation 0x953ce343 __raiseError + 195
1 libobjc.A.dylib 0x99a3da2a objc_exception_throw + 276
2 CoreFoundation 0x953ce25d +[NSException raise:format:] + 141
3 Foundation 0x965cbcc6 -[NSConnection sendInvocation:internal:] + 2710
4 Foundation 0x965cad06 -[NSDistantObject methodSignatureForSelector:] + 1529
5 CoreFoundation 0x9530a03a forwarding + 250
6 CoreFoundation 0x95309f1e _CF_forwarding_prep_0 + 14
7 GlkClient 0x2d001dd4 glk_select + 650
8 GlkClient 0x2d00cd4c gidispatch_call + 1852
9 glulxe 0x000057a2 perform_glk + 1194
10 glulxe 0x00002791 execute_loop + 745
11 glulxe 0x00006e3e glk_main + 154
12 glulxe 0x0000c81c main + 616
13 glulxe 0x0000249d start + 53

In the thread you pointed to, some people seem so say it’s fine when you uninstall/remove it from the list of applications, then re-install it from scratch. Is this not working for any of you?

No, uninstalling isn’t working, and it is not an issue isolated to Inform. Zoom crashes too (I think Inform uses this interpreter, anyway). Spatterlight and Gargoyle work, however.

For the moment, I think I’ll just have to compile the game and test it with Spatterlight instead of testing it within the Inform IDE.

Two conditions appear to need to be met to reproduce this crash:

  1. You must be compiling to Glulxe.
  2. You must be running VoiceOver.

A workaround for this is to compile to ZCode. This is not ideal, for obvious reasons, and I’ve been struggling with this problem as well.

Something is extremely broken in the Glulxe interpreter UI in terms of accessibility, which is a real shame, since IF is such a great medium for blind and visually impaired gamers. Some of the new audio features would be fun to play with as well, but without a fix to this problem, VO users are just out of luck.

I’m a Mac developer and would be happy to contribute to the work involved in solving this problem, but I don’t believe that the source for the Inform Mac IDE is publicly available. If I’m mistaken and someone can point me to it, I’d be happy to take a look and contribute to the fixes.

As I wrote, I am not using VoiceOver. Just compiling to glulx makes Inform crash. Also, I’m not sure the glulxe interpreter is at cause since it crashes also with git, but not with Spatterlight.

Also, compiling with the z-machine is not a solution, since using the French Language extension makes the story file too big.

I’ll just test my game with Spatterlight for the moment

The Mac IDE source is posted at but I don’t know whether that’s up-to-date. Actually, I know it’s not up-to-date; the files are timestamped 2009.

I cloned that tree, together with some later (but still not up-to-date) branches, at

I suspect long-term bugginess in CocoaGlk. (CocoaGlk is used in Mac Zoom and the Mac I7 IDE, but not Spatterlight or Gargoyle.)

I have not done any testing with MacOS Voiceover at all.

@ Natrium729 -

Sorry, I missed that you’d said you were not running VoiceOver, which is interesting. It’s hard for me to be certain of every aspect, but on my machine it appears that Inform runs OK with Glulxe if VoiceOver is disabled, and then hangs immediately when VO is activated. There could be more going on there, though, since i can’t see the screen when VO is off.

@ Zarf -

I’ll checkout your clone this week, though I hesitate diving too deep into without the latest official source. I wonder if a clean implementation of CocoaGLK might be a better way to go, although I fear that would probably be a monstrous project. In either case, I’d really like to do some serious VO testing with this stuff anyway. The Inform IDE is mostly pretty good with VoiceOver, but there are a few dodgy patches.

on my system, I have latest beta of Yosemite on 2nd partition, and current version of Mavericks on 1st partition. I have tested I7, all builds from 6G60 on up (Gluix), and tested compiled games on Zoom player. Using VO (cmnd-f5) or magnify screen (crtl-2 finger scroll, or cmnd-option-plus or minus), causes issue every time.
I cannot use z-code any longer, hitting memory space limits. 28000+ words of code. Many times I would run the game (Go button) just to look for typos and errors, with no intention of playing it at the moment. Now with Gluix format and Spatterlight, I do the same by ‘Releasing’ the game, but cancelling the ‘save as’ window directly afterwards (cmnd-period). Thus, I don’t have to switch to Spatterlight until ready to play-test.

According to the current edition of the Inform7 books, the Mac IDE has been rewritten recently, and I get the impression that most, if not all, of the 2009 code is now obsolete. From the book:

“In 2014 Toby Nelson, the author’s brother, put months of time into the project by rewriting and modernising the Mac OS X application: sandboxing it for the Mac App Store, giving it a more contemporary design, and much more.”

Excerpt From: Graham Nelson and Emily Short. “Inform - A Design System for Interactive Fiction.” iBooks.

As for Spatterlight, it does work well with VoiceOver, but the latest version of it I can find is dated 2008, so it is pretty out of date. If there is a copy that is more recent than V0.5.0 that I’m missing somewhere down the line, let me know, and I’ll keep searching for that as well.

If Toby Nelson is around here somewhere and would like some help with the Mac development, I’m here and willing to contribute to the project.

There were a lot of changes in the 2014 release, but plenty of old code is still there. (I say this by observing the behavior of the system, not by looking at code.)

I agree that you’d want to start any fixes with the current release.

@ lioncourt: I am using 0.5.0 as well, mainly in Mavericks. I’ve been working on the same project off and on for over a year. I am staying with I7 6G60 for now. I am not ready to translate the project into a deprecating version yet.

Update: Toby Nelson has posted the current Mac IDE source code:

Whoa. Is this an equivalent statement to “The Mac version of Inform is now open-source software”? I see that what’s in the repo calls itself simply “Inform”, and declares itself free under the GPL and a number of other licenses (c.f. … er/COPYING)

Correct me if I’m wrong, but as far as I know the IDEs have always been open-source and downloadable from the web site. This is just the first release since Toby took over maintaining the Mac version, so nothing earth-shattering unfortunately. The compiler is still closed-source.