Inform and macOS Catalina?

Well, the blog post on the Inform Webseite said:

“… Instead, a fully 64-bit version of the current Inform will be available for download here in the next few days, and shortly after that on the Mac App Store.”

As the blog entry dated from Oct 10th I’m hoping that we will see the new version any day now …

Jens

Yes, I’ve been looking for the fully 64-bit build for Inform 7 for Catalina. I made the mistake of upgrading to Catalina and then realizing I7 won’t run. :expressionless:

The new Mac build is now up: http://inform7.com/releases/2019/10/10/catalina.html

Huzzah! :smile:

Thanks Toby!

Is it just me or is the Release for Testing menu item broken in the new release? It seems to only create standard, non-debug builds.

I’m not seeing that. When I do “Release for Testing”, I get a debug game file (with the debug verbs, etc).

Right, it works fine with a new test project, but with Counterfeit Monkey it produces nothing. Actually it won’t produce any build at all, debug or not, but it was opening the old gblorb I made with the old 32-bit app, which confused me. No errors in the console, though. Works fine when compiling and running in the IDE. I tried it with an older version of the CM code as well with the same result.

EDIT: The working version writes at the end:

! Completed: wrote blorb file of size 12412656 bytes (135 picture(s), 0 sound(s))

Compiler finished with code 0

The new one just says

Compiler finished with code 6

Other differences in console output: old, working version says

Inform 6.33N for Mac OS X (30th August 2015)

New version:

Inform 6.34 for Mac OS X (5th March 2016)

Old:

Allocated:
 77785 symbols (maximum 90000)    60203917 bytes of memory

New:

Allocated:
 77785 symbols (maximum 90000)    66272361 bytes of memory

It sounds like some stage of the release process is crashing, but there’s no message about which.

Can you post the entire console output?

Sure:

The console output for the working version is identical apart from the lines I mentioned above.

Okay, it looks like it successfully creates Counterfeit Monkey.inform/Build/output.gblorb but fails when copying it to the Counterfeit Monkey.materials/Release folder. This is odd. Again, it’s not happening on my laptop.

Maybe try deleting the Release folder entirely and let the app recreate it.

Worst case, you can copy out Counterfeit Monkey.inform/Build/output.gblorb and rename it manually.

Thanks! Almost got it to work now. First I cleaned out the Build folder, which made the build fail in a more interesting way: Packing up for release - Failed error (with a broken image, see below.) Then I commented out the “Release along with …” line, and the build worked! It seems to be the “and a website” part that it chokes on.

Right, there we go. The cBlorb stage fails when “along with a website” is specified. This is true for both Release and Release For Testing.

I’ll pass that along.

Thanks again! Glad we could figure it out.

Just for the record: the same problem occurs with Release along with an interpreter.

Fixed now: http://inform7.com/releases/2019/11/14/catalina-update.html

2 Likes

How I fixed this:

I had the same issue as the original poster after downloading from Mac App Store. Turns out the version on there is not the Catalina compatible version - it was version 1.65.1. I downloaded the ‘interim’ version 1.28 from Inform7.com and replaced the one I had. That seemed to do the trick.

5 Likes

This is still the problem, though the actual Catalina (macOS 10.15) inform version number that works is 1.68.1.
Could we at least update the app description in the Mac App Store to say that it won’t run on Catalina, and where to download the right version?

Also, anyone downloading Inform 1.68.1 for Catalina should be aware that testing extensions and dark mode are still broken. See Inform on Mac - no cursor? and MacOS Inform 1.68 can't test extensions?.

OK, I downloaded the latest (“interim”) version directly from the Inform website, and it had problems with dark mode. I then got the version from the App Store an was delighted that dark mode worked great, but then sickened to realized that projects won’t compile at all (something about 32-bit vs 64-bit). It’s lunacy that a “broken” version can exist on the app store like this for YEARS (since 2019 at least) without being fixed. Ugh.

I was so excited to begin working with Inform, but I cannot seem to find a version that doesn’t have one problem or another…

An unofficial Mac Build has fixes for those. (I’m not a Mac person and can’t vouch for it personally, but others seem to have had success with it.)