inform 7 Glulx problem


I am working with Inform7 for a class project. I was trying to use the extensions Auto-Map by Mark Tilford, Inform ATTACK by Victor Gijsbers, and Conversation Framework by Eric Eve. The game works under Z-code 8 but crashes after a few rooms. I tried switching it to Glulx but when I compile the game window just shows the Cocoa GLK logo and nothing else. I am on a MacBook Pro with OS X Lion.

Any help would be appreciated.

EDIT: I should also point out that running the game with Glulx settings under Spatterlight and it works no problem.

I’m surprised it compiles at all into the tiny Z8 machine, but I think there have been issues with Inform on Lion? I don’t remember if this was what it was, though. (I’m still running Tiger. On PPC.)

The Lion problem is discussed here, with a link to a fixed version:

Thanks! But now I am having a problem in that Inform attack stopped working.

What exactly do you mean by “stopped working”? If you mean that it doesn’t even seem to be present, make sure the extensions are installed correctly in their respective folders and that you are including them at the top of your source in the right order. Some extensions have to be listed before or after others for procedural reasons.

I have uninstalled and reinstalled it. I have rearranged the include statements. When I removed it I get compile errors (Naturally). Nothing worked

I fixed my issue, I was changing who the player was and inform attack did not like that.