Inform 7 Doesn't Work Anymore

(IShiggyDiggyDoo) #1

Inform 7 recognizes everything as an Inform 7 game (pictures, music, etc), so when I actually tried to open previous games I’ve used on it it refuses to open. It doesn’t do anything. Just sits there acting like I never chose anything. Come back 20 minutes later and it’s still sitting there, acting like I never chose anything. Really at wits end here, tried uninstall, reinstall, short of computer wipe what can I do?

1 Like

(Hanon Ondricek) #2

Hey, welcome to the forum, @Shiggy!

What exactly are you trying to open? You said “pictures, music”… A compiled game (created by hitting the publish button - most usually a .gblorb) cannot be opened in the Inform 7 IDE.

Inform project files have the extension .inform - for me those will open the IDE as the default program on Mac, but on PC I have to open Inform first and then open the game.inform file from the dialog.

0 Likes

(IShiggyDiggyDoo) #3

I know they can’t be. It thinks everything that isn’t Inform 7 is an Inform 7 file. I’m opening a couple text adventure games. They are virus free and I’ve done it before. I used to be able to do it either way, by opening the game itself and Inform would open, or opening the game via Inform 7

0 Likes

#4

Just a wild guess… were the previous games created in a different version of Inform?

I had a lot of games I made years ago that won’t open properly in version 6M62.

0 Likes

(Hanon Ondricek) #5

I may be way off base, but the only thing I can think of is you may have inadvertently done an “Open With” and selected Inform and chose an option to “always open files of this type” with Inform. Check file associations and see if blorb files have the Inform logo which means they’re set to open by default in the wrong program.

2 Likes

#6

Good guess @HanonO . I was wondering if the question was “Open to edit” or “Open to play”.

Installing “Windows Glulxe” will reset the blorb association if I remember correctly. Possibly Gargoyle too.

0 Likes

(IShiggyDiggyDoo) #7

What would Windows Gluxle do? I used to have Gargoyle but deleted it last year.

0 Likes

#8

They are the programs that actually play the games. There are others, but these will reset associations if that is what is broken. Inform 7 is the creation platform. It can play the games too, but the other two are more “feature rich” and better for playing. If you are having problems playing, I suggest you install one of those. And if asked, allow it to associate the blorb (or gblorb) with itself. I prefer Windows Glulxe, but either is fine.

0 Likes

#9

And uninstalling will break associations, so that may be what happened. Try installing a good player and let us know what happens.

0 Likes

#10

Here is a link to the most recent (?) version of Win Glulxe. It is the version I use.

Windows Glulxe 0.5.4

0 Likes

(Hanon Ondricek) #11

Another option would be to right-click one of the games and select “open with” and choose an interpreter program (or the correct application for whatever you’re opening). Look for a tick box that says “always open files of this type with…”

1 Like

(IShiggyDiggyDoo) #12

I had it deleted long before I got Inform 7.

0 Likes

(IShiggyDiggyDoo) #13

I had that already set up

0 Likes

(IShiggyDiggyDoo) #14

It’s working now, thank you all

2 Likes