Inform 10.1.2, compiles fine, story fails to start [SOLVED]

Look, all I did was get 10.1.2 and I started up a game I’m currently writing. Now, in my old Inform, the game compiles and runs fine. Has a few rooms that are implemented. So I know the game is fine. But when I compile to test in this new Inform, it seems to compile fine but then I’m greeted by a blank sheet. See image. There’s just no game to be had. Am I missing a trick in this new Inform I should know about?
Oh, the only other thing I did, as you can see in the image, is I changed my colors because I’ve always wanted night mode for Inform and was thrilled to see the new version offered that. So I don’t think that has anything to do with it. To test this, I changed the test coloring back to black and the story still failed to load.
Anway, I’m hoping to hear of any ideas you guys have.
Thanks for listening.

edit: I’m on Windows. And I’ve also tried brand new games and other completed games and nothing happens after compile for any of them.

edit edit: Solved. I had to switch it from Glulx to Zcode.

1 Like

You can also try changing the Glulx interpreter in the settings; Inform comes with two (glulxe and git) and sometimes Windows objects to one but not the other.


Thank you. I had to do this. It worked.