Infinite Adventure

Had a quick look at Infinite Adventure, and wondering if it is supposed to be like this? Given the aesthetic and the nature of the related game in the comp, it seems like it could be deliberate, but it doesn’t match the cover art and the only review I’ve found doesn’t mention it.

Screenshot of my view of title screen

Adfnture1

Do I need to download a virtual head cleaner diskette for my DOSBox?

2 Likes

That’s what it looks like for me, too (running DOSBox 0.74-3 under x64 Linux). I notice that starting the game repeatedly doesn’t produce the exact same textual deformities on different runs, either: different words are mutilated in different ways on different runs.

You’re right that it doesn’t match the cover art. I assume it’s a bug? But it’s hard to tell because it’s consciously being coy about its origins, so maybe it’s a clever meta-puzzle of some kind.

In any case, the problem is continued on the first play screen.

My sc een matc hes th cov r a t pe fe ly. I ope d and clo e it a f w tim s.

No aberrations here.

Schermopname (3)

The differences in the actual title within the title screen are due to procedural text generation.

1 Like

I note that moving past the title screen shows the same textual gaps as I see on the title screen:

infadv

Hello everyone–

Despite his tragic and sensationalized death, this evening I was able to conduct a séance with Mr. Scotts via AOL Instant Messenger. He confirmed that the text of his game should indeed be legible and he suspected bugs were afoot. I explained to him the many, many different operating systems that have proliferated since his demise, and he suggested I test his game on some of them. He was particularly insistent on testing in OS/2, as he believed it to be the operating system of the future.

I quickly verified several OSes, including Windows 10 running DOSBox, Vista and XP (where the program runs natively), and in a virtual machine running FreeDOS. All were successful. I also tested the game using an old laptop with Ubuntu 14.04 and DOSBox 0.74, and it runs correctly there, too.

I suspect this might be some sort of weird DOSBox issue with non-Windows 64-bit systems (and maybe just 64-bit Linux). I talked with JTN about it and suggested to maybe run the Windows version of DOSBox via Wine. It was confirmed that Infinite Adventure worked correctly in this manner, using the DOSBox0.74-3-win32-installer.exe file.

I thanked JTN, and went to tell Mr. Scotts about my results and to thank him as well. But by then, he had set his status to Away, leaving only his parting message: “Happy INFINITE ADVENTURING!”

Duly sworn,
B.J. Best

15 Likes

For the record, I also see corrupted text in DOSBox 0.74-3-3 on macOS Big Sur 11.6 (which is 64-bit only).

EDIT: I was able to get it to work on 64-bit Windows 10 in DOSBox.

2 Likes

Ditto, Mojave. The “64-bit non-Windows” hypothesis seems to hold.

So I tracked the problem down to a specific, platform-dependent bug in DOSBox.

Gory details

A buggy floating-point emulation, of all things – the language runtime used by INFINITE.EXE (ab)uses floating-point instructions for a fast memory copy, but DOSBox’s FPU emulation doesn’t have enough fidelity and loses some of the data; except on 32-bit Intel, where DOSBox has a wheeze to use the hardware FPU and thus get correct behaviour. See https://sourceforge.net/p/dosbox/bugs/369/, which links to DOSBOX scrambles screen when running FreePascal \ VOGONS showing a similar effect on text display in another program.

Knowing this gives a few more options for workarounds, but none of them are especially easy.

I’m not aware of any workaround for DOSBox on non-Intel processors, I’m afraid. Your best bet would probably be to find some other way to emulate DOS.

For Linux on 64-bit Intel processors:

  • The Windows-DOSBox-under-Wine trick is probably still the easiest one.
  • If you have the right kind of Debian-derived Linux distro, you can use multiarch to temporarily install a 32-bit DOSBox build; this should be cleanly reversible without lasting effects on your system.
    First you need to enable installation of :i386 (32-bit) packages:
    dpkg --add-architecture i386
    then you can install the 32-bit DOSBox build (replacing the 64-bit one if it’s present) with:
    apt install dosbox:i386
    When you’re done you can go back to a 64-bit DOSBox build with:
    apt install dosbox:amd64
    (I don’t know offhand if this will work on current Ubuntu.)
  • You could build your own copy of DOSBox from Subversion; this helps because they added a way to use the real Intel FPU in 64-bit Intel builds too (r3851), which hasn’t made it to a release yet; so such a build should Just Work.

Macs: dunno. Since I think all but very old and very new Macs have Intel processors, it ought to be possible to do something, but I don’t know any details.

2 Likes

'I tried this with Dosbox-X and it worked where Dosbox failed.

4 Likes

The second method (i386 DOSbox on x64 computer with multiarch) worked for me on Linux Mint 20.1!

Built my own DOSBox from source on OSX Mojave (10.14 on 64-bit Intel), and it indeed Just Works. Didn’t do anything special, just built with the default params:

svn checkout https://svn.code.sf.net/p/dosbox/code-0/dosbox/trunk dosbox-code-0
cd dosbox-code-0/
./autogen.sh
./configure
make
./src/dosbox
1 Like

What language runtime is this?

I’d be quite curious to see the source of Infinite Adventure. (I suggest plugging a modem into a Ouija board to facilitate the transfer.)

2 Likes

Aha, yes, looks like this fork came up with a more widely applicable fix (issue 119, commit 0b0baa0cc3). So this looks like an option for (at least some) non-Intel processors.

1 Like

Dosbox-X also worked for me on macOS Big Sur 11.6.

@bjbest60 I wonder if it wouldn’t make sense to update the description on IFComp and IFDB to mention “DOSBox-X” instead of DOSBox.

2 Likes

This time, thanks to my clairvoyant’s advice of using the three of swords Tarot card as a mouse pad, I managed to contact A. Scotts through a haunted Prodigy bulletin board . He asked me to genuinely thank everyone here for the deep dive into the technical issues. He was also very, very relieved that he could pin the bug on DOSBox rather than his own code. He seemed like he wanted to say more, much more, but then his aura became corrupted, dissipating into a hiss of demodulated static.

I was then able to reach the Abort/Retry/Fail team, and they successfully updated the game’s IFComp blurb, so it now lists DOSBox as preferred for Windows and DOSBox-X as preferred for Mac and Linux.

So, to summarize, if you’d like to play Infinite Adventure:
Windows: DOSBox
Mac / Linux : DOSBox-X

(A fiction can be a difficult thing to maintain. Again, a genuine thanks, all.)

8 Likes

I got impatient and tried plugging a modem into my own Ouija board. And, to my surprise, it worked!

Now I have an enormous pile of interesting-looking strings.

3 Likes

Do the strings stand upright and dance when you play the flute?

Worse than that! They talk to me, like familiar NPCs…

1 Like

Hah! I was looking for a name for my chamber-music quartet. You think “The Talking Strings” is already taken?

2 Likes