[IF entry] Traveller's Log [Can't open the game/Solved]

Has anyone tried this entry yet (download only)?
There is only one file in the folder (python, no html/exe) and I can’t seem to manage to open the game itself. There is also no walkthrough to help with the setup. Is the game just playable in Python?


No instructions, huh? This thread on running a python game from a comp last year might be helpful:

(The initial posts are about Macs, but after that there’s some discussion of Windows too).

I’m no python maven but hopefully this works – if not just bump the thread with what’s not working and I’m sure folks can help!


It seems to need Python 3, so you may need to install Python 3. (Python 2 gives some bugs.)

If you install Python on Windows, you can then double click on the file.

If on Unix or Mac, you may need to type (path of python script) (path of the python file).

Though you may be able to just type python trvlslgs.py or python3 trvlslgs.py … you may have to open a new terminal window after installing.

My guess is it’d be best to go to the directory in it and type “/path/python ./trvlslgs.py” to be sure.


Yeah, it works with Python 3 for me. Huh. Very…terse. And random, I think? The actual action text is kind of hard to see between the description of all your current stats.

1 Like

wtf… So the file was actually working from the beginning, but the first question is just very misleading:
You need to write no for the first question to get the stats (the code was random). If you answer yes, it asks you which file to open and automatically closes the window if it is not correct (I am guessing).

I hope the rest of the game is less obtuse…


Looking at the source, I see what they’re trying to do.

If you win the game, you can create your own backstory and load it. Which is a cool idea. But

  1. the instructions aren’t specific enough, and
  2. it throws an error and bails if you guess the first command wrong, e.g. you type “y” or “n” instead of “yes” or “no.” That’s probably what you saw if you clicked on the file from Windows explorer. I ran from the command line so I saw an error.

There probably should be a check for a bad file name, and then the game continues. But yeah, you probably just want to say no to get started.

The game itself error-checks if you type in a bad command, though, and you’re told what commands to choose from, so that’s good.


Oops, I meant to comment on that and I forgot. Say no to reading a file and then enter three digits that it will use as a seed to generate a random character (I think). I think after that the game makes more sense. Though I’m not sure how much there is to it. It seems like a lot of random events that may or may not change your stats.

1 Like

It wooorks! (Also I am a dragon :smiley: )

1 Like

Thanks for this! I also couldn’t figure out how to get it to run.