IF and Linux

Hi folks,

I’ve now moved over to Linux Mint as my OS of choice. Does anyone else here use Linux, and would anyone know of any software for both the reading and writing of interactive fiction? I could get some stuff for windows and just use Linux’s windows simulator but it would be nice if there was some native stuff. I’ve had a fish about and found ‘gargoyle’ but not used it yet, I think it’s just for playing stuff and I want to have a go at creating sometime.

I have frotz on my phone naturally so I’ll never be truly stuck :slight_smile: but I ought to make use of my big screen too, plus write stuff.

Any info most welcome

This is a good place to get info:


The “Authoring Systems” and “Interpreters” sections should give you an idea of what’s available.

ADRIFT 5 Runner now has a Linux version that runs under Mono. See http://forum.adrift.co/viewtopic.php?f=3&t=7202 for details. This is still at a very early stage however. I guess that doesn’t help you if you want to write games tho…

My personal experience, as a Linux user, is:

Gargoyle to play the games. It reads almost everything, but it has some issues with Hugo files, I think.

I’m using gnome-inform7 to write my story, and it works very well. I haven’t used other languages*, so my personal experience report ends here :slight_smile:

[size=85]* Question from a non native: is it ‘I haven’t use’ or ‘I haven’t used’?[/size]

“I haven’t used” is correct.


I second the recommendation of Gargoyle. It’s beautiful and plays all the major game formats (although, as Iribeiro noted, it has issues with a few formats - Hugo and Adrift, mainly).

I also use QTADS for TADS 2 and 3 games. Gargoyle can run TADS games, but it doesn’t support multimedia or text formatting, whereas QTADS does. QTADS is also a very nice interpreter - not as stylish as Gargoyle, but clean, functional and easy to customise.

For authoring, Inform 7 runs natively on Linux. TADS 2 and 3 also do if you’re willing to use the command line, but if you want to use the TADS Workbench, you’ll need Wine. (It does run quite well under Wine, although there are a few nagging problems.)

Gargoyle is unable to properly play V6 Z-machine games (which basically means Journey, Shogun, Zork 0, and Arthur), and probably never will be able to. Other than for V6, though, Gargoyle is my interpreter (or interpreter collection) of choice.

Zoom can play V6 and runs natively on Linux. For V6 you might also consider Windows Frotz running under Wine. In my experience Windows Frotz does V6 a bit better than Zoom, and it runs flawlessly with Wine.

Whoah, how? When I tried installing it, it told me something along the lines of “I need these libraries, but I’m not going to install them, and no, I won’t tell you why.” And when I tried to automatically resolve the issue, it just deleted gnome-inform7.

Linux Mint is based on Ubuntu, right? Which version of Ubuntu? The .deb on the Inform 7 website is compiled for Ubuntu 11.04 and doesn’t work on earlier versions, so you might need to use this .deb instead. It’s the same version of Inform 7, just compiled for Ubuntu 10.10 instead of 11.04.

If neither .deb is working for you, it might be a problem specific to Linux Mint. Let us know which libraries are causing the issue and we’ll see if we can help you get it working.

That’s what happens when I try to install the package provided by Synaptic Package Manager. BTW, I’m using Debian.

Okay, says I, and try to install libwebkit-1.0.1:

It does say however that I do have libwekit-1.0.2 installed, but apparently it does nothing.


And when I do apt-get -f install, it just uninstalls gnome-inform7:

Oh, sorry, I just assumed you were the original poster. Not paying attention… :blush:

The Debian gnome-inform7 was packaged for Lenny, which supplied libwebkit-1.0-1, but later versions of Debian no longer include it. You’d better report it as a bug on the Inform 7 bug tracker and ask for a new Debian package to be built, with the correct dependencies. (Especially since Lenny is now officially obsolete.) I don’t know how long that will take to be fixed, but when Ubuntu 11.04 came out and the old Ubuntu packages stopped working, it wasn’t that long before a new package was released.

In the mean time, if you’re impatient, you could try building it from source

I will have to mess with this again, too. It’s the only thing that I wasn’t immediately able to get up and running with Linux Mint Debian Edition when I switched from Ubuntu 10.04.

The .deb package for 6G60 dated 17 July 2011 worked just swimmingly for my Linux Mint Debian Edition. Now if the Army would stop using proprietary formats for digitally signing documents, I could get rid of my Windows partition on this machine…

Has anyone tried installing Inform 7 on Slackware 13.37 ?

I tried but got too many compiling errors…so I guess im stuck with I6 for now

What about a native CLI interpreter. Gargoyle and zoom are both cool but both require an X session to be active. I’d like to be able to play my games from anywhere by simply SSHing to my box.

There’s many of them. Either designed for terminals (Frotz, Fizmo, FrobTADS) or running through GlkTerm (Git, Glulxe).

I haven’t yet found one that runs zblorb files. But hey, I’m pretty much a n00b in IF. :slight_smile:

nfrotz is a terminal-window interpreter that handles zblorb.

Allright! :slight_smile: Tnx! :slight_smile: