I7 for OS 10.5.8?

I’ve been sitting on my hands for a couple of weeks, waiting to see if a maintenance release would appear that would allow the I7 IDE to run 6E72 under MacOS 10.5.8.

As of this afternoon, there still doesn’t seem to be such a release. I just downloaded it again from the Inform site and tried running it. Same behavior as before. It’s a doorstop.

This is bumming me out, because I’d like to start working on updating the Handbook. I would prefer to do the work sitting here with my laptop on my lap rather than sitting in the office using the PC (yeah, yeah, I know – I’m spoiled, I’ve got too many computers). Just as significant, in my opnion, there’s a whole slice of the authoring community that can’t use 6E72 at all, because, like me, they haven’t upgraded to 10.6. This makes me less enthusiastic about doing the work. I mean, if a bunch of people can’t use the software, why should I put in a lot of work supporting it?

Sure, I could upgrade to 10.6. It’s only $29. But (and this is a big but): I have an upcoming freelance project for which I’m going to have to use the Mac. My current software installation works fine, so I’m just plain not going to up grade until I get this project done.

I’d sure appreciate it if someone who is in the know would enlighten us as to whether there will be a maintenance release for the older (but still completely viable) MacOS, or whether I’m just shit outta luck until sometime next year.

Should I be bugging Andrew Hunter unmercifully about this? Or is the next release only days away?


I have no information about this at all, except that the bug report database indicates that the ball is in Andrew’s court.

I’ve mentioned this in a couple of fora, but if it might help at all, I’m happy to mention it again: The notion has arisen that there is a workaround for this issue, and it may well be that this workaround functions on some machines. However, most folks who have posted to the bug tracker report that in fact there is no workaround on 10.5 or 10.4. This has also been my experience, and it sounds like it’s Jim’s situation as well.


Andrew Hunter has posted a fixed IDE on the bug tracker. It only includes the 6E59 compiler, but I suppose you could try swapping in the 6E72 compiler.

I don’t have any other news, but I think you can expect this to be fixed soon. You’re certainly not the only one running pre-10.6, especially since PPC Macs only support 10.5 at the latest.

Your suggestion of swapping the compiler seems to work fine. I’m now running the 6E59 IDE with both 6E72 compilers. This is a huge relief, as it allows me to get busy updating the Handbook.


I’m glad this thread is here. It never occurred to me that downloading the latest I7 would cause any problems.

Can someone tell me where to find this fix?

Hmm… I wonder if I have the same problem or a different one. Clicking “Go” seems to trigger a successful compilation, but then the game never starts. Is that a different situation?

I tried doing a release. The IDE claims the release was successful, and it creates a Release folder in the Materials, but there are no files in the Release folder.

That sounds like the same issue. This thread on the bugs site seems to offer a solution:



That solution may work, but someone said it’s intermittent. My solution works for me, and seems reliable:

Download and install 72. Rename the package in Applications to “Inform 6E72” so it won’t be overwritten by the next step. Then download and install 59.

Copy the 72 compiler into the original location in the 59 install, overwriting the 59 compiler. Just to be safe I also copied all of the files from Resources > Extensions > Reserved, and the Standard Rules from Resources > Extensions > Graham Nelson.

At this point the IDE thinks it’s running 59, but the compiler and the Standard Rules are 72.

I don’t know that this method is free of side effects. There may also be changes, for instance, in Unicode Character Names, which I didn’t bother to copy. But it seems to do the job. I can run 6E72 (with all of its charming quirks) in OS 10.5.8.

If this doesn’t work for you, please let us know!

It seemed to be working for me, but I wanted to try getting 6E72 working, so I tried your solution:

$ cd /Applications/Inform\ 6E72.app/Contents/Resources/Inform7/Extensions/ $ cp -r Reserved Graham\ Nelson /Applications/Inform.app/Contents/Resources/Inform7/Extensions/

I may have started out with the wrong version (it appears to be 6E58) but it’s the one I downloaded from Andrew’s link here:


Trying to compile my game, I got this:

I don’t think there’s a 6E58 release. More to the point, though, I have no idea what sort of code you’re running there. Terminal? I just dragged some stuff around from within Finder, or rather, I selected files with the mouse and used Cmd-C and Cmd-V.

To do this from within Finder, you have to use the Show Package Contents command in the utility menu.

It appears, if I understand the Terminal lines, that you copied the Extensions but not the compiler. The compiler is in (pause while he turns on his MacBook) Applications > Inform 6E72 > Contents > Resources > Compilers. There are three items there – cBlorb, inform-6.31-biplatform, and ni. You need to copy and paste them all into the identical location in your Inform 6E59 package.

If that doesn’t make sense, or doesn’t work, let us know.


There wasn’t any 6E58 release, but it’s the version of the compiler that Andrew Hunter had available to test with, and so it’s what’s linked on the bug report page.


Argh! Horrifying! :wink:

It’s funny - some people are afraid of the command line, but I have a greater fear of GUI interactions - you can never tell for sure what’s happening behind the scenes. And hey, with the command line, you can copy and paste the entire operation right from your browser to your terminal!

Aha! That’s what I was missing. Trying it now:

$ cd /Applications/Inform\ 6E72.app/Contents/Resources/ $ cp -r Compilers /Applications/Inform.app/Contents/Resources/

It works! Thanks!

Has this been reported in Mantis?

Yes, ektemple posted the link:


It’s marked as fixed; I don’t know when a new build will show up.