HELP with Lectrote bundle needed.


Poor guy here can’t compile the Win version of his games with Lectrote bundle. I have installed the seventeen-thousand things required (Wine Stable included, plus X11, plus probably a couple of trojans), but the terminal keeps rejecting the Win(XX) bundle due to the fact that “I’m missing «wine» in the PATH”.

I’m obviously out of my league. The instructions on Lectrote page(s) are elegant, but I have just a partial grasp of them.

Anyone using my downtown-bar-language can help me pls?

My system: MacOS Sierra. High Sierra, if needed.

Thanks and a lot of LOVE!

How have you installed Wine?

I used homebrew, which installs a binary in /usr/local/bin/wine.

Hi zarf and thanks for the reply.

I’ve installed wine using the three packages found in the site, under the MacOS section. I’ve also run the three configs, so I can tell wine is working as the Win pref panel pops up and I’m able to detect drives, audio and so on.

Still: no wine under the /usr/local/bin folder.

And Lectrote compiler answers this:

[code]Packaging app for platform win32 ia32 using electron v1.6.11
Could not find “wine” on your system.

Wine is required to use the appCopyright, appVersion, buildVersion, icon, and
win32metadata parameters for Windows targets.

Make sure that the “wine” executable is in your PATH.

See for details.
Traceback (most recent call last):
File “”, line 319, in
builddir(dest, pack, pkg)
File “”, line 248, in builddir
shutil.copyfile(filename, os.path.join(dir, filename))
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/”, line 121, in copyfile
with open(dst, ‘wb’) as fdst:
FileNotFoundError: [Errno 2] No such file or directory: ‘dist/GAMENAME-win32-ia32/./LICENSE’[/code]

(GAMENAME used here to avoid spoilers :slight_smile: )

ETA: looks like the PATH is not properly configured. Do you have a command for installing Wine through homebrew? My last resource then I’ll be using a Win machine to do the work, as a final resort. I just need to find the Win machine, now.

Installation instructions and documentation is at .

Ouch. Looks like I skipped the part where it says I need Xcode.
So now I have to upgrade to HighSierra and then get Xcode.
Hope my laptop has enough free space available.

Thanks again :slight_smile:

It worked. Using homebrew was the easiest solution. And reading carefully your manual, too.

Thanks a lot for the help, but much more for the incredible work you keep doing for us.

Just one final thing (sorry for bothering you!).

Is there a way to force the preferences at the start, after a fresh install? I see the window is now 600x800, Lora font, light theme, no margins.
I tried to change these, adding the new values in mainextension.js and then by changing the original main.js, but nothing seems to happen.

Where are those prefs saved, anyway?

Ps: is this the part to change in main.js?

var prefs = { gamewin_width: 600, gamewin_height: 800, gamewin_marginlevel: 1, gamewin_colortheme: 'light', gamewin_font: 'lora', gamewin_customfont: null, gamewin_zoomlevel: 0, glulx_terp: 'quixe' };

Is it enuf to add this code to mainextension.js?

Yeah, doing any Mac development at all generally requires the latest OS and Xcode.

The preferences are saved in Library/Application Support/GAMETITLE/lectrote-prefs.json.

Yes, that’s the section in main.js. You’ll have to change it there; putting a prefs object in mainextension.js won’t help.

Perfect! Everything is cool now.

Thanks a lot for the help.