Help please - Twine 2.3.8

For some reason whenever I click a node the arrows are disappearing, and the tiles of the disconnected nodes are stacked against the edge of the window. I’ve tried restarting and running on multiple versions. I’m running on windows. The game is running, but it’s still doing the crazy arrow disappearing thing the links work in the game just the arrows in the GUI are removed

Which game are you asking about?

Sorry, asking about twine 3.2.8 engine

It sounds like the “position” attribute of your passages have gotten corrupted somehow. Did you perhaps run a search-and-replace before things broke? In some rare cases doing that can cause problems like this.

First, you might want to try publishing your story to HTML, then delete it from Twine, close and then re-open Twine, and try importing that HTML file. Hopefully that will fix it.

If not, you’ll need to open a copy of the HTML (keep a backup of the original) in a decent text editor (like Notepad++) and search for “position=”. You should find lines which look something like this:

<tw-passagedata pid="16" name="Passage Name" tags="" position="1375,25" size="100,100">

If the position has something other than two integers separated by a comma then that’s the problem. Remove any decimal places, and if you find something like “NaN” (Not a Number) as a position, then replace that with an actual number (like “500”).

Once you’ve fixed the HTML file, save it, delete the game from Twine and then import this fixed version to see if it works properly now.

Hopefully that does the trick. If not, we’ll need to see your HTML to figure it out, so you’d need to post a link to it.

Hope that helps! :smiley:

Hey HIeV. You’re welcome to my export. Someone has kindly fixed the error in ym export however the editor is still replicating the error every time i click a node. Wondering where the config files are stoed so I can try removing them. I’ve reinstalled several versions of twine and having the same problem. Also I think the problem may have been caused when I used Alt+Scroll. Are you on discord?

I’m not on Discord currently, but if you need to send me a file, you can use a temporary upload site like SendGB (click the “link” icon) to post a temporary link.

As for where the config files are, for the v2.3.x branch of Twine on the Windows OS, they should be in C:\Users\username\AppData\Roaming\Twine\ (replace “username” with your user name). You might try creating an archive of all of your Twine stories using the “Archive” button in the Twine editor, closing Twine, then deleting that folder, the Twine folder (likely in your C:\Program Files or C:\Program Files (x86) directory), and the My Documents\Twine folder, then reinstalling the latest version of Twine (currently v2.3.8). That should give you a clean install. Then you can import the archive to get your stories back.

Hopefully that does the trick. :smiley:

I already removed the roaming files :s No cigar.

Yeah, there were a bunch of broken positions (i.e. positon="NaN,NaN") in the HTML. I’ve fixed them, so this version should work now: https://sendgb.com/cOLQAFTfRC8

The fixed ones will all be along the left-hand side now, just because I defaulted them to a left position of 1000.

Have fun! :smiley:

Thanks so much for your help HIEV!! Let me know if ther;es anything I can do for you.

It works perfectly now. It wasn’t the editor after all :slight_smile:

I have used replace to replace NaN with “1000.” This works but the editor is replicating the problem again in the subsequent instance. Did you do anything else except replace NaN,NaN?

What exactly do you mean by “the subsequent instance”? You didn’t use the version I fixed?

Well, in one case it was something like postion="NaN,1250" and I changed that to postion="1000,1250", but the rest were all postion="NaN,NaN" and I changed them to postion="1000,1000", postion="1000,1200", postion="1000,1400", etc… That way they wouldn’t overlap.

Also, just to avoid the stupid story duplication bug, I changed the game’s name from “The lost sea. ” to “The lost sea.” (I removed the space at the end). That way if you imported it while you still had the old version of that game in Twine, it wouldn’t cause that duplication bug.

Anyways, if you’ve found a way to replicate the “NaN” position bug, let me know and I’ll pass it on to the developer. The developer’s been trying to figure out where that’s coming from for a while now.

Thanks. :smiley:

Thanks I found the problem is every time this error occurs you need to wipe the roaming data. Thanks again for all the support. I*'m really bad at coding :stuck_out_tongue: