Help Needed for Savage Island Part 1

I’m trying to get the knife from under the lake and from what I understand you have to swim north underwater but when I try this the game tells me it does not understand the word “north!” I can swim east and get the block but north does not work???

I’ve tired abbreviations and everything else, but I can’t swim north no matter what I type.

The version I’m using is the Inform version and I’m using WinFrotz to run it. I’m wondering if this is some bug or quirk just for that version of the game. I hope not, I’d hate to have to scrounge for another version and start all over!

Can anyone help? Thanks!

Here’s a walkthrough, though I don’t know if everything works on the version you’re playing. But it looks like the command you’re looking for might be

hold breath

Thanks for trying, but I’ve done that. :frowning:

I drop the log, hold my breath and then try to swim north to get the knife but it says it doesn’t know what a “north” is! Really odd. I can swim east and get the block the walk-through mentions but no north swimming is allowed apparently.

Also, I can’t type NORTH on land to go north either even if there is a way north. Same with SOUTH and south. It only lets me do N and S. And no, typing SWIM N fails also. Sigh. The version I downloaded is from the IF archive, so I wonder if others are having this issue?

It must be a bug in that version. I downloaded the games from Scott’s own website and that version allows for NORTH and SOUTH. Yikes, that is a bad bug!

The Inform conversion of Scott Adams Adventureland was just as buggy. Whoever converted them back in the day must have used a flawed converter.

Elsewise discussion have noted that not everybody is aware where the converter is. It’s called “scott2zip”: … tools.html

You can take a look at it if you want. Allow for the fact that it’s 1995-era Perl, and generates 1995-era Inform source code (Inform 5). The last time I tried to get it working, I failed. But there it is.

The Inform version of Golden Voyage has the same exact problem with ignoring NORTH and SOUTH, which makes sailing to certain locations impossible.

And on most of the conversions if you restore a saved game the parser stops recognizing virtually every word and command making saving useless and thus making certain games, particularly Savage Island 1, virtually impossible to solve unless you get REAL lucky.

Also, the version of Secret Mission is unwinnable because (SPOILER ALERT) the saboteur doesn’t die until the final countdown starts (and sometimes he doesn’t die at all!) which makes it impossible to frisk him and get the necessary items to finish the game in time.

I mention all this not to pile on whoever did the conversions but to warn those who play those versions from making the mistake I did, which was getting deep into a game and then having to start all over when it got buggy and then driving themselves crazy thinking they must be doing something wrong.

Well, it sounds like the world is ready for another batch of ZMachine versions of all those games. :wink: Preferably bug-free.

You might also try Chris Spiegel’s Glk port of ScottFree, which can run the original game files.

(It will be available in the forthcoming Gargoyle release but can be had now for the asking.)

Oh, yes, not to mention the commodore and spectrum versions and God knows what other formats. He can always play those.

Pity there’s no reliable ZMachine version, though. It’s so portable.

You seem to have taken my post in the wrong spirit, though I was not responding to you.

Dref mentioned downloading the games from Scott Adams’ site; those games are in the ScottFree format, hence it felt topical to mention the existence of a new interpreter for that format.

Resurrecting this topic - I just tried the Inform version of Strange Odyssey, and knowing the 8-bit versions very well, I would advise nobody play the conversion. An important feature of the display is entirely absent. The same feature figures prominently in 8-bit The Count, which I assume also makes it worth avoiding in Inform, if for no other reason.

Are any one of these Inform conversions of Adams games okay? It seems to me that a set of ports that are as buggy and holey as these are worse than nothing.

  • Wade

Feel free to explain what was missing, in a spoiler tag if necessary…

The ports were an early effort – one of the first things I remember seeing on the Archive. I’m sure a more faithful Inform port is possible, but nobody has ever gone back to revisit them.

Adventureland is winnable… that’s the only one I managed to win, and that’s all I know.

So is the Circus game, so that’s actually two I managed to win, with different levels of hintage.

I was under the impression that these ports were done by an automatic script?..

Yes, I think if you run any one of them, the title screen explains that they were converted by a tool. But obviously, nobody carefully checked the ports, which is a big deal. Checking them (or porting something in general) is also a tremendous amount of work, but that’s what’s required if you’re gonna do it and be able to say the port is legit.

Anyway, I have commented on the things we know for sure don’t work right in the IFDB entries. I still just have the urge to slap ‘DON’T USE!’ stickers over all of these, given there are multiple other versions of each game that do work properly, but due to my sensibleness I will not comment on the ones I haven’t tested (grr!).

  • Wade

Your comment on the IFDB entry on Strange Odyssey seems awfully nonspecific, though (“The Inform conversion of this game does not reproduce an important screen effect present in the original 8-bit versions”). Why not explain what it is under a spoiler tag?

Seconded. I didn’t ask because, after Zarf’s suggestion, I was kinda hoping you’d tell us on your next reply.

The screenshot in World of Spectrum doesn’t show anything untoward… neither does a quick, 2-3 move playthrough (Spectrum version)…

It was deliberately nonspecific to avoid a spoiler. I haven’t tried putting a spoiler tag in the main description of a game before, and when I think about doing so, my gut reaction is I don’t like the idea of the fundamental text for something in a general reference database having a specific spoiler or even a spoiler tag. That doesn’t mean I won’t necessarily do it, though. But all that happened was - in retrospect, I didn’t know whether Zarf was asking for information here, or in a spoiler tag on IFDB. I went there, wrote what I wrote, then got distracted when I decided to go and check all the versions of the game that I could. So sorry for any confusion. But now I can report back.

Well, this is related to what I was saying about ‘ports need checking’. It’s not possible to identify the issue from a screenshot, or in 2-3 moves, or without checking other version.

So I talk a lot about Strange Odyssey, and a little about The Count, below:

[spoiler]In Strange Odyssey, in the original version of the game for the Apple, Atari and TRS80, there are splitsecond flashes of text which occur in a couple of situations.

The first is when you start the game. On move 1, you get a glimpse of the hexagonal room, like a premonition.

The second situation, and way more important, is that when you are in the hexagonal room and start touching the plastic, each touch gives you a momentary glimpse of the location you will move to if you now step into the curtain of light. That’s the point of it. On the versions of this game where this doesn’t happen, the text ‘You feel strangely disoriented for a moment’ and the accompanying pause (in Inform, you don’t even get the pause) is kind of pointless, given that you receive no glimpse of anything, though it still does change the gamestate of your next destination.

The port to the C64 was done in 1987 and it’s also missing the feature. I don’t know when the Spectrum port was done, but I assume not in the original run, because it doesn’t have it either.

You can see the feature in action because someone has put up a Youtube vid of Strange Odyssey being played on Atari. The first flash is visible immediately at game start, at 10 seconds in. Obviously the others come later, in the hexagonal room:

(The font is a little ouchy!)

The Count uses the same kind of text flashing to show what’s happening to the player at night, which is creepy and important, and also to deliver glimpses of things which act as clues.[/spoiler]

  • Wade

Oh, I wasn’t clear – I at least wanted the information under a spoiler tag here, which you have now provided, so thank you.

Wow, that’s surprisingly modern. And a way cool effect.

Of course the ports are at fault for being buggy, I don’t dispute that, but if other commercial ports also missed that feature then maybe in this particular instance it’s not entirely the porter’s fault. Even if they could check the game out step by step, which they should have, they might simply not have known about it.