Gargoyle renders fonts weirdly

#1

Hi,

I just downloaded Gargoyle from here and installed it on my Windows computer. From what I read it is supposed to have specifically nice font rendering. However, what I get is this: gargoyle.png Ugly blurry font! Is that a Gargoyle bug? Is intended? (I certainly hope it isn’t!) In some screenshots of it on the web it looks much better. Anything I can do to fix it?

0 Likes

Jonathan Blow playing Hadean Lands
(Hanon Ondricek) #2

Have you tried playing with whether TrueType font smoothing is checked or unchecked in your display preferences to see if that makes a difference?

0 Likes

(Erik Temple) #3

The font smoothing is intentional. I’m not sure whether Gargoyle has a setting to turn off its font smoothing, but I do know that it uses its own display libraries and won’t be affected by any Windows system settings.

0 Likes

#4

Ok odd, since I personally find it harder to read. I’d rather play in cmd.exe!

Also I was surprised, Gargoyle was linked from somewhere as “iTunes-like” application. Does it actually have some sort of games library functionality where it can list them all with iFiction details and such? Because I couldn’t find any such thing. Is there any glulx-capable interpreter which actually does this?

0 Likes

#5

Gargoyle is definitely not itunes-like :slight_smile:

I think there are some frontend-like applications around for IF games. Zoom has a kind of one built-in. People who use or know of the others might chime in.

  • Wade
0 Likes

#6

Zoom doesn’t appear to support glulx or Windows though. Gargoyle would seem a good candidate due to its wide format support if it just got extended with some sort of game library management and had its font rendering settings fixed (I mean common, it’s really too blurry to be read without effort… even if that’s supposed to look nicer or whatever).

0 Likes

#7

Zoom does support Glulx, but you’re right, it doesn’t support Windows, which I sometimes forget.

I hate to be the guy who says ‘I know,’ in response to your complaints, then absorbs them and makes more complaints of his own, but - yeah, I know. Gargoyle runs pretty much everything but has annoying preferences, weird scrollback and copy and paste, and doesn’t talk to accessibility services on Mac.

Broadly speaking there’s a catch with each interpreter, or if not a catch, there’s at least a lack of a fire and forget solution. I find this frustrating and say so occasionally, but the system programmers give us what we have already for free. All I can do after that is implore people who are capable of working on these things to keep at it in the interests of the community. And they already are. For instance, I understand Gargoyle’s developer has mostly lost time to work on it, so it’s stalled.

  • Wade
0 Likes

#8

You could try changing the lcd setting. There’s no setting to remove all the anti-aliasing though.

One iTunes-like option is Grotesque: grotesque.invergo.net/fossil/index

0 Likes

#9

Regarding Gargoyle, I suppose it uses weak font hinting. Some people like that, but most systems are configured for strong hinting because it’s more readable. Therefore I’m a bit confused there’s apparently no option to change that.

Grotesque looks pretty awesome, will give it a try :slight_smile:

0 Likes

#10

I think Gargoyle’s core font rendering code was written when OS’s didn’t offer good font rendering. Typography is one of Gargoyle’s premier features! These days we’re used to nice fonts in most programs.

0 Likes

#11

I noticed this too running it on W8, very blurry.

I previously only ran it on Linux and it worked great there.

I think there’s no denying that the best hope for slick IF presentation is html+css

0 Likes

(Matt_W) #12

Another necro on this thread, but I’ve also noticed the default fonts that Gargoyle installs with are not Unicode fonts. I noticed particularly with Counterfeit Monkey, which has, at least in one scene, a sign written with Greek characters that don’t render at all with Bitstream Charter.

0 Likes

#13

I think I was able to clean up the blurry font a little by adjusting the gamma value to 0 in the garglk.ini configuration file. Not exactly sure what that setting is or what, if anything other than the font, that I may have changed, but it does seem to have helped a bit.

0 Likes

#14










YOU render fonts weirdly!

-Wade

0 Likes