Frotz iOS Help Needed! Trouble with Frotz iPad App

Hi all, hope you’re doing okay.

I’m trying to play some IF remotely with my 8 year old nephew. The set-up is that we’re using phones to video call, I’m playing on my PC and he’s playing the same game on my sister’s iPad.

We finished playing one game and tried to load another. I successfully talked Max through browsing the IFDB to find the one we wanted, and it’s appeared in the iPad’s Frotz games list.

What’s odd is that when he opens the game for the first time, the splash screen says “resume game” instead of “play game”. When he taps “resume game” the app crashes.

I got my sister to restart the iPad but it didn’t have any effect. I remember having a similar problem with Frotz when I had an iPad, but I can’t remember what I did to solve it and I don’t have it any more.

Both the game we finished and the new game are Glulx.

What game? And what was the previous game?

There’s a “restart” button next to the “Resume Story” button. It’s hard to see because it’s a purple curly arrow on grey, but it’s there.


Try opening the keyboard with the keyboard icon on the upper right side of the screen. Then type in quit at the prompt then respond yes. If that works, select the story list option on the upper left. My ipad has locked up and crashed in a similar fashion a couple of times. This was one of the ways that worked.

Maybe this will help in some crashes.


PS. This seems like a recent issue. Maybe it is related to an OS update?

1 Like

First game was To Hell in a Hamper and the second Renegade Brainwave - Max wanted to play games I’d written :blush:

I didn’t see it, but I’ll get my sister to have a look when we resume tomorrow.

We’ll try that - thank you!

I remember having very similar issue once or twice with my iPad Mini, which was ancient when it finally gave up the ghost.

1 Like

I did a quick test playing those two games, and I didn’t run into any problems. Oh well – you have things to try.

Thank you Zarf, I appreciate your efforts.