Flack's IFComp 2010 Game Reviews


#1

A bit of context:

I am new to the world of (modern) Interactive Fiction, not having dabbled in the genre since parsers were limited to two word commands and capitalization was optional. I am a nobody in the realm of IF and my opinion shouldn’t be given much/any weight. Unfortunately, historically speaking, being both unqualified and ignorant rarely prevents me from throwing my two cents worth in on a particular topic – this one included.

My goal over the next few weeks is to play as many of the 2010 IFComp entries as possible, commenting on each one in this thread as I play them. Those of you looking to avoid game spoilers (or poor writing in general) should probably steer clear. The Planet Interactive Fiction blog/RSS feed is rife with game reviews from experts in the field; in my reviews, I hope to capture the thoughts, feelings and perceptions from a relatively new (again) IF gamer.

And with that … on with the reviews!


#2

Review: The Sons of the Cherry

Right up front I should admit that I chose to play this game first because it is a ChoiceScript (“Choose Your Own Adventure”) game, which I thought would be a good way to wade into this year’s games.

[spoiler]Sons of the Cherry (SotC) begins with four seemingly random questions. Not having played a ChoiceScript game before, I suspect these are used to randomly generate player stats or something. Depending on the color of shirt you are wearing, how you might react to an angry hornet, and how honestly you answer questions such as these, your gaming experience may be affected.

I should also note that the second word in this game is “loamy”, which I had to look up. (I live in Oklahoma; we don’t have a lot of loamy landscapes apparently.) I also encountered the words “ichorous” and “eldritch”. These are not words that come up frequently in the world of computer networking, which is mostly what I read about.

In SotC you play a magician (mystical, not stage) framed for the abduction of a creepy shrieking girl with no pupils. Despite your best intentions you are arrested, only to be sprung shortly afterwards by a mysterious masked visitor (FRIEND OR FOE?). Throughout the game’s roughly 15-20 minute run time you’ll perform some magic(k), rescue a fellow cult member enslaved by Ben Franklin, and try to assassinate George Washington. Why this hasn’t already been turned into a made-for-television docudrama, I’ll never know.

Throughout the game players are presented with two opposing choices, one of which is adventurous while the other is typically safe. On my first romp through the game I largely went with the adventurous choices (which seemed more in tune with the spirit of the game).

The game ends rather abruptly. Seemingly just minutes after we are introduced to this alternate (OR IS IT) version of history with both good and evil practitioners of magick frolicking around the War of Independence, the game ends after your assassination attempt on George Washington fails. And I realize this is fiction and all, but seriously, who misses shooting another person in a tent? My family and I went camping last summer in a tent and we all instantly knew the moment someone else farted, snored, or simply rolled over. If I had fired a gun in that tent, regardless of the direction, I would have wounded at least three people, myself included. Maybe old pistols were really, really inaccurate, or maybe George Washington hung out in a circus tent, but, wow – take a deep breath and squeeeeeeeeeze the trigger …

The most disappointing part of the game was, after playing it a second time, I realized that very few of my choices affected the outcome. For example when presented with the choice to fight or run away, after choosing fight, my NPC companion told me, “Nah let’s just run,” (I’m paraphrasing here) and so we ran anyway. Other than being able to cut out the middle third of the game and end up with a less-magical-yet-more-depressing ending, the game by and large plays the same no matter what you choose. I even lied and told it I was wearing a green shirt instead of a white one!

The feeling that I was playing a “Have an Adventure Chosen For You” culminated in a spooky scene in which I was supposed to conduct a magick ritual. When I chose not to, the game looped and informed me, “Maybe you should.” When I chose not to again, the game informed me “maybe you should.” I hit chose not to 10 times and finally accepted my fate and chose yes. This is like when a waiter offers you a choice between the veal and the chicken and then telling you they’re all out of veal after you choose it. If my choices don’t matter, why make it interactive at all?

After completing the game a second time I didn’t feel like SotC was very interactive. I did enjoy the writing style and I liked the weaving of magic into historical events, but there just wasn’t enough here to make me feel like I chose anything, or made a difference, or really had any fun. I would like to see a longer piece of work from this author, one in which I could learn more about these secret organizations and their motivation and have fun doing it.[/spoiler]


#3

Review: A Quiet Evening at Home

[spoiler]This game turned me off almost immediately due to the ridiculousness of the opening “puzzle”. As the game opens, you find yourself standing outside your home with a strong urge to pee. If you don’t make it to your bathroom within x amount of turns, you’ll pee your pants and the game ends. So before I talk about any other aspect of this game, I’m going to talk about, in depth, how dumb this is.

The first problem I have with this puzzle is, why do I not know how to get into my own house? In the real world, I enter my house the same way every single day. The game gives no explanation as to why, on this particular day, I don’t know where I keep my key. Give me a lump on the head, temporary amnesia, a freaky brain injury … SOME reason as to why I do not know where the key to my house is!

And actually, a head injury might explain the next section of the game, in which you run from room to room in search of your bathroom. I want you to imagine this in real life. You just got home from work (or school, or whatever), you need to whiz … and so you go wandering around your kitchen in search of the toilet. It’s stupid. Why do I not know where the toilet is IN MY OWN HOME. Some of the rooms in this game list possible exits, but few tell you what lies in each direction. Shouldn’t I KNOW that my bedroom is to the north, or that my kitchen is to the east? It’s a terrible setup.

I’m thirty-seven years old, and let me tell you this – I will piss off my balcony, in my driveway, into a potted plant or the kitchen sink before I pee in my own pants. Of course the game doesn’t let you do any of these things, and instead you’ll spend multiple turns in search of your own bathroom in your own house. I wet my pants (in the game, not real life) and had to restart three times before I found the bathroom in time. Not only do I have amnesia; I also have the world’s only master bedroom without a bathroom in it. Damn my luck.

Without any real direction, it becomes apparent as you begin to find things throughout the house that you are supposed to (A) fix yourself dinner and (B) take out the garbage. I don’t even know how to describe this part of the game, other than to say that fixing a bowl of soup in the game is approximately (using Calculus) 8,302,305,590 times harder in the game than in real life. My eight-year-old son can microwave his own dinner but I’ll be damned if I could fix a bowl of soup for myself in this game. The final piece of the puzzle I was missing – the can opener – can only be discovered if you (A) solve a puzzle involving your pet hamster and (B) wait for him to randomly wander into a room, at which point the can opener appears. The equivalent of this in real life is getting dressed for work in the morning and not being able to find your shoes until you take a piece of pizza and place it in your bathroom.

Before resorting to the walk-thru, I found myself spinning my wheels on what turned out to be red herrings. For example, I wasn’t supposed to eat, search, or play with the garbage – I was supposed to take it out. In the beginning of the game you find a Netflix movie and in my living room I find a television (and later a laptop), but there never seems to put the two together and watch the movie. And before you say “watching a movie in a text adventure doesn’t sound like very much fun,” I just spent 500 turns to make a bowl of soup and take out the garbage …

I could go into the lack of capital letters and some missing punctuation but those problems seem secondary in retrospect.

A Quiet Evening at Home reminded me of this old fishing game I used to have for my PC, which was 10x more complicated than real fishing and nowhere near as fun. Perhaps it reflects my overall experience with IF, but I found myself continually frustrated while playing this game, and continually disappointed in myself that I kept playing it. At no point during the game did I ever think “this is fun” or “I should recommend this to a friend”. Sorry, anonymous.[/spoiler]


#4

In my personal opinion there is no such thing as a “nobody” in the realm of IF. 8)

Paul, in the realm of IF.


#5

Now now, perhaps he meant “Nobody” in the sense of the splendiferously badass Indian character played by Gary Farmer in a certain Jim Jarmusch film?

Come on, Stupid White Man…


#6

I have no idea to what you’re referring but I’m sure it’s very interesting. 8)


#7

Heh heh. Wow, man, that review may well contain more text than the game itself. I agree with you on the incongruity of the game’s opening puzzle. For some reason I did not have as many problems with the puzzles as you did. Perhaps because, once I realised that after the very first puzzle there was essentially no direction to the game, I just went about my life in the house like it was mine. Thus, I solved certain things before the game even prompted me to. For example…

[spoiler]First thing I did (after unsuccessfully trying to piss in the sink and then finding the bathroom – P.S. game designers if peeing is a puzzle then peeing should be a recognised verb, that is all) is find the trash and take it out. (I had already been in the backyard.) But I didn’t complete the final step of taking it to the curb. This threw me for a loop later when the game said I should take out the trash and I was like, ‘I did! Stop nagging me.’ bad childhood flashback

As for the soup, I don’t get what was so hard about it, besides opening the can. I resented the fact that it wouldn’t let me actually intentionally search the place where the opener ended up being. I could only find it ‘by accident’. I don’t mind being prevented from doing things by my character’s mood, but my character’s mood at that point should have been, find that can opener at all costs, not, don’t bother searching through stuff. It made no emotional sense, I’d be turning the house upside down. But I didn’t spend too much time sweating that, and once it turned up by accident, the only other hitch was figuring out how to ‘get’ the water from the tap into the bowl. That was a pretty awkward description BTW. ‘(taking the water first)’ – one of those cases where the standard responses should not be relied upon.[/spoiler]

One thing I will give the game – it makes no bones about what it is trying to achieve. Just read the title. 87 I was wiling to get into that headspace and just ‘live it’, and If it had been a bit more elegantly programmed, I might have enjoyed it for what ‘just living it’ is worth.

Paul.


#8

In regards to “puzzle number two”, I figured out what I was supposed to be doing by the items I kept finding. If I had found a carburetor, some headers, a handful of spark plugs and a bucket of bolts, eventually it would have dawned on me that I was supposed to assemble an engine too.

There was one other moment that, in retrospect, didn’t make sense either:

How does a flashlight pop out of a futon? I own two futons and they are either L shaped couches, or flat beds. I can’t imagine a flashlight popping out of either configuration …

That’s nitpicking though, and I do want to say that despite the game’s shortcomings, the anonymous author was able to piece together a working house. I think a couple of beta testing transcripts would have brought a few of the puzzles’ issues immediately to the author’s attention. All of the basics of a game were there and in place, and I hope the author doesn’t get discouraged by my gentle ribbing and has another go at it.


#9

There are several different types of futons that fold different ways the L-shaped ones are only one way. There are some that fold into an S-shape (In fact, I’m sitting on one like that right now), and others apparently that just roll up, though I didn’t really know about those roll-up ones myself until earlier today. Point is, you can lose objects inside those other types and I assume the author had one of those in mind.


#10

Review: Heated

[spoiler]Within the first few seconds of playing Heated I found something I liked, and something I didn’t. I liked the fact that the game presented my goals to me right up front (“You need to show up early, look sharp and be ready to get your report in before the end of the day.”) What I didn’t like was, the first sentence of the game was actually a run-on sentence, telling me that (in what seems to be a theme so far) this game wasn’t very thoroughly proofread. Normally I wouldn’t be so picky, but these are text adventures, and this is a competition. On with the game.

The goal of Heated is to get to work (a) on time and (b) not completely pissed off. Your anger (er, “heat”) is tracked throughout the game. In two of the three games I’ve played so far this year, I have found myself wandering around my own home. This must be a common theme for new IF authors; if I program and submit a game next year, I will definitely make sure it takes place in my house. Unlike in “A Quiet Evening at Home”, your house in Heated is logically laid out and easy to navigate, although there were at least three areas of the backyard with no items and nothing to do.

Although the writing was decent and some of the object descriptions were entertaining, I got distracted counting “its vs. it’s” and “your vs. you’re” errors. And then, half a dozen moves into the game, I got this response while examining my closet:

Your closet is a finely aged nook in the wall. It has two magnificent balsa-wood sliding doors Though you’re sure there was an iron in here too, at one point anyway.that are mercifully closed.

Yikes.

The best advice the game offers you up front is “Save often!”, and it’s not kidding; waste too much time wandering around your house, chew the gum you found at the wrong time (I incorrectly tried to freshen my breath with it since I don’t seem to own a toothbrush or any toothpaste …) or get too “heated” and it’s game over. The good news is, after three or four attempts and without looking at the built-in hints I was able to win the game. Once you figure out the proper order in which to do things before you leave your house, you can run through the entire entry in less than two minutes.

Heated contains quite a bit of “oddness”, and I continually received frustrating responses from the game – like not being close enough to my alarm clock to smash it while lying in bed. (“You cannot reach it from here.”) Here are a few other “odd” responses I got:

x room
Without having visited that yet you can’t really piece together a solid description.

your bathroom
It isn’t in the best shape, but it isn’t condemned either (mostly because as far as the city is concerned, this room doesn’t even exist). It has the normal bathroom fixtures; a shower, a counter with a sink and mirror, and toilet. To the east is your bedroom.

take off clothes
That’s supposed to be done in the comfort of your own home.

use bathroom
Which do you mean, the bathroom counter, the bathroom sink, the bathroom mirror, or your bathroom?
use sink
[The word “USE” is too vague …]
use bathroom sink
[The word “USE” is too vague …]
wash hands
That isn’t here.
use shower
[The word “USE” is too vague …]
turn on shower
That’s not something you can switch.

front lawn
An unmanicured and patchy lawn leads up to the front of your house. Your driveway sits just to the east.

examine house
There is more than one room that fits that description.

The author notes in the game’s documentation that this is his first attempt at programming an IF game, and it shows. I think more experienced authors have more, well, experience in predicting what a player might attempt and how they might attempt it. Once I got on the same wave-length as the author I was able to beat this game fairly quickly. Heated is a small game and a short competition entry, but I didn’t experience any crashes or major bugs while playing. Like I said, the author included some entertaining descriptions within the game, but it definitely could have used a proofreader. “Your alarm, in an apparent attempt on your life, is driving you to suicide.” (If it’s an attempt on my life, that’s murder …)

Despite some miscommunication between the game and I, what I liked about this game were some of the object descriptions and the clarity of my overall goals. Next year I would like to see a larger and more-polished game from this author.[/spoiler]


#11

Good point, and a good reminder of just how difficult it can be to convey something as simple as the description of a single object in IF.


#12

I think all my awesome reviews broke Parchment. :confused:

EDIT: It’s back!


#13

Review: Under, in Erebus

[spoiler]After spending the last two nights playing games in which I wandered around the most familiar of domains (my own home), tonight I had quite the opposite experience in Under, in Erebus (UiE).

As the game begins you find yourself being shoved by a mob onto a mysterious train. Moments later the train takes off for parts unknown, racing deep into the depths of the Earth and ultimately stopping in (I assume) Erebus.

Erebus is dark and mysterious and the writing within the game reflects this. The writing, in fact, is superb – the best I’ve encountered so far this year. The descriptions are limited but vivid. I got a real sense of the things I could (and couldn’t) see, and the feeling of being somewhat disoriented comes though in the writing.

I’ll cut to the chase here; at the heart of UiE lies a puzzle that I wouldn’t figure out in two hours, possibly two weeks, and maybe even if given two years. Maybe it’s because I just spent the past two nights playing games where the major objectives were to fix myself some soup and find my bathroom before I peed in my pants, but in UiE you’ve got magic glyphs carved into rocks, size-altering peas a’la Alice in Wonderland, a guy who lives on an island who wants me to fix him a drink, and a bunch of magic booths. I wandered around for about an hour before resorting to hints, and I spent a while looking at hints before I resorted to the walk through, and I’m not even sure I completely understood everything at that point. I think during my trip to Erebus I must’ve bumped my head pretty hard.

UiE features great writing and a well laid out world, but after a while I began wondering what on Earth (or under it, I suppose) I was supposed to be doing. I do finally get how the main puzzle works, but I would be super surprised (and/or impressed) to hear about someone beating this game without hints. I feel like I just spent two hours staring at a piece of modern art, and finally had to walk away because I’m too stupid to understand whatever it was the artist was trying to express.

Now if you’ll excuse me, I need to go fix myself some more soup …[/spoiler]


#14

Review: Ninja’s Fate

Oh boy.

[spoiler]Imagine, if you will, a film that paid tribute to a bad director – Ed Wood, perhaps. The film would make references to many different awful scenes from Ed Wood’s awful movies and tie them together as loosely as possible. This odd idea for an homage only works if (A) the viewer is familiar with the source material (in this example, Ed Wood’s films) and (B), it’s done with a nod and a wink to the audience. Simply referencing random bits from old, awful movies doesn’t necessarily make for enthralling entertainment.

And, I should add, that no one unfamiliar with the source material has any business reviewing the final work. Anyone unfamiliar with Wood’s films is most definitely not the intended audience.

Ahem.

Ninja’s Fate is the text version of the above scenario. It’s an (intentionally, I hope) bad game based on the (unintentionally, I presume) bad games of Paul Panks. Who is Paul Panks? I had no idea before trying this game, and only know now after reading other people’s review of this game. Paul Panks, by many accounts, appears to have been the Ed Wood of Interactive Fiction. His words were the “pie plates on a string” of UFO attacks; his characters, the Glen or Glenda of transgender drama.

I can’t tell you what the real point of this homage was and I can’t tell you what the hell was going on half the time – what I can tell you is, I am not the intended audience for this game. Not being in on that who is (or was) Paul Panks, any references to the guy’s former games were lost on me.

A few years ago, I rented a film called The Lost Skeleton of Cadavra. It was released in 2004, but shot to look like it was filmed in the 50s. It had all the earmarks of being a lost B-film from that era – it has a cave, and some aliens, and a talking skeleton. For some reason, I never could get into that movie. While I love old bad B movies, there was something about making one intentionally bad that just didn’t have the same feel to me. Ninja’s Fate felt that way, too. I get the whole “make a bad game and include bits from other bad games to make a tribute to a bad game author with a new bad game”, but ultimately I felt like the joke was between the two authors, and that we (as players) weren’t fully in on it.

Anyway, like I said, as someone unfamiliar with Panks’ other games, I don’t feel like there’s much more I can say about this one.[/spoiler]


(Silas Greenback) #15

I may or may have not played one of Pank’s games before. If the style of Ninja’s Fate is anything to go by, the tributee’s games would be the kind I would play for a few turns and move on to something else. There are quite a few out there like that. Few of them are memorable.

I originally scored Ninja’s Fate a 3. All things considered, particularly the obvious mentions of Pank’s past low IF Comp rankings, I suspect the author may be happiest with a 1, so a 1 it is.

That makes 2 games ranking a 1 so far. Ninja’s Fate ranks a one with a gold star sticker and a handwritten “Nice Job!” beside it while The Chronicler sits beside itself with a dunce cap in the corner.


#16

Review: Aotearoa

[spoiler]Every program needs a name (I learned that from Tron). Occasionally I write programs at work, but before ever writing a single line of code, I’ll spend a day or two brainstorming on a good program name. The right name can inspire me to write a great program. I don’t know what it is, but it seems that by choosing a great name, sometimes the code will just fall into place behind it.

I hope to play my way through all ~30 games in this year’s competition, but to be perfectly honest I started with the ones that sounded interesting. Aotearoa, to me, did not sound interesting. (I’m talking about the name here, not the game’s premise.) As a dumb hick from Oklahoma, I thought an aotearoa was the dark part around a nipple. If there’s been any pattern to this year’s games so far, it’s been the ones that sounded great haven’t been, and the ones that sound strange, foreign or bizarre have turned out to be the most interesting.

Aotearoa, it turns out, is not the name of the nearest spiral galaxy to the Milky Way, but rather the native Maui name for New Zealand. (Who knew? Not me.) Aotearoa (the game) throws about a dozen native words at you right up front, so between trying to remember foreign names and replacing north/south/east/west with fore/aft/starboard/port while travelling on a boat (“I’m on a boat!”), I thought for sure there were rough waters ahead.

But while riding on a boat on the way to Aotearoa island, something happened – I got caught up in the story. More so than any other game I’ve played so far this year, I was not just interested in the game, but in the plot. The more I played this game, the more interested and involved I became. I don’t think there’s a twelve-year-old alive who hasn’t dreamed of visiting an island filled with real life dinosaurs.

This – THIS! – is the type of game I thought I would be playing all along. I didn’t realize it before, but compared to Aotearoa, many of the other games just felt like “objects in rooms” instead of the interactive world presented here. It is evident that the author of this game spent a lot of time tweaking, smoothing, and perfecting this game. I didn’t see any typos, or bugs, or obvious logic errors.

As a newcomers to the scene, I’ve been using the terms “text adventure” and “interactive fiction” interchangably. After playing Aotearoa, it has suddenly become clear to me. THIS is Interactive Fiction. And don’t get me wrong – I think there’s room in the world for both types of games (the game I’m currently working on would be classified as a text adventure), but Aotearoa is a wonderful example of Interactive Fiction.

While I can’t definitely say this is the best game in the competition (I haven’t played them all), I can say it’s bay far the best one I’ve played. This game is well written and well construction. Kudos to the author.[/spoiler]


#17

Spoiler for all the games in this year’s IFComp:

I have. And it is. :smiley:


(Silas Greenback) #18

With this year’s comp, I played the entries alphabetically. With Aotearoa being only the second game I played, it set the bar very high.

I’ve chosen Aotearoa and another game as tied for first and will decide by the deadline. The other game, Leadlight, wasn’t well received by most reviewers, though for whatever reason, I liked it very much. (Even the combat system didn’t turn me off.)

Just by going on the flawless execution and the use of a standard interpreter rather than making the player use something other than provided for the best gameplay, Aotearoa gets first ranking without any further thought.