Error from Step 1

Brand new here. This is day 2 of Twine. I’ve used the online version on 2 different computers. Both in Edge AND IE11. One laptop works fine the other it keeps giving me “An error occurred while publishing your story (object doesn’t support property or method ‘finally’)”. Yes, I’m getting the same error in 2 different browsers on the same machine whereas on another laptop it works swimmingly.

Also when a new passage is created it doesn’t contain all of the same content, it just has “Double-click this passage to edit it.” in the body of it vs all of the instructional text. Any recommendations would be great!

If you want to report an error with the online version of Twine in some browsers, then the Twine “Issues” page on GitHub is the place to do that. (I don’t normally use the online version, so I don’t know what might cause that error.)

That said, since you’re not on a mobile device (smart phone, iPad, etc.), it’s generally better to download and use the offline version of Twine. That should prevent any problems with publishing.

I’d recommend seeing if you can use the “Archive” button in the online version of Twine to create an archive of your current work, then use the “Import” button in the offline version of Twine, and import that archive, that way you can pick up where you left off.

Also, other than for testing purposes, I’d recommend against using any version of IE, if you can, since it’s pretty badly outdated. The current version of Edge is basically a reskinned version of Chrome, so that should work fine.

And yes, it’s completely normal for new passages to contain nothing but “Double-click this passage to edit it.” in it. It’s up to you to add whatever content you want to those passages, and since normally it won’t be the same as any other passage, there’s no way for the Twine editor to know what else to put there.

Any “instructional text” would vary depending on what story format you use within the Twine editor. I’d highly recommend using the SugarCube story format, due to its ease of entry, flexibility, breadth of sample code, and suite of built-in tools. That link will take you to the SugarCube download (if you want the latest version) and documentation. You can select the story format you’re using in the main Twine editor window to set the default story format (Twine defaults to the Harlowe story format), or within any particular story to set the story format for that particular story.

Hope that helps! :grinning:

I suspect by “instructional text” they meant the tutorial.

That is a known bug in Twine: The report is about Firefox, but it’s likely that it affects other browsers as well. It should work well in Chrome.

Some more backstory. I’m working on behalf of an 12 year old on a laptop that’s badly hanging on. I’m trying my damnedest to get all the latest updates on it.

I am aware that edge and chrome are the same under the hood and it worked on my current version on Edge. Both IE and Edge fail so I wanted to know if it was a specific security problem or what.

Thanks for noting the default text is normal. That was a concern of mine. Will work harder on updating as a possible solution.

While both Edge & Chrome are based on Chromium that ‘framework’ is made up of a number of sub-components (eg. a HTML render, a JavaScript engine, etc…) all of which the user of Chromium is allowed to either extend with custom code, or replace entirely with their own custom implement.

So how “the same under the hood” those two web-browsers sore depending on exactly what sub-component ‘enhancements’ or ‘replacements’ each of those to two companies have done.

Give me a break. Yes, I understand that Chromium isn’t a 1:1, and it is a framework that both are built on. So there isn’t a guarantee they will be completely functional. I am simply trying to ascertain if there are known reasons why Edge/ IE will work on one laptop and not another as my searching couldn’t find anything in black and white.

I’m new to Twine and don’t know the framework, jargon or capabilities. I hadn’t planned on becoming an expert. My HTML, Javascript and browser nuance knowledge are dated as I’ve been out of development for a while so I’m not sure where to start debugging. At the moment the laptop is packed up to be moved so it will be a few days till I can monkey with it. I’m just trying to get it working on an old laptop for an 11 year old so that she doesn’t have to use mine. #STEM

Sorry. Greyelf can be a bit… needlessly pedantic at times. :smirk:

Did you try the offline version of Twine? That should fix the problem you’re seeing.

I’m on a Windows 7 machine that’s 10 years old, and that works fine for me.

Thanks. It’s unfortunate some technical types can be that way. They make the industry look bad. And a reason many drop out of the field.

I was trying not to have to install as there’s not much room on the hard drive, but if that is all that I can do, then I will go that route. But if you have a Win7 device running it, there may be hope. I’m not able to work with it right now, but will report back in a few days. Thanks!

Thanks for the feedback folks. Couldn’t get the latest feature update on the machine (but I did get some patches on there) as I could only strip out so much on the device (the OS has gotten huge these days). But I was able to upgrade Edge alone and things worked! Thanks!