"Do you want live notifications" banner cannot be dismissed

When I visit this forum I get a “Do you want live notifications when people reply to your posts? [Enable Notifications]” banner at the top. There’s an × at the right that should be able to dismiss it, but clicking it does nothing :smile:

This only leaves “Enable Notifications”. After clicking that it’s still possible to reject it in the browser’s notifications popup, so it’s only a slight user-friendliness issue.

This is with Firefox 98.0.2, but it’s been the case for quite a while (I think it comes back every time I log in?). I’m using the dark theme, no idea if that matters.

1 Like

Report the same with Firefox. No use of dark theme. Will update with the version in the AM.

ETA: v 99.0.1

I haven’t seen the notice, and there’s nothing on the Discourse meta forum that I can see. I can post about it if you’d like though.

Has this been going on for a long time, or did it only start recently?

1 Like

Strange! I’ve seen the same notice on other Discourse boards, but there dismissing did work. For whatever reason that problem seems specific to here.

I’ve tried narrowing down why it doesn’t work but couldn’t find anything obvious like an error in the javascript console and my JS debugging skill only go so far.

It’s been the case for a year or so, mayb longer. I didn’t report it before because I thought it’d be some temporary problem that’d go away with the next update in forum or browser software (and who knows, it might).

1 Like

Apologies if you’ve already tried this, but if you change to a different forum theme does the popup remain un-dismissable?

(One other potential last-ditch solution - accept the notification, then go to browser settings and turn it back off.)

1 Like

Thanks for reporting it, @Dannii.

I hadn’t! But now I’ve just tried a few of the themes (including IntFiction). Same behavior, clicking the × does nothing, no feedback at all.

I’ve also disabled all firefox extensions and restarted firefox. No change.

Yes, that works :smile:


This resolved the issue for me as well. Changing themes had no effect. Thanks for the help.