Compiling IFM 5.5 to Ubuntu Works Now

Hey, in case anyone needed an update, I just noticed that IFM 5.5 is on the the if-archive here, and compiling it for Ubuntu 22.04 works now.

I have yet to test it out extensively. (I don’t have much spare time right this minute; I actually had logged in to attempt a compile of 5.4, because I wanted to post a bug report here. But then, in the process, I noticed that 5.5 was posted, as I was looking to download a fresh source package. Turns out I’m not posting a bug report today, lol)

When you get to the make install part, you need to use sudo make install, because the binary goes into usr/local/bin, and needs permission first. That’s about it, though.

No errors, no warnings, no immediate crash. Totally fine. Will post more, if I can figure out how to run a test on this. Really excited, because writing the map with code is a lot easier for me that drawing it with a mouse.

Happy gaming!


I confirm, IFM 5.5 compiles out-of box also under Debian 11, and without warnings.

Best regards from Italy,
dott. Piergiorgio.

1 Like