Code 2

I was editing one of my games and after deleting a simple tick mark (’) and clicking on ‘Go’, the program threw a Code 2 error, saying that this was only possible if I had 1) exceeded a memory volume limit (or something like that), 2) tried to compile a story that was downloaded off of a CD-ROM or 3) tried to download and use code that I was not legally permitted to use, and if none of these were true, then my computer was at fault. At first I assumed it was #1 above, but then I immediately tried to compile it again, and that time it went through without a hitch. I am wondering what made it throw that error. Could it have been because I had deleted the tick mark and then hit ‘Go’ in such quick succession after the ‘Problem’ message, that the computer had not ‘caught up’ yet, when I hit ‘go’ again??

Just wondering. I vaguely recall getting that error before.

I might be mistaken about this, but check the Settings panel of Inform7 and check out what I circled on the attached image.

The error messages you quote sound like a Windows error, not an Inform error.

I don’t believe you can generate that by editing the source and hitting “Go” quickly. It sounds more like a transient error in your OS, maybe bad RAM.

(I could be wrong, though.)

Ah, ok. I misunderstood and thought it might be that easy fix. My apologies! :blush:

An error code of 2 usually means something like the compiler tried to write to a file, but got an error from the operating system instead. If this happens again, on the Results tab click on Console, and that will show the output from the compiler, which will provide more detail about what happened. Without that information it’s not possible to diagnose this any further, sorry.

Zarf–yes I think that was what the message was saying–my computer–the OS–was at fault. I recall getting that error message before, way back when, so maybe it was only a momentary thing. It’s compiling without a hitch now.

MTW–that’s alright–I prefer Glulx.

DK–I’ll remember to click on Console next time it happens and report back. Could it happen as a result of having so many projects saved, or when I am shifting back and forth between two projects? I was doing that yesterday, copying some routines from one project to paste into another.

Thank you all.

There’s no obvious reason that either of those would cause a problem. Which doesn’t help much, I admit :slight_smile: