Can't upload images/files for posts?

I’m having some difficulty adding images or files to posts. When I try to upload something, there is a percentage upload indicator that reaches 100%, but then it disappears, and nothing is added to the post itself.

Uploading worked fine for me a week ago. Am I the only one experiencing this? Has something changed on the server side?

EDIT: Quoting from posts doesn’t seem to be working for me any more, either.

I’ve had no problems. The image/attachment limit is 4096kb. Is your file larger than that?

I’m uploading this screenshot which shows the allowed file extensions. Are you perhaps trying to upload a ZIP or an HTML file?

Screen Shot 2022-07-03 at 5.26.14 PM

The issue seems to be specific to one environment, and it’s possibly related to browser and/or browser version. Uploads and quotes worked fine when I tried logging in from another environment.

I don’t think anything significant changed on my end over the last several days. I’m guessing that a server upgrade introduced some incompatibility? At any rate, it definitely seems to be my problem, not the site’s.

Do you think pdf could be added as a valid file extension?

Recently I couldn’t attach txt file to my pm, I had to zip it first. It said that txt is not allowed as attachment, although I sent lots of them before. It was just a transcript, nothing too large.

.pdf and .txt have been added.
Screen Shot 2022-07-04 at 10.43.39 AM