Can't rebuild a story created with Twine 1, 8 years ago

years ago (around 2013) I wrote a little Twine story. I only recovered the html version, which is working fine, except for the font and formatting.
I couldn’t open the html file with Twine 2, so I downloaded Twine 1.4.2 and the story is displaying fine, with chapters, etc.

But when I try to test play I have this message :

an error occurred while building your story.

Traceback (most recent call last):
File “storyframe.pyo”, line 907, in rebuild
File “tiddlywiki.pyo”, line 188, in toHtml
File “tiddlywiki.pyo”, line 507, in toHtml
File “tiddlywiki.pyo”, line 495, in applyRot13
File “encodings\rot_13.pyo”, line 20, in decode
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xe0’ in position 26: ordinal not in range(128)

I can’t remember the old story format I wrote with (maybe harlowe ? not sure at all).
I tried the Twine 1 to 2 archive converter but it didn’t work.

Is there a way to fix this old file or do I need to rewrite my story ?

Thanks !

If you open the HTML file in a text editor then you should be able to look at the source to see what story format and what version of that format that you used.

Anyways, we’d likely need to have access to the HTML file in order to see what’s going on here. However, it looks like there’s something wrong with your installation of Twine v1.

Side note: “around 2013” isn’t “1 years ago”, so I’m a little confused about the contradiction between your subject line and the text within your post. I’m guessing you meant to write “8 years ago”, correct?

Twine 1, years ago.

Thanks for your answers !

Yes, I forgot the comma so the title was confusing :slight_smile:
Here is a link to the html file : Dropbox - Le Chateau.html - Simplify your life
(my story is written in french)

So when I open the file it seems that it was built in 2014, with sugarcane I guess ?
I installed Twine 1.4.2 on another computer and I have the same error when I try to test play.

OK, there were a whole bunch of little things which interfered with each other (such as StorySetting ROT13 being on + non-English characters), making the conversion difficult, so rather than explain how to untangle that mess I just did it for you.

You can grab the version converted to use Twine 2 / SugarCube 2 from here. Make sure you have the latest version of SugarCube installed in Twine 2 and then just import that HTML file to be able to edit it again.

Enjoy! :slight_smile:

1 Like

Oh, thanks a lot for your time, it’s so kind ! Yes, I remember there was conflicts with some characters like â, é, etc…Now it works fine.
Maybe I’ll finally publish this story ! Thanks again