Can't log into bug Jira

I found a bug between Inform 7 (working) and Inform 10 (not working to run the same file). It seems to hand up on Easy Doors by Hanon Ondricek. The error is shown below.

Problem. An internal error has occurred: inter error. The current sentence is ‘An easydoor is usually openable’ ; the error was detected at line 272 of “inter/building-module/Chapter 3/Produce.w”. This should never happen, and I am now halting in abject failure.

What has happened here is that one of the checks Inform carries out internally, to see if it is working properly, has failed. There must be a bug in this copy of Inform. It may be worth checking whether you have the current, up-to-date version. If so, please report this problem via Bugs | Inform 7.

As for fixing your source text to avoid this bug, the last thing you changed is probably the cause, if there is a simple cause. Your source text might in fact be wrong, and the problem might be occurring because Inform has failed to find a good way to say so. But even if your source text looks correct, there are probably rephrasings which would achieve the same effect.

When I try to report this to the Jira bug database, it does not send my email address for verification.
P.S. I have run Inform 10 successsfully on small items since download, but the first time I ran my larger file, using the Extension Open Doors, it popped out this error.

1 Like

I’ve heard lots of people complain about Jira, unfortunately – not sure if this is an issue or just the thing running slow.

I did just try compiling a game with Easy Doors (v 3.2) included and didn’t get this error, so I don’t think the extension is at fault – hopefully wiser heads might have some clue about what the issue might be.

2 Likes

I get the same error, which seems to be due to a line in that version of Easy Doors (3/160425), just before the cited “current sentence”, although I don’t know what the underlying cause is.

In fact, a similar error can be produced in Inform 10 without Easy Doors, just by this source:

The Lab is a room.

The widget is a thing in the lab.
The widget can be unopenable.

[this doesn't work, either:
The widget can be unopenable or openable.]

[whereas this works: 
The widget can be openable or unopenable.]

The momentary fix is to install the newest version of Easy Doors (3.2), which works, as Mike notes. The difference between the versions is that the line “An easydoor can be unopenable or openable.” was changed to “An easydoor can be openable or unopenable.”.

5 Likes