Can't load locale in Twine web standalone version (


I’ve recently noticed that in web version of Twine I can use in-browser search to find stuff in the passage, which is great, and would save me a lot of hassle (so far I was using desktop app and switching back and forth from n++).

I wanted to use web version, but there was a problem with paths to images (I use a lot of media files), so I decided to go with standalone web version. The problem is - when I run it on my desktop computer everything seems to work fine, but I can’t see any descriptions or titles of the buttons in Twine ui, instead I just see language vars. The only dropdown I can see proper strings in, is the language change dropdown in the options. And I can see it’s set to English as default, and I can set it to something else, but it doesn’t fix anything.

I’m using Windows 11 Home x64, Polish. The system is also pretty fresh, I’ve installed it couple days ago from scratch (clean install, not an upgrade), so no strange settings or browsers (I use latest Edge on Chromium).

Any ideas how to fix it?

If it is something to do with the Polish locale on your PC, you can try creating a new user account and setting it to the English (US) locale.

If that works, you can run the app from your regular account as the new user.

Instead of logging into the new account, you can right click on the app and click “Run as different user”. I don’t think that will mess with the image paths, but it might.

Edit: this is assuming Windows 11 has user specific and not system-wide locales. I think it does, but again I am not quite sure. A bit of Googling also turned up this locale emulator.

I’ve tried copying en_EN locale and changing it to pl_PL but it didn’t help. I’ve also tried switching my user account to EN but it also didn’t worked.

I cannot at the moment create a new user with strictly EN locale, but honestly I don’t think it will help…

I will look at this app you mention when I have a moment.

What you’re seeing is just the result of trying to run a web app locally without a server: the browser prevents local files from retrieving other local files for security reasons.

You’d need to run a local web server like XAMPP, and have that serve up the Twine application. But I’m not sure whether that would make your image issues return.

That’s what I thought:( Ok, thanks for the info anyway!

The fact that currently the web-browser based release of the Twine 2.x application can’t be used locally without a web-server should be reported as a bug, because it was possible to do so with previous versions of that release.

1 Like