Can I use Inform 7 with Wordpress? If so how?



This link loads the js file (as text… browser does not know what to do with it).

It is in the same folder, with same permissions on the individual files. That is why I am thinking it might be a port issue. Something with .z5 files is different. Maybe it is the fact it is associated locally with Frotz. But that shouldn’t matter when using Parchment to load it. Unless it is trying to load it through a port other than port 80.

And it loads the .js if I use the Parchment html file on my server. But not the straight .z5 file. Shouldn’t Parchment load both .js and .z5 version? So that is why I keep thinking it is a port issue. Java script loads through port 80.

And won’t load either type. I am using this code:

<iframe src="; options=%7B%22width%22%3A60%7D" width="100%" height="600"></iframe>

I have tried it with and without the .js at the end of the file name, and with and without the width=“100%” height=“600” which should just effect the iframe window size.

And I have tried other files, not just Curses. With the same results.

If I use the included (in Parchment download) .html file to load the .js it works fine. I just can’t re-size it to fit the iframe window. That is why I was hoping the was a way to add the re-size option to the…

…line in the .html file.

I am baffled. Try this and let me know if it works for you:

This is a direct link to the .html file that loads “stories/curses.z5.js” from my server.

It does load for me… locally, and on other computers I have tried. Well, I admit, I have only tried it on one non-local computer, but it worked.

The problem is that your domain is using frames to redirect to where your actual website is hosted. Either stop using those frames, or use the real URL: … rses.z5.js

I’d really recommend setting your DNS settings properly rather than using frames.

Your web server (IIS) won’t serve up files of an unknown type like .z5 unless you configure it to.

If you’re running your own server, you’ll need to add a new file extension to IIS, picking the type from the list of IF MIME types.

Otherwise you’ll have to ask your hosting provider to do it for you.

I thought for sure I had tried using the literal IP instead of the redirect name… but maybe it was in combination with other things that kept it from working. Maybe it was with the .z5 and like bcressey mentioned, IIS was dumb and didn’t know what to do.

Damn GoDaddy redirects.

But it works like this. Thanks!

And I will add the mime settings to IIS and see what happens. Server is in the other room… not a long walk. :slight_smile:

Okay… using both fixes and now everything works. Z-files and J-Script files. Thanks to both of you.

Just one more question…

It only re-sizes when I use as the “player” and not when I use my own hosted version. What do I have to change in the index.html file to allow re-sizing? I tried changing (in several ways, and even deleting this line):

And that didn’t help. I know… I should just be happy that I can play it through and get the results I want. But I am the annoying type that likes to know the ‘whys’ about things.

I promise to shut up after this. :wink:

Your local version is probably old. The changes for resizing it came after the last inform 7 release.

I am using the most recent quixe version from on the website with the most recent files updated as of April 13, 2011.

Use the master branch instead.

That works. Does it still have the improved quixe support?

For now, I have 2 Parchment directories, one for WP (master branch) and one for “normal” use (quixe branch). If I replace the quixe version with the master branch (I see it has been recently updated) will I lose the quixe improvements?

I had problems with the quixe status bar showing in the previous master branch version… that is why I am using the quixe branch for general use.

The master branch uses the original Quixe. The code for changing the width is currently Z-Code only though so that doesn’t matter. Quixe (from the quixe branch) may or may not resize itself correctly in an iframe, I’m not sure.

Of course the best thing would be to merge the quixe branch back to master, but I need more people testing it. Have you found any bugs with it?

As it stands now, the Quixe branch version does not re-size in the iframe. At least not for me.

But other than that, I have had no problems with it. I use it daily for my own project testing and a few friends have played entire games on it without a glitch. So no bugs to report. Just a big thank you for giving us a great web interpreter to use.

Quixe is intended to always resize itself to its container, whether that’s a div in a window or an iframe. I haven’t tested the version that’s integrated with Parchment, however.