Build Web Page Package


When I build the web page package, I get the following output:

Tip: you can go to the source location of a compile error
by double-clicking on the error message in this window

----- begin build: Fri Sep 25 19:26:29 2020 -----

t3make -Fy “C:\Users\Mike\AppData\Local\Temp\tad2886.tmp” -Fo …
t3res -create “C:\IF\Chaos\Chaos–Web.3r0” -add

zip “C:\IF\Chaos\Chaos –” “C:\IF\Chaos\Chaos–Web.t3” “readme.txt”
. adding Chaos–Web.t3
. adding readme.txt
t3make “-f” “C:\Program Files (x86)\TADS 3\mkwebfiles\mkweb.t3m”
TADS Compiler 3.1.3 Copyright 1999, 2012 Michael J. Roberts

t3run “-plain” “-s0” “-d” “C:\IF\Chaos” “C:\Program Files (x86)\TADS 3\mkwebfiles\mkweb” “tadsver=3” “out=C:\IF\Chaos\web” “info=GameInfo.txt” “zipfile=C:\IF\Chaos\Chaos –” “coverart=webuires\EdgeOfChaos04.jpg”

open: error code 3

rmdir /s “C:\Users\Mike\AppData\Local\Temp\tad2886.tmp”

I changed mkweb to create index.html instead of index.htm since that’s what the IF Comp requires. But where does the index.htm command get called from? It’s not a huge deal, but it would be nice for it to point to the file I created and not the default .htm version.

Thanks for any assistance!
– Mike

Sorry, I don’t myself know anything about using TADS on the web (yet), I just know that several months ago there was a conversation on here about a lot of TADS/web issues. Those guys (or gals) seemed to know what they were talking about, so I don’t know if they’ve seen your post or if you could possibly try to PM them?

Thanks, John.

Note that this is not really a web issue, it’s really a build issue. When the build is kicked off it runs t3make, t3res, zip, t3run, etc… it then tries to launch the index.htm file. Since I’ve renamed that file, it can’t find it.

I’m just trying to understand where – if at all – I can change it to the new file name. Not an urgent issue since it’s really cosmetic at this point.

– Mike

The comp site should allow for .htm files too. I’ll raise a ticket.

1 Like

Oh, thanks for that! I didn’t consider this an option, so I appreciate the assist!

– Mike